summaryrefslogtreecommitdiffstats
path: root/php-pecl-runkit7.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-07 13:54:29 +0200
committerRemi Collet <remi@remirepo.net>2019-06-07 13:54:29 +0200
commit2809da7279e7a0c144a471f6b8c9d6f98f70f703 (patch)
tree514906e638b4cbefb0da6e2e581b1a036bded79b /php-pecl-runkit7.spec
parentea237a40ade4baa12c684d5a539c9def07ca644e (diff)
- update to 3.0.0RC1
- extension renamed from runkit to runkit7
Diffstat (limited to 'php-pecl-runkit7.spec')
-rw-r--r--php-pecl-runkit7.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/php-pecl-runkit7.spec b/php-pecl-runkit7.spec
index 2d5c3e1..f90c1a7 100644
--- a/php-pecl-runkit7.spec
+++ b/php-pecl-runkit7.spec
@@ -15,13 +15,13 @@
# The project is runkit7 but the extension is only runkit
%global proj_name runkit7
-%global pecl_name runkit
+%global pecl_name runkit7
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.1.0
-#global upstream_prever RC1
+%global upstream_version 3.0.0
+%global upstream_prever RC1
Name: %{?sub_prefix}php-pecl-%{proj_name}
Summary: For all those things you... shouldn't have been doing anyway... but surely do!
@@ -30,7 +30,7 @@ Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_
License: BSD
URL: https://pecl.php.net/package/%{proj_name}
-Source0: https://pecl.php.net/get/%{proj_name}-%{version}.tgz
+Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.1
@@ -95,7 +95,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-extver=$(sed -n '/#define PHP_RUNKIT_VERSION/{s/.*\t"//;s/".*$//;p}' runkit.h)
+extver=$(sed -n '/#define PHP_RUNKIT7_VERSION/{s/.*\t"//;s/".*$//;p}' runkit.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
: Error: Upstream RUNKIT version is now ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:dev}.
: Update the pdover macro and rebuild.
@@ -124,7 +124,7 @@ cp -pr NTS ZTS
peclconf() {
%configure \
- --enable-runkit \
+ --enable-runkit7 \
--with-libdir=%{_lib} \
--with-php-config=$1
}
@@ -235,6 +235,10 @@ fi
%endif
%changelog
+* Fri Jun 7 2019 Remi Collet <remi@remirepo.net> - 3.0.0~RC1-1
+- update to 3.0.0RC1
+- extension renamed from runkit to runkit7
+
* Wed May 29 2019 Remi Collet <remi@remirepo.net> - 2.1.0-1
- update to 2.1.0