summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-08-16 07:52:56 +0200
committerRemi Collet <remi@php.net>2022-08-16 07:52:56 +0200
commitaa810b55a0063da68d42be180cc5f95d6310a24a (patch)
tree22a643a0d1537a0e6aa8665b7393a27336e28fab
parentce9f3fa538552abbac78917c4a5284506e123651 (diff)
update to 4.0.0a6
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION102
-rw-r--r--php-pecl-runkit7.spec23
3 files changed, 63 insertions, 64 deletions
diff --git a/PHPINFO b/PHPINFO
index e22efd9..80f5923 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
runkit7
runkit7 support => enabled
-version => 4.0.0a3
+version => 4.0.0a6
Custom Superglobal support => enabled
Runtime Manipulation => enabled
diff --git a/REFLECTION b/REFLECTION
index f089348..1577175 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
+Extension [ <persistent> extension #119 runkit7 version 4.0.0a6 ] {
- INI {
Entry [ runkit.superglobal <PERDIR,SYSTEM> ]
@@ -60,11 +60,11 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [7] {
Parameter #0 [ <required> string $function_name ]
Parameter #1 [ <required> $argument_list_or_closure ]
- Parameter #2 [ <optional> string or NULL $code_or_doc_comment ]
- Parameter #3 [ <optional> bool or NULL $return_by_reference ]
- Parameter #4 [ <optional> string or NULL $doc_comment ]
- Parameter #5 [ <optional> string or NULL $return_type ]
- Parameter #6 [ <optional> bool or NULL $is_strict ]
+ Parameter #2 [ <optional> ?string $code_or_doc_comment = null ]
+ Parameter #3 [ <optional> ?bool $return_by_reference = null ]
+ Parameter #4 [ <optional> ?string $doc_comment = null ]
+ Parameter #5 [ <optional> ?string $return_type = null ]
+ Parameter #6 [ <optional> ?bool $is_strict = null ]
}
- Return [ bool ]
}
@@ -73,11 +73,11 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [7] {
Parameter #0 [ <required> string $function_name ]
Parameter #1 [ <required> $argument_list_or_closure ]
- Parameter #2 [ <optional> string or NULL $code_or_doc_comment ]
- Parameter #3 [ <optional> bool or NULL $return_by_reference ]
- Parameter #4 [ <optional> string or NULL $doc_comment ]
- Parameter #5 [ <optional> string or NULL $return_type ]
- Parameter #6 [ <optional> bool or NULL $is_strict ]
+ Parameter #2 [ <optional> ?string $code_or_doc_comment = null ]
+ Parameter #3 [ <optional> ?bool $return_by_reference = null ]
+ Parameter #4 [ <optional> ?string $doc_comment = null ]
+ Parameter #5 [ <optional> ?string $return_type = null ]
+ Parameter #6 [ <optional> ?bool $is_strict = null ]
}
- Return [ bool ]
}
@@ -116,11 +116,11 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [7] {
Parameter #0 [ <required> string $function_name ]
Parameter #1 [ <required> $argument_list_or_closure ]
- Parameter #2 [ <optional> string or NULL $code_or_doc_comment ]
- Parameter #3 [ <optional> bool or NULL $return_by_reference ]
- Parameter #4 [ <optional> string or NULL $doc_comment ]
- Parameter #5 [ <optional> string or NULL $return_type ]
- Parameter #6 [ <optional> bool or NULL $is_strict ]
+ Parameter #2 [ <optional> ?string $code_or_doc_comment = null ]
+ Parameter #3 [ <optional> ?bool $return_by_reference = null ]
+ Parameter #4 [ <optional> ?string $doc_comment = null ]
+ Parameter #5 [ <optional> ?string $return_type = null ]
+ Parameter #6 [ <optional> ?bool $is_strict = null ]
}
- Return [ bool ]
}
@@ -129,11 +129,11 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [7] {
Parameter #0 [ <required> string $function_name ]
Parameter #1 [ <required> $argument_list_or_closure ]
- Parameter #2 [ <optional> string or NULL $code_or_doc_comment ]
- Parameter #3 [ <optional> bool or NULL $return_by_reference ]
- Parameter #4 [ <optional> string or NULL $doc_comment ]
- Parameter #5 [ <optional> string or NULL $return_type ]
- Parameter #6 [ <optional> bool or NULL $is_strict ]
+ Parameter #2 [ <optional> ?string $code_or_doc_comment = null ]
+ Parameter #3 [ <optional> ?bool $return_by_reference = null ]
+ Parameter #4 [ <optional> ?string $doc_comment = null ]
+ Parameter #5 [ <optional> ?string $return_type = null ]
+ Parameter #6 [ <optional> ?bool $is_strict = null ]
}
- Return [ bool ]
}
@@ -159,11 +159,11 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
Parameter #0 [ <required> string $class_name ]
Parameter #1 [ <required> string $method_name ]
Parameter #2 [ <required> $argument_list_or_closure ]
- Parameter #3 [ <optional> $code_or_flags ]
- Parameter #4 [ <optional> $flags_or_doc_comment ]
- Parameter #5 [ <optional> string or NULL $doc_comment ]
- Parameter #6 [ <optional> string or NULL $return_type ]
- Parameter #7 [ <optional> bool or NULL $is_strict ]
+ Parameter #3 [ <optional> $code_or_flags = null ]
+ Parameter #4 [ <optional> $flags_or_doc_comment = null ]
+ Parameter #5 [ <optional> ?string $doc_comment = null ]
+ Parameter #6 [ <optional> ?string $return_type = null ]
+ Parameter #7 [ <optional> ?bool $is_strict = null ]
}
- Return [ bool ]
}
@@ -173,11 +173,11 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
Parameter #0 [ <required> string $class_name ]
Parameter #1 [ <required> string $method_name ]
Parameter #2 [ <required> $argument_list_or_closure ]
- Parameter #3 [ <optional> $code_or_flags ]
- Parameter #4 [ <optional> $flags_or_doc_comment ]
- Parameter #5 [ <optional> string or NULL $doc_comment ]
- Parameter #6 [ <optional> string or NULL $return_type ]
- Parameter #7 [ <optional> bool or NULL $is_strict ]
+ Parameter #3 [ <optional> $code_or_flags = null ]
+ Parameter #4 [ <optional> $flags_or_doc_comment = null ]
+ Parameter #5 [ <optional> ?string $doc_comment = null ]
+ Parameter #6 [ <optional> ?string $return_type = null ]
+ Parameter #7 [ <optional> ?bool $is_strict = null ]
}
- Return [ bool ]
}
@@ -187,11 +187,11 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
Parameter #0 [ <required> string $class_name ]
Parameter #1 [ <required> string $method_name ]
Parameter #2 [ <required> $argument_list_or_closure ]
- Parameter #3 [ <optional> $code_or_flags ]
- Parameter #4 [ <optional> $flags_or_doc_comment ]
- Parameter #5 [ <optional> string or NULL $doc_comment ]
- Parameter #6 [ <optional> string or NULL $return_type ]
- Parameter #7 [ <optional> bool or NULL $is_strict ]
+ Parameter #3 [ <optional> $code_or_flags = null ]
+ Parameter #4 [ <optional> $flags_or_doc_comment = null ]
+ Parameter #5 [ <optional> ?string $doc_comment = null ]
+ Parameter #6 [ <optional> ?string $return_type = null ]
+ Parameter #7 [ <optional> ?bool $is_strict = null ]
}
- Return [ bool ]
}
@@ -201,11 +201,11 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
Parameter #0 [ <required> string $class_name ]
Parameter #1 [ <required> string $method_name ]
Parameter #2 [ <required> $argument_list_or_closure ]
- Parameter #3 [ <optional> $code_or_flags ]
- Parameter #4 [ <optional> $flags_or_doc_comment ]
- Parameter #5 [ <optional> string or NULL $doc_comment ]
- Parameter #6 [ <optional> string or NULL $return_type ]
- Parameter #7 [ <optional> bool or NULL $is_strict ]
+ Parameter #3 [ <optional> $code_or_flags = null ]
+ Parameter #4 [ <optional> $flags_or_doc_comment = null ]
+ Parameter #5 [ <optional> ?string $doc_comment = null ]
+ Parameter #6 [ <optional> ?string $return_type = null ]
+ Parameter #7 [ <optional> ?bool $is_strict = null ]
}
- Return [ bool ]
}
@@ -230,7 +230,7 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [3] {
Parameter #0 [ <required> string $class_name ]
Parameter #1 [ <required> string $source_method_name ]
- Parameter #2 [ <required> string $source_target_name ]
+ Parameter #2 [ <required> string $target_method_name ]
}
- Return [ bool ]
}
@@ -239,7 +239,7 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [3] {
Parameter #0 [ <required> string $class_name ]
Parameter #1 [ <required> string $source_method_name ]
- Parameter #2 [ <required> string $source_target_name ]
+ Parameter #2 [ <required> string $target_method_name ]
}
- Return [ bool ]
}
@@ -247,9 +247,9 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [4] {
Parameter #0 [ <required> string $destination_class ]
- Parameter #1 [ <required> string $destination_method ]
+ Parameter #1 [ <required> string $destination_method_name ]
Parameter #2 [ <required> string $source_class ]
- Parameter #3 [ <optional> string or NULL $source_method ]
+ Parameter #3 [ <optional> ?string $source_method_name = null ]
}
- Return [ bool ]
}
@@ -257,9 +257,9 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [4] {
Parameter #0 [ <required> string $destination_class ]
- Parameter #1 [ <required> string $destination_method ]
+ Parameter #1 [ <required> string $destination_method_name ]
Parameter #2 [ <required> string $source_class ]
- Parameter #3 [ <optional> string or NULL $source_method ]
+ Parameter #3 [ <optional> ?string $source_method_name = null ]
}
- Return [ bool ]
}
@@ -268,7 +268,7 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [3] {
Parameter #0 [ <required> string $constant_name ]
Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> int or NULL $new_visibility ]
+ Parameter #2 [ <optional> ?int $new_visibility = null ]
}
- Return [ bool ]
}
@@ -277,7 +277,7 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [3] {
Parameter #0 [ <required> string $constant_name ]
Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> int or NULL $new_visibility ]
+ Parameter #2 [ <optional> ?int $new_visibility = null ]
}
- Return [ bool ]
}
@@ -300,7 +300,7 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [3] {
Parameter #0 [ <required> string $constant_name ]
Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> int or NULL $new_visibility ]
+ Parameter #2 [ <optional> ?int $new_visibility = RUNKIT7_ACC_PUBLIC ]
}
- Return [ bool ]
}
@@ -309,7 +309,7 @@ Extension [ <persistent> extension #122 runkit7 version 4.0.0a3 ] {
- Parameters [3] {
Parameter #0 [ <required> string $constant_name ]
Parameter #1 [ <required> $value ]
- Parameter #2 [ <optional> int $new_visibility ]
+ Parameter #2 [ <optional> int $new_visibility = RUNKIT7_ACC_PUBLIC ]
}
- Return [ bool ]
}
diff --git a/php-pecl-runkit7.spec b/php-pecl-runkit7.spec
index 1773f00..6d3ac4a 100644
--- a/php-pecl-runkit7.spec
+++ b/php-pecl-runkit7.spec
@@ -1,32 +1,32 @@
# remirepo spec file for php-pecl-runkit7
#
-# Copyright (c) 2019-2021 Remi Collet
+# Copyright (c) 2019-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-runkit7
%else
%global _root_prefix %{_prefix}
%endif
+%bcond_without tests
+
# The project is runkit7 but the extension is only runkit
%global proj_name runkit7
%global pecl_name runkit7
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global with_tests 0%{!?_without_tests:1}
%global upstream_version 4.0.0
-%global upstream_prever a3
+%global upstream_prever a6
-Name: %{?sub_prefix}php-pecl-%{proj_name}
+Name: %{?scl_prefix}php-pecl-%{proj_name}
Summary: For all those things you... shouldn't have been doing anyway... but surely do!
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{proj_name}
@@ -45,10 +45,6 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
Provides: %{?scl_prefix}php-pecl(%{proj_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{proj_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
-%endif
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
@@ -165,7 +161,7 @@ export REPORT_EXIT_STATUS=1
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
-%if %{with_tests}
+%if %{with tests}
# ignore FPM tests because of systemd monitoring changing output
rm ?TS/tests/runkit_fpm*
@@ -183,7 +179,7 @@ TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
-%if %{with_tests}
+%if %{with tests}
: Upstream test suite ZTS extension
cd ../ZTS
TEST_PHP_EXECUTABLE=%{__ztsphp} \
@@ -226,6 +222,9 @@ fi
%endif
%changelog
+* Tue Aug 16 2022 Remi Collet <remi@remirepo.net> - 4.0.0~a6-1
+- update to 4.0.0a6
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 4.0.0~a3-2
- rebuild for 8.1.0RC1