summaryrefslogtreecommitdiffstats
path: root/php-pecl-rrd.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-rrd.spec')
-rw-r--r--php-pecl-rrd.spec16
1 files changed, 12 insertions, 4 deletions
diff --git a/php-pecl-rrd.spec b/php-pecl-rrd.spec
index ce3207b..b208560 100644
--- a/php-pecl-rrd.spec
+++ b/php-pecl-rrd.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-rrd
#
-# Copyright (c) 2011-2023 Remi Collet
+# Copyright (c) 2011-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -24,12 +24,14 @@
Summary: PHP Bindings for rrdtool
Name: %{?scl_prefix}php-pecl-rrd
Version: 2.0.3
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 12%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD-2-Clause
URL: https://pecl.php.net/package/rrd
Source: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Patch0: %{pecl_name}-build.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -68,6 +70,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
+%patch -P0 -p1
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_RRD_VERSION/{s/.* "//;s/".*$//;p}' php_rrd.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -130,12 +134,12 @@ done
%if %{with_zts}
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%endif
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if %{with tests}
cd %{sources}
@@ -198,6 +202,10 @@ fi
%changelog
+* Mon Jan 29 2024 Remi Collet <remi@remirepo.net> - 2.0.3-12
+- fix incompatible pointer types using patch from
+ https://github.com/php/pecl-processing-rrd/pull/4
+
* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 2.0.3-4
- rebuild for PHP 8.3.0RC1