summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-28 13:33:10 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-28 13:33:10 +0100
commite9609bda4b53909a4caeac0ed09356b8df6bda99 (patch)
tree80b007bbe2ac7abec7c18089ddc65bb0ecacfaf1
parentf5972759eefce76ae119942ccdcfb8550e42329f (diff)
php-pecl-rrd: 2.0.0 (php 7, stable)
-rw-r--r--REFLECTION-PHP7200
-rw-r--r--php-pecl-rrd-php7.spec (renamed from php-pecl-rrd-dev.spec)17
2 files changed, 206 insertions, 11 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
new file mode 100644
index 0000000..b682c03
--- /dev/null
+++ b/REFLECTION-PHP7
@@ -0,0 +1,200 @@
+Extension [ <persistent> extension #58 rrd version 2.0.0 ] {
+
+ - Functions {
+ Function [ <internal:rrd> function rrd_update ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $file ]
+ Parameter #1 [ <required> $options ]
+ }
+ }
+ Function [ <internal:rrd> function rrd_create ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $options ]
+ }
+ }
+ Function [ <internal:rrd> function rrd_graph ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $file ]
+ Parameter #1 [ <required> $options ]
+ }
+ }
+ Function [ <internal:rrd> function rrd_error ] {
+ }
+ Function [ <internal:rrd> function rrd_fetch ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $file ]
+ Parameter #1 [ <required> $options ]
+ }
+ }
+ Function [ <internal:rrd> function rrd_first ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $file ]
+ Parameter #1 [ <optional> $raaindex ]
+ }
+ }
+ Function [ <internal:rrd> function rrd_info ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $file ]
+ }
+ }
+ Function [ <internal:rrd> function rrd_last ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $file ]
+ }
+ }
+ Function [ <internal:rrd> function rrd_lastupdate ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $file ]
+ }
+ }
+ Function [ <internal:rrd> function rrd_restore ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $xml_file ]
+ Parameter #1 [ <required> $rrd_file ]
+ Parameter #2 [ <optional> $options ]
+ }
+ }
+ Function [ <internal:rrd> function rrd_tune ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $file ]
+ Parameter #1 [ <required> $options ]
+ }
+ }
+ Function [ <internal:rrd> function rrd_xport ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $options ]
+ }
+ }
+ Function [ <internal:rrd> function rrdc_disconnect ] {
+ }
+ Function [ <internal:rrd> function rrd_version ] {
+ }
+ }
+
+ - Classes [3] {
+ Class [ <internal:rrd> class RRDGraph ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:rrd, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $path ]
+ }
+ }
+
+ Method [ <internal:rrd> public method save ] {
+ }
+
+ Method [ <internal:rrd> public method saveVerbose ] {
+ }
+
+ Method [ <internal:rrd> public method setOptions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $options ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:rrd> class RRDCreator ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:rrd, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $path ]
+ Parameter #1 [ <optional> $startTime ]
+ Parameter #2 [ <optional> $step ]
+ }
+ }
+
+ Method [ <internal:rrd> public method save ] {
+ }
+
+ Method [ <internal:rrd> public method addDataSource ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $description ]
+ }
+ }
+
+ Method [ <internal:rrd> public method addArchive ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $description ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:rrd> class RRDUpdater ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:rrd, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $path ]
+ }
+ }
+
+ Method [ <internal:rrd> public method update ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $values ]
+ Parameter #1 [ <optional> $time ]
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-rrd-dev.spec b/php-pecl-rrd-php7.spec
index ceec37c..ffb8dd6 100644
--- a/php-pecl-rrd-dev.spec
+++ b/php-pecl-rrd-php7.spec
@@ -14,19 +14,15 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name rrd
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
-%global prever beta3
+#global prever beta3
Summary: PHP Bindings for rrdtool
Name: %{?scl_prefix}php-pecl-rrd
Version: 2.0.0
-Release: 0.7.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/rrd
@@ -55,14 +51,10 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.0"
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
@@ -220,6 +212,9 @@ fi
%changelog
+* Mon Dec 28 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0
+
* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.7.beta3
- rebuild for PHP 7.0.0RC5 new API version