summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-19 08:19:44 +0200
committerRemi Collet <remi@remirepo.net>2021-04-19 08:19:44 +0200
commit647c7b583eb29b238d37b035eb70d4a4d212ee1d (patch)
tree306ed1aa62afa78b42a8d7549abbecff1250d129
parent02e454398ffbc1699b4ce4cf15bd4e90ec87735f (diff)
update to 2.0.2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION20
-rw-r--r--php-pecl-rrd.spec23
-rw-r--r--rrd-php8.patch213
4 files changed, 28 insertions, 230 deletions
diff --git a/PHPINFO b/PHPINFO
index 16fc5b2..efdf81c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
rrd
rrd tool module => enabled
-rrd tool module version => 2.0.1
+rrd tool module version => 2.0.2
rrdtool library version => 1.7.2
diff --git a/REFLECTION b/REFLECTION
index f4776f5..53c5b48 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 rrd version 2.0.1 ] {
+Extension [ <persistent> extension #120 rrd version 2.0.2 ] {
- Functions {
Function [ <internal:rrd> function rrd_update ] {
@@ -23,6 +23,9 @@ Extension [ <persistent> extension #117 rrd version 2.0.1 ] {
}
}
Function [ <internal:rrd> function rrd_error ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:rrd> function rrd_fetch ] {
@@ -78,8 +81,14 @@ Extension [ <persistent> extension #117 rrd version 2.0.1 ] {
}
}
Function [ <internal:rrd> function rrdc_disconnect ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:rrd> function rrd_version ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -107,9 +116,15 @@ Extension [ <persistent> extension #117 rrd version 2.0.1 ] {
}
Method [ <internal:rrd> public method save ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:rrd> public method saveVerbose ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:rrd> public method setOptions ] {
@@ -146,6 +161,9 @@ Extension [ <persistent> extension #117 rrd version 2.0.1 ] {
}
Method [ <internal:rrd> public method save ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:rrd> public method addDataSource ] {
diff --git a/php-pecl-rrd.spec b/php-pecl-rrd.spec
index 4161816..a8bf072 100644
--- a/php-pecl-rrd.spec
+++ b/php-pecl-rrd.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-rrd
#
-# Copyright (c) 2011-2020 Remi Collet
+# Copyright (c) 2011-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -22,18 +22,16 @@
Summary: PHP Bindings for rrdtool
Name: %{?scl_prefix}php-pecl-rrd
-Version: 2.0.1
-Release: 9%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.0.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/rrd
Source: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-# https://svn.php.net/viewvc?view=revision&revision=350618
-Patch0: %{pecl_name}-php8.patch
-
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: rrdtool
BuildRequires: pkgconfig(librrd) >= 1.3.0
BuildRequires: %{?scl_prefix}php-pear
@@ -66,12 +64,6 @@ Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
Procedural and simple OO wrapper for rrdtool - data logging and graphing
@@ -91,8 +83,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p3 -b .up
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_RRD_VERSION/{s/.* "//;s/".*$//;p}' php_rrd.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -220,6 +210,9 @@ fi
%changelog
+* Mon Apr 19 2021 Remi Collet <remi@remirepo.net> - 2.0.2-1
+- update to 2.0.2
+
* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 2.0.1-9
- rebuild for PHP 8.0.0RC1
diff --git a/rrd-php8.patch b/rrd-php8.patch
deleted file mode 100644
index c5b48c4..0000000
--- a/rrd-php8.patch
+++ /dev/null
@@ -1,213 +0,0 @@
---- pecl/rrd/trunk/rrd.c 2020/09/23 07:41:40 350617
-+++ pecl/rrd/trunk/rrd.c 2020/09/23 09:09:08 350618
-@@ -552,6 +552,9 @@
- ZEND_ARG_INFO(0, file)
- ZEND_ARG_INFO(0, options)
- ZEND_END_ARG_INFO()
-+
-+ZEND_BEGIN_ARG_INFO(arginfo_rrd_void, 0)
-+ZEND_END_ARG_INFO()
- /* }}} */
-
- /* {{{ */
-@@ -559,7 +562,7 @@
- PHP_FE(rrd_update, arginfo_rrd_update)
- PHP_FE(rrd_create, arginfo_rrd_create)
- PHP_FE(rrd_graph, arginfo_rrd_graph)
-- PHP_FE(rrd_error, NULL)
-+ PHP_FE(rrd_error, arginfo_rrd_void)
- PHP_FE(rrd_fetch, arginfo_rrd_fetch)
- PHP_FE(rrd_first, arginfo_rrd_first)
- PHP_FE(rrd_info, arginfo_rrd_info)
-@@ -569,9 +572,9 @@
- PHP_FE(rrd_tune, arginfo_rrd_tune)
- PHP_FE(rrd_xport, arginfo_rrd_xport)
- #ifdef HAVE_RRDC_DISCONNECT
-- PHP_FE(rrdc_disconnect, NULL)
-+ PHP_FE(rrdc_disconnect, arginfo_rrd_void)
- #endif
-- PHP_FE(rrd_version, NULL)
-+ PHP_FE(rrd_version, arginfo_rrd_void)
- PHP_FE_END
- };
- /* }}} */
---- pecl/rrd/trunk/rrd_create.c 2020/09/23 07:41:40 350617
-+++ pecl/rrd/trunk/rrd_create.c 2020/09/23 09:09:08 350618
-@@ -323,10 +323,13 @@
- ZEND_ARG_INFO(0, description)
- ZEND_END_ARG_INFO()
-
-+ZEND_BEGIN_ARG_INFO_EX(arginfo_rrdcreator_void, 0, 0, 0)
-+ZEND_END_ARG_INFO()
-+
- /* class method table */
- static zend_function_entry rrd_create_methods[] = {
- PHP_ME(RRDCreator, __construct, arginfo_rrdcreator_construct, ZEND_ACC_PUBLIC)
-- PHP_ME(RRDCreator, save, NULL, ZEND_ACC_PUBLIC)
-+ PHP_ME(RRDCreator, save, arginfo_rrdcreator_void, ZEND_ACC_PUBLIC)
- PHP_ME(RRDCreator, addDataSource, arginfo_rrdcreator_description, ZEND_ACC_PUBLIC)
- PHP_ME(RRDCreator, addArchive, arginfo_rrdcreator_description, ZEND_ACC_PUBLIC)
- PHP_FE_END
---- pecl/rrd/trunk/rrd_graph.c 2020/09/23 07:41:40 350617
-+++ pecl/rrd/trunk/rrd_graph.c 2020/09/23 09:09:08 350618
-@@ -140,6 +140,7 @@
- array_init(&zv_argv);
-
- ZEND_HASH_FOREACH_KEY_VAL(Z_ARRVAL(obj->zv_arr_options), num_key, zs_key, zv_option_val) {
-+ (void)num_key; /* to avoid -Wunused-but-set-variable */
- smart_string option = {0}; /* one argument option */
-
- /* option with string key means long option, hence they are used as
-@@ -356,6 +357,9 @@
- /* }}} */
-
- /* arguments */
-+ZEND_BEGIN_ARG_INFO_EX(arginfo_rrd_void, 0, 0, 0)
-+ZEND_END_ARG_INFO()
-+
- ZEND_BEGIN_ARG_INFO_EX(arginfo_rrd_path, 0, 0, 1)
- ZEND_ARG_INFO(0, path)
- ZEND_END_ARG_INFO()
-@@ -367,8 +371,8 @@
- /* class method table */
- static zend_function_entry rrd_graph_methods[] = {
- PHP_ME(RRDGraph, __construct, arginfo_rrd_path, ZEND_ACC_PUBLIC)
-- PHP_ME(RRDGraph, save, NULL, ZEND_ACC_PUBLIC)
-- PHP_ME(RRDGraph, saveVerbose, NULL, ZEND_ACC_PUBLIC)
-+ PHP_ME(RRDGraph, save, arginfo_rrd_void, ZEND_ACC_PUBLIC)
-+ PHP_ME(RRDGraph, saveVerbose, arginfo_rrd_void, ZEND_ACC_PUBLIC)
- PHP_ME(RRDGraph, setOptions, arginfo_rrd_options, ZEND_ACC_PUBLIC)
- PHP_FE_END
- };
---- pecl/rrd/trunk/tests/rrd_010.phpt 2020/09/23 07:41:40 350617
-+++ pecl/rrd/trunk/tests/rrd_010.phpt 2020/09/23 09:09:08 350618
-@@ -40,11 +40,11 @@
- [920805900]=>
- float(0)
- [920806200]=>
-- float(0.033333333333333)
-+ float(0.03333333333%s)
- [920806500]=>
-- float(0.033333333333333)
-+ float(0.03333333333%s)
- [920806800]=>
-- float(0.033333333333333)
-+ float(0.03333333333%s)
- [920807100]=>
- float(0.02)
- [920807400]=>
-@@ -52,20 +52,20 @@
- [920807700]=>
- float(0.02)
- [920808000]=>
-- float(0.013333333333333)
-+ float(0.01333333333%s)
- [920808300]=>
-- float(0.016666666666667)
-+ float(0.01666666666%s)
- }
- ["speed2"]=>
- array(13) {
- [920804700]=>
- float(NAN)
- [920805000]=>
-- float(0.056666666666667)
-+ float(0.05666666666%s)
- [920805300]=>
- float(0.02)
- [920805600]=>
-- float(0.0033333333333333)
-+ float(0.00333333333%s)
- [920805900]=>
- float(0)
- [920806200]=>
-@@ -73,7 +73,7 @@
- [920806500]=>
- float(0)
- [920806800]=>
-- float(0.066666666666667)
-+ float(0.06666666666%s)
- [920807100]=>
- float(0.02)
- [920807400]=>
-@@ -81,9 +81,9 @@
- [920807700]=>
- float(0.02)
- [920808000]=>
-- float(0.013333333333333)
-+ float(0.01333333333%s)
- [920808300]=>
-- float(0.016666666666667)
-+ float(0.01666666666%s)
- }
- }
--}
-\ No newline at end of file
-+}
---- pecl/rrd/trunk/tests/rrd_012.phpt 2020/09/23 07:41:40 350617
-+++ pecl/rrd/trunk/tests/rrd_012.phpt 2020/09/23 09:09:08 350618
-@@ -69,7 +69,7 @@
- ["rra[1].xff"]=>
- float(0.5)
- ["rra[1].cdp_prep[0].value"]=>
-- float(0.026666666666667)
-+ float(0.02666666666%s)
- ["rra[1].cdp_prep[0].unknown_datapoints"]=>
- int(0)
- }
---- pecl/rrd/trunk/tests/rrd_017.phpt 2020/09/23 07:41:40 350617
-+++ pecl/rrd/trunk/tests/rrd_017.phpt 2020/09/23 09:09:08 350618
-@@ -47,11 +47,11 @@
- [920805900]=>
- float(0)
- [920806200]=>
-- float(0.033333333333333)
-+ float(0.0333333333%s)
- [920806500]=>
-- float(0.033333333333333)
-+ float(0.0333333333%s)
- [920806800]=>
-- float(0.033333333333333)
-+ float(0.0333333333%s)
- [920807100]=>
- float(0.02)
- [920807400]=>
-@@ -59,9 +59,9 @@
- [920807700]=>
- float(0.02)
- [920808000]=>
-- float(0.013333333333333)
-+ float(0.0133333333%s)
- [920808300]=>
-- float(0.016666666666667)
-+ float(0.0166666666%s)
- }
- }
- [1]=>
-@@ -81,11 +81,11 @@
- [920805900]=>
- float(0)
- [920806200]=>
-- float(33.333333333333)
-+ float(33.333333333%s)
- [920806500]=>
-- float(33.333333333333)
-+ float(33.333333333%s)
- [920806800]=>
-- float(33.333333333333)
-+ float(33.333333333%s)
- [920807100]=>
- float(20)
- [920807400]=>
-@@ -93,9 +93,9 @@
- [920807700]=>
- float(20)
- [920808000]=>
-- float(13.333333333333)
-+ float(13.333333333%s)
- [920808300]=>
-- float(16.666666666667)
-+ float(16.666666666%s)
- }
- }
- }