summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-16 17:22:40 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-16 17:22:40 +0200
commit481c43240fa6bde073f14bb1da36828e1e38076e (patch)
treebe4ad68fa343cae6415e832af940e731e1096c56
parent2210ef3aebb06fefb8e0940dcebb0612d5b21978 (diff)
php-pecl: add numerical prefix to extension configuration file (more)
-rw-r--r--php-pecl-rrd.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-pecl-rrd.spec b/php-pecl-rrd.spec
index 19dfda5..3993d63 100644
--- a/php-pecl-rrd.spec
+++ b/php-pecl-rrd.spec
@@ -13,12 +13,17 @@
%global with_zts 0%{?__ztsphp:1}
%global pecl_name rrd
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: PHP Bindings for rrdtool
Name: %{?scl_prefix}php-pecl-rrd
Version: 1.1.3
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/rrd
@@ -72,7 +77,7 @@ system for time series data.
mv %{pecl_name}-%{version} NTS
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
EOF
@@ -101,14 +106,14 @@ rm -rf %{buildroot}
make install -C NTS INSTALL_ROOT=%{buildroot}
# Drop in the bit of configuration
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make install -C ZTS INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -171,17 +176,20 @@ fi
%defattr(-, root, root, -)
%doc %{pecl_docdir}/%{pecl_name}
%doc %{pecl_testdir}/%{pecl_name}
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 1.1.3-2
+- add numerical prefix to extension configuration file (php 5.6)
+
* Wed Jan 15 2014 Remi Collet <remi@fedoraproject.org> - 1.1.3-1
- Update to 1.1.3 (stable)