summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION50
-rw-r--r--php-pecl-rpminfo.spec19
3 files changed, 39 insertions, 36 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..f948460
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,6 @@
+
+rpminfo
+
+rpminfo support => enabled
+Extension version => 0.2.1
+RPM library version => 4.15.1
diff --git a/REFLECTION b/REFLECTION
index e67b4a3..98e6636 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,30 +1,30 @@
-Extension [ <persistent> extension #129 rpminfo version 0.2.1 ] {
+Extension [ <persistent> extension #136 rpminfo version 0.2.1 ] {
- Constants [24] {
- Constant [ string RPMVERSION ] { 4.14.1 }
- Constant [ integer RPMSENSE_ANY ] { 0 }
- Constant [ integer RPMSENSE_LESS ] { 2 }
- Constant [ integer RPMSENSE_GREATER ] { 4 }
- Constant [ integer RPMSENSE_EQUAL ] { 8 }
- Constant [ integer RPMSENSE_POSTTRANS ] { 32 }
- Constant [ integer RPMSENSE_PREREQ ] { 64 }
- Constant [ integer RPMSENSE_PRETRANS ] { 128 }
- Constant [ integer RPMSENSE_INTERP ] { 256 }
- Constant [ integer RPMSENSE_SCRIPT_PRE ] { 512 }
- Constant [ integer RPMSENSE_SCRIPT_POST ] { 1024 }
- Constant [ integer RPMSENSE_SCRIPT_PREUN ] { 2048 }
- Constant [ integer RPMSENSE_SCRIPT_POSTUN ] { 4096 }
- Constant [ integer RPMSENSE_SCRIPT_VERIFY ] { 8192 }
- Constant [ integer RPMSENSE_FIND_REQUIRES ] { 16384 }
- Constant [ integer RPMSENSE_FIND_PROVIDES ] { 32768 }
- Constant [ integer RPMSENSE_TRIGGERIN ] { 65536 }
- Constant [ integer RPMSENSE_TRIGGERUN ] { 131072 }
- Constant [ integer RPMSENSE_TRIGGERPOSTUN ] { 262144 }
- Constant [ integer RPMSENSE_MISSINGOK ] { 524288 }
- Constant [ integer RPMSENSE_RPMLIB ] { 16777216 }
- Constant [ integer RPMSENSE_TRIGGERPREIN ] { 33554432 }
- Constant [ integer RPMSENSE_KEYRING ] { 67108864 }
- Constant [ integer RPMSENSE_CONFIG ] { 268435456 }
+ Constant [ string RPMVERSION ] { 4.15.1 }
+ Constant [ int RPMSENSE_ANY ] { 0 }
+ Constant [ int RPMSENSE_LESS ] { 2 }
+ Constant [ int RPMSENSE_GREATER ] { 4 }
+ Constant [ int RPMSENSE_EQUAL ] { 8 }
+ Constant [ int RPMSENSE_POSTTRANS ] { 32 }
+ Constant [ int RPMSENSE_PREREQ ] { 64 }
+ Constant [ int RPMSENSE_PRETRANS ] { 128 }
+ Constant [ int RPMSENSE_INTERP ] { 256 }
+ Constant [ int RPMSENSE_SCRIPT_PRE ] { 512 }
+ Constant [ int RPMSENSE_SCRIPT_POST ] { 1024 }
+ Constant [ int RPMSENSE_SCRIPT_PREUN ] { 2048 }
+ Constant [ int RPMSENSE_SCRIPT_POSTUN ] { 4096 }
+ Constant [ int RPMSENSE_SCRIPT_VERIFY ] { 8192 }
+ Constant [ int RPMSENSE_FIND_REQUIRES ] { 16384 }
+ Constant [ int RPMSENSE_FIND_PROVIDES ] { 32768 }
+ Constant [ int RPMSENSE_TRIGGERIN ] { 65536 }
+ Constant [ int RPMSENSE_TRIGGERUN ] { 131072 }
+ Constant [ int RPMSENSE_TRIGGERPOSTUN ] { 262144 }
+ Constant [ int RPMSENSE_MISSINGOK ] { 524288 }
+ Constant [ int RPMSENSE_RPMLIB ] { 16777216 }
+ Constant [ int RPMSENSE_TRIGGERPREIN ] { 33554432 }
+ Constant [ int RPMSENSE_KEYRING ] { 67108864 }
+ Constant [ int RPMSENSE_CONFIG ] { 268435456 }
}
- Functions {
diff --git a/php-pecl-rpminfo.spec b/php-pecl-rpminfo.spec
index c6d9495..ce7f3aa 100644
--- a/php-pecl-rpminfo.spec
+++ b/php-pecl-rpminfo.spec
@@ -1,6 +1,6 @@
# spec file for php-pecl-rpminfo
#
-# Copyright (c) 2018-2019 Remi Collet
+# Copyright (c) 2018-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -22,11 +22,11 @@
Summary: RPM information
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.2.1
-Release: 5%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 0.2.2
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: rpm-devel >= 4.11.3
@@ -48,12 +48,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
@@ -230,6 +224,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Mar 11 2020 Remi Collet <remi@remirepo.net> - 0.2.2-1
+- update to 0.2.2
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.2.1-5
- rebuild for 7.4.0RC1