summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION10
-rw-r--r--php-pecl-rpminfo.spec9
3 files changed, 16 insertions, 5 deletions
diff --git a/PHPINFO b/PHPINFO
index 3d77e32..035cf29 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
rpminfo
rpminfo support => enabled
-Extension version => 1.0.1
+Extension version => 1.1.0
RPM library version => 4.18.1
RPM stream wrapper => yes
diff --git a/REFLECTION b/REFLECTION
index c627e11..2706a15 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #98 rpminfo version 1.0.1 ] {
+Extension [ <persistent> extension #99 rpminfo version 1.1.0 ] {
- Constants [278] {
Constant [ string RPMVERSION ] { 4.18.1 }
@@ -325,6 +325,14 @@ Extension [ <persistent> extension #98 rpminfo version 1.0.1 ] {
}
- Return [ int|bool ]
}
+ Function [ <internal:rpminfo> function rpmgetsymlink ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $path ]
+ Parameter #1 [ <required> string $name ]
+ }
+ - Return [ ?string ]
+ }
}
}
diff --git a/php-pecl-rpminfo.spec b/php-pecl-rpminfo.spec
index 2318183..2df4c20 100644
--- a/php-pecl-rpminfo.spec
+++ b/php-pecl-rpminfo.spec
@@ -19,7 +19,7 @@
Summary: RPM information
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.1
+Version: 1.1.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
@@ -171,7 +171,7 @@ TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php --show-diff %{?_smp_mflags}
%endif
%if %{with_zts}
@@ -186,7 +186,7 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php --show-diff %{?_smp_mflags}
%endif
%endif
@@ -206,6 +206,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Nov 10 2023 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
* Fri Oct 13 2023 Remi Collet <remi@remirepo.net> - 1.0.1-1
- update to 1.0.1