summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-12 16:44:00 +0100
committerRemi Collet <remi@remirepo.net>2018-02-12 16:44:00 +0100
commitf7f2ab94c3fbc68e6c6c7041b9dd498b1b9fae16 (patch)
tree30b6d100196e8314228ab8975cfd86e908fdcc14
parent1a2d8e249757dd1c5fb1233a76b004be838bdcff (diff)
v0.2.1
-rw-r--r--REFLECTION27
-rw-r--r--php-pecl-rpminfo.spec9
2 files changed, 33 insertions, 3 deletions
diff --git a/REFLECTION b/REFLECTION
index 94ccbb3..e67b4a3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,30 @@
-Extension [ <persistent> extension #129 rpminfo version 0.2.0 ] {
+Extension [ <persistent> extension #129 rpminfo version 0.2.1 ] {
- - Constants [1] {
+ - Constants [24] {
Constant [ string RPMVERSION ] { 4.14.1 }
+ Constant [ integer RPMSENSE_ANY ] { 0 }
+ Constant [ integer RPMSENSE_LESS ] { 2 }
+ Constant [ integer RPMSENSE_GREATER ] { 4 }
+ Constant [ integer RPMSENSE_EQUAL ] { 8 }
+ Constant [ integer RPMSENSE_POSTTRANS ] { 32 }
+ Constant [ integer RPMSENSE_PREREQ ] { 64 }
+ Constant [ integer RPMSENSE_PRETRANS ] { 128 }
+ Constant [ integer RPMSENSE_INTERP ] { 256 }
+ Constant [ integer RPMSENSE_SCRIPT_PRE ] { 512 }
+ Constant [ integer RPMSENSE_SCRIPT_POST ] { 1024 }
+ Constant [ integer RPMSENSE_SCRIPT_PREUN ] { 2048 }
+ Constant [ integer RPMSENSE_SCRIPT_POSTUN ] { 4096 }
+ Constant [ integer RPMSENSE_SCRIPT_VERIFY ] { 8192 }
+ Constant [ integer RPMSENSE_FIND_REQUIRES ] { 16384 }
+ Constant [ integer RPMSENSE_FIND_PROVIDES ] { 32768 }
+ Constant [ integer RPMSENSE_TRIGGERIN ] { 65536 }
+ Constant [ integer RPMSENSE_TRIGGERUN ] { 131072 }
+ Constant [ integer RPMSENSE_TRIGGERPOSTUN ] { 262144 }
+ Constant [ integer RPMSENSE_MISSINGOK ] { 524288 }
+ Constant [ integer RPMSENSE_RPMLIB ] { 16777216 }
+ Constant [ integer RPMSENSE_TRIGGERPREIN ] { 33554432 }
+ Constant [ integer RPMSENSE_KEYRING ] { 67108864 }
+ Constant [ integer RPMSENSE_CONFIG ] { 268435456 }
}
- Functions {
diff --git a/php-pecl-rpminfo.spec b/php-pecl-rpminfo.spec
index ea52991..5841cf9 100644
--- a/php-pecl-rpminfo.spec
+++ b/php-pecl-rpminfo.spec
@@ -6,6 +6,10 @@
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-pecl-rpminfo
@@ -18,7 +22,7 @@
Summary: RPM information
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.2.0
+Version: 0.2.1
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
@@ -217,6 +221,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Feb 12 2018 Remi Collet <remi@remirepo.net> - 0.2.1-1
+- update to 0.2.1 (beta)
+
* Thu Feb 8 2018 Remi Collet <remi@remirepo.net> - 0.2.0-1
- update to 0.2.0 (beta)