summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-09-03 15:26:48 +0200
committerRemi Collet <remi@php.net>2024-09-03 15:26:48 +0200
commitcd66dd48fbe1c7622fb4e896310c9e111fde66e3 (patch)
treefb7d3649f5c45b42dda36dfd02630f59dcc09704
parent703626e8ebc0ed85a81ebb8e5ac725123ee6b3e6 (diff)
update to 1.1.1
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION13
-rw-r--r--php-pecl-rpminfo.spec35
3 files changed, 23 insertions, 31 deletions
diff --git a/PHPINFO b/PHPINFO
index 035cf29..8008be9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,8 @@
rpminfo
rpminfo support => enabled
-Extension version => 1.1.0
-RPM library version => 4.18.1
+Extension version => 1.1.1
+Author => Remi Collet
+License => PHP-3.01
+RPM library version => 4.19.1.1
RPM stream wrapper => yes
diff --git a/REFLECTION b/REFLECTION
index 2706a15..a216d7d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,7 @@
-Extension [ <persistent> extension #99 rpminfo version 1.1.0 ] {
+Extension [ <persistent> extension #91 rpminfo version 1.1.1 ] {
- - Constants [278] {
- Constant [ string RPMVERSION ] { 4.18.1 }
+ - Constants [285] {
+ Constant [ string RPMVERSION ] { 4.19.1.1 }
Constant [ int RPMSENSE_ANY ] { 0 }
Constant [ int RPMSENSE_LESS ] { 2 }
Constant [ int RPMSENSE_GREATER ] { 4 }
@@ -191,6 +191,9 @@ Extension [ <persistent> extension #99 rpminfo version 1.1.0 ] {
Constant [ int RPMTAG_POSTUN ] { 1026 }
Constant [ int RPMTAG_POSTUNFLAGS ] { 5023 }
Constant [ int RPMTAG_POSTUNPROG ] { 1088 }
+ Constant [ int RPMTAG_POSTUNTRANS ] { 5104 }
+ Constant [ int RPMTAG_POSTUNTRANSFLAGS ] { 5108 }
+ Constant [ int RPMTAG_POSTUNTRANSPROG ] { 5106 }
Constant [ int RPMTAG_PREFIXES ] { 1098 }
Constant [ int RPMTAG_PREIN ] { 1023 }
Constant [ int RPMTAG_PREINFLAGS ] { 5020 }
@@ -201,6 +204,9 @@ Extension [ <persistent> extension #99 rpminfo version 1.1.0 ] {
Constant [ int RPMTAG_PREUN ] { 1025 }
Constant [ int RPMTAG_PREUNFLAGS ] { 5022 }
Constant [ int RPMTAG_PREUNPROG ] { 1087 }
+ Constant [ int RPMTAG_PREUNTRANS ] { 5103 }
+ Constant [ int RPMTAG_PREUNTRANSFLAGS ] { 5107 }
+ Constant [ int RPMTAG_PREUNTRANSPROG ] { 5105 }
Constant [ int RPMTAG_PROVIDEFLAGS ] { 1112 }
Constant [ int RPMTAG_PROVIDENAME ] { 1047 }
Constant [ int RPMTAG_PROVIDENEVRS ] { 5042 }
@@ -246,6 +252,7 @@ Extension [ <persistent> extension #99 rpminfo version 1.1.0 ] {
Constant [ int RPMTAG_SUPPLEMENTNEVRS ] { 5060 }
Constant [ int RPMTAG_SUPPLEMENTS ] { 5052 }
Constant [ int RPMTAG_SUPPLEMENTVERSION ] { 5053 }
+ Constant [ int RPMTAG_SYSUSERS ] { 5109 }
Constant [ int RPMTAG_TRANSFILETRIGGERCONDS ] { 5088 }
Constant [ int RPMTAG_TRANSFILETRIGGERFLAGS ] { 5082 }
Constant [ int RPMTAG_TRANSFILETRIGGERINDEX ] { 5080 }
diff --git a/php-pecl-rpminfo.spec b/php-pecl-rpminfo.spec
index 2df4c20..05ab26c 100644
--- a/php-pecl-rpminfo.spec
+++ b/php-pecl-rpminfo.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-rpminfo
#
-# Copyright (c) 2018-2023 Remi Collet
+# Copyright (c) 2018-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -19,7 +19,7 @@
Summary: RPM information
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.1.0
+Version: 1.1.1
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
@@ -27,8 +27,8 @@ Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: pkgconfig(rpm) >= 4.11.3
-BuildRequires: %{?scl_prefix}php-devel >= 8
+BuildRequires: pkgconfig(rpm) >= 4.13
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -54,7 +54,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd %{sources}
@@ -130,26 +130,6 @@ do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
cd %{sources}
%if 0%{?fedora} < 37 && 0%{?rhel} < 10
@@ -192,7 +172,7 @@ REPORT_EXIT_STATUS=1 \
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -206,6 +186,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Sep 3 2024 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+
* Fri Nov 10 2023 Remi Collet <remi@remirepo.net> - 1.1.0-1
- update to 1.1.0