summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-16 17:22:40 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-16 17:22:40 +0200
commitaddcb5f05566a1a9bf4f61c97eef34f699b183c1 (patch)
tree7f305916e4734eee207287ac51e25f568ef0b573
parent1decda5a634e17484e10b80018b02506716b52d2 (diff)
php-pecl: add numerical prefix to extension configuration file (more)
-rw-r--r--php-pecl-riak.spec22
1 files changed, 16 insertions, 6 deletions
diff --git a/php-pecl-riak.spec b/php-pecl-riak.spec
index 8b2cdef..fa50671 100644
--- a/php-pecl-riak.spec
+++ b/php-pecl-riak.spec
@@ -20,11 +20,18 @@
%global pecl_name riak
%global with_zts 0%{?__ztsphp:1}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%if "%{php_version}" < "5.6"
+# After json
+%global ini_name %{pecl_name}.ini
+%else
+# After 40-json
+%global ini_name 50-%{pecl_name}.ini
+%endif
Summary: Riak database PHP extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.1.4
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: ASL 2.0 and BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -96,7 +103,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat << 'EOF' | tee %{pecl_name}.ini
+cat << 'EOF' | tee %{ini_name}
; Enable %{summary}
extension=%{pecl_name}.so
@@ -141,7 +148,7 @@ make -C NTS \
install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -150,7 +157,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
make -C ZTS \
install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -210,16 +217,19 @@ rm -rf %{buildroot}
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 1.1.4-2
+- add numerical prefix to extension configuration file (php 5.6)
+
* Fri Mar 21 2014 Remi Collet <remi@fedoraproject.org> - 1.1.4-1
- Update to 1.1.4