summaryrefslogtreecommitdiffstats
path: root/php-pecl-request.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-26 17:21:29 +0200
committerRemi Collet <remi@remirepo.net>2017-06-26 17:21:29 +0200
commitbb45a24f1fb33f645f390ad8ae8d04fb29a783e6 (patch)
treecfbd740bf0154c7f0eb64722f65f5a78be97ee46 /php-pecl-request.spec
parent77b1c1d01fdc5f5aeb254c0bd17cc7b00b5d4d0b (diff)
add patch for php 7.1 and 7.2
Diffstat (limited to 'php-pecl-request.spec')
-rw-r--r--php-pecl-request.spec22
1 files changed, 21 insertions, 1 deletions
diff --git a/php-pecl-request.spec b/php-pecl-request.spec
index 4c58814..475f197 100644
--- a/php-pecl-request.spec
+++ b/php-pecl-request.spec
@@ -19,12 +19,16 @@
Summary: Server-side request and response objects
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 0.4.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.5.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Patch0: 0001-Use-IS_VOID-7.1-instead-of-IS_NULL.patch
+Patch1: 0002-Fix-type-check-for-setContentDownload.patch
+Patch2: 0003-fix-for-PHP-7.2.patch
+
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -56,6 +60,10 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -96,6 +104,10 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b .void
+%patch1 -p1 -b .upstream
+%patch2 -p1 -b .php72
+
# Sanity check, really often broken
extver=$(sed -n '/define PHP_REQUEST_VERSION/{s/.* "//;s/".*$//;p}' php_request.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -117,6 +129,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -139,6 +153,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
@@ -227,6 +243,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Jun 26 2017 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.5.b1
+- add patch for reflection with 7.1
+- add patch for reflection with 7.2
+
* Mon Dec 19 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.4.b1
- update to 1.0.0b1 (beta)