summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-08-16 13:08:36 +0200
committerRemi Collet <remi@remirepo.net>2018-08-16 13:08:36 +0200
commit665feb7f56ce75a04e186ff39b66b4ff63f4d495 (patch)
tree0a2c10bee97bff600d47de02160d8fc500075bc2
parentc166809cec6fd0d35e6df70c4bd81d207b84bfeb (diff)
rebuild for 7.3.0beta2 new ABI
add patch for PHP 7.3 from https://github.com/pmjones/ext-request/pull/14
-rw-r--r--14.patch25
-rw-r--r--php-pecl-request.spec9
2 files changed, 33 insertions, 1 deletions
diff --git a/14.patch b/14.patch
new file mode 100644
index 0000000..e59f81d
--- /dev/null
+++ b/14.patch
@@ -0,0 +1,25 @@
+From 96477c166d10062f43c4a500d8c94b09b0c3db3a Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 16 Aug 2018 13:03:35 +0200
+Subject: [PATCH] fix for 7.3.0beta
+
+---
+ serverresponse.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/serverresponse.c b/serverresponse.c
+index e2b3f04..734ff5b 100644
+--- a/serverresponse.c
++++ b/serverresponse.c
+@@ -1031,7 +1031,11 @@ static inline void send_cookie(zend_string *name, zval *arr)
+ raw = zval_is_true(tmp);
+ }
+
++#if PHP_VERSION_ID < 70300
+ php_setcookie(name, value, expires, path, domain, secure, !raw, httponly);
++#else
++ php_setcookie(name, value, expires, path, domain, secure, httponly, NULL, !raw);
++#endif
+ }
+
+ PHP_METHOD(ServerResponse, sendCookies)
diff --git a/php-pecl-request.spec b/php-pecl-request.spec
index 214df32..4627bd1 100644
--- a/php-pecl-request.spec
+++ b/php-pecl-request.spec
@@ -19,12 +19,13 @@
Summary: Server-side request and response objects
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 0.9.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.10.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
Patch0: https://patch-diff.githubusercontent.com/raw/pmjones/ext-request/pull/12.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/pmjones/ext-request/pull/14.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
@@ -107,6 +108,7 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
%patch0 -p1 -b .pr12
+%patch1 -p1 -b .pr14
# Sanity check, really often broken
extver=$(sed -n '/define PHP_REQUEST_VERSION/{s/.* "//;s/".*$//;p}' php_request.h)
@@ -243,6 +245,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 1.0.0-0.10.b2
+- rebuild for 7.3.0beta2 new ABI
+- add patch for PHP 7.3 from
+ https://github.com/pmjones/ext-request/pull/14
+
* Wed Jul 18 2018 Remi Collet <remi@remirepo.net> - 1.0.0-0.9.b2
- rebuild for 7.3.0alpha4 new ABI