summaryrefslogtreecommitdiffstats
path: root/php-pecl-ref.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-ref.spec')
-rw-r--r--php-pecl-ref.spec16
1 files changed, 15 insertions, 1 deletions
diff --git a/php-pecl-ref.spec b/php-pecl-ref.spec
index 2393c35..9af5ae4 100644
--- a/php-pecl-ref.spec
+++ b/php-pecl-ref.spec
@@ -19,12 +19,15 @@
Summary: Soft and Weak references support in PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 0.4.2
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
+Patch0: 01a154bc126333e03f2c98117e79059553760001.patch
+Patch1: 20.patch
+
BuildRequires: %{?scl_prefix}php-devel >= 7.0.3
BuildRequires: %{?scl_prefix}php-pear
@@ -49,6 +52,10 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -75,6 +82,9 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b .upstream
+%patch1 -p1 -b .pr20
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_REF_VERSION/{s/.* "//;s/".*$//;p}' php_ref.h)
if test "x${extver}" != "x%{version}%{?versuf}"; then
@@ -213,6 +223,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Jun 28 2017 Remi Collet <remi@remirepo.net> - 0.4.2-2
+- add patch for PHP 7.2 from
+ https://github.com/pinepain/php-ref/pull/20
+
* Mon Mar 6 2017 Remi Collet <remi@remirepo.net> - 0.4.2-1
- Update to 0.4.2 (stable)