summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-27 17:55:45 +0200
committerRemi Collet <remi@remirepo.net>2017-08-27 17:55:45 +0200
commite52d8d6efca01bfe477614cc5430a7991d84152a (patch)
treeeea118fc873cba8ca777ff5121fd2c98712441c0
parent13574c57db0671bb456c44b5b303d9a46085a742 (diff)
Update to 0.5.0
raise minimal PHP version to 7.1
-rw-r--r--REFLECTION17
-rw-r--r--php-pecl-ref.spec8
2 files changed, 16 insertions, 9 deletions
diff --git a/REFLECTION b/REFLECTION
index 4da413a..85fefc7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 ref version 0.4.4 ] {
+Extension [ <persistent> extension #63 ref version 0.5.0 ] {
- Functions {
Function [ <internal:ref> function Ref\refcounted ] {
@@ -158,7 +158,7 @@ Extension [ <persistent> extension #122 ref version 0.4.4 ] {
- Parameters [2] {
Parameter #0 [ <required> $referent ]
- Parameter #1 [ <optional> $notify ]
+ Parameter #1 [ <optional> callable or NULL $notify ]
}
}
@@ -178,8 +178,9 @@ Extension [ <persistent> extension #122 ref version 0.4.4 ] {
Method [ <internal:ref> public method notifier ] {
- Parameters [1] {
- Parameter #0 [ <optional> $notify ]
+ Parameter #0 [ <optional> callable or NULL $notify ]
}
+ - Return [ callable or NULL ]
}
}
}
@@ -203,7 +204,7 @@ Extension [ <persistent> extension #122 ref version 0.4.4 ] {
- Parameters [2] {
Parameter #0 [ <required> $referent ]
- Parameter #1 [ <optional> $notify ]
+ Parameter #1 [ <optional> callable or NULL $notify ]
}
}
@@ -223,8 +224,9 @@ Extension [ <persistent> extension #122 ref version 0.4.4 ] {
Method [ <internal:ref, inherits Ref\AbstractReference> public method notifier ] {
- Parameters [1] {
- Parameter #0 [ <optional> $notify ]
+ Parameter #0 [ <optional> callable or NULL $notify ]
}
+ - Return [ callable or NULL ]
}
}
}
@@ -248,7 +250,7 @@ Extension [ <persistent> extension #122 ref version 0.4.4 ] {
- Parameters [2] {
Parameter #0 [ <required> $referent ]
- Parameter #1 [ <optional> $notify ]
+ Parameter #1 [ <optional> callable or NULL $notify ]
}
}
@@ -268,8 +270,9 @@ Extension [ <persistent> extension #122 ref version 0.4.4 ] {
Method [ <internal:ref, inherits Ref\AbstractReference> public method notifier ] {
- Parameters [1] {
- Parameter #0 [ <optional> $notify ]
+ Parameter #0 [ <optional> callable or NULL $notify ]
}
+ - Return [ callable or NULL ]
}
}
}
diff --git a/php-pecl-ref.spec b/php-pecl-ref.spec
index b0bd406..a8fcc9d 100644
--- a/php-pecl-ref.spec
+++ b/php-pecl-ref.spec
@@ -18,14 +18,14 @@
Summary: Soft and Weak references support in PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.4.4
+Version: 0.5.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-BuildRequires: %{?scl_prefix}php-devel >= 7.0.3
+BuildRequires: %{?scl_prefix}php-devel >= 7.1
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -218,6 +218,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Sun Aug 27 2017 Remi Collet <remi@remirepo.net> - 0.5.0-1
+- Update to 0.5.0
+- raise minimal PHP version to 7.1
+
* Tue Aug 1 2017 Remi Collet <remi@remirepo.net> - 0.4.4-1
- Update to 0.4.4