summaryrefslogtreecommitdiffstats
path: root/php-pecl-redis6.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-redis6.spec')
-rw-r--r--php-pecl-redis6.spec47
1 files changed, 30 insertions, 17 deletions
diff --git a/php-pecl-redis6.spec b/php-pecl-redis6.spec
index 04d0456..fa2ddf0 100644
--- a/php-pecl-redis6.spec
+++ b/php-pecl-redis6.spec
@@ -30,24 +30,22 @@
# after 20-json, 40-igbinary and 40-msgpack
%global ini_name 50-%{pecl_name}.ini
-%global upstream_version 6.0.2
+%global upstream_version 6.1.0
#global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
-Summary: Extension for communicating with the Redis key-value store
+Summary: PHP extension for interfacing with key-value stores
Name: %{?scl_prefix}php-pecl-redis6
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/redis
Source0: https://pecl.php.net/get/%{sources}.tgz
-Patch0: %{pecl_name}-upstream.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.2
+BuildRequires: %{?scl_prefix}php-devel >= 7.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
%if %{with igbinary}
@@ -107,12 +105,12 @@ Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}5 < 6
%description
-The phpredis extension provides an API for communicating
-with the Redis key-value store.
+This extension provides an API for communicating with RESP-based key-value
+stores, such as Redis, Valkey, and KeyDB.
-This Redis client implements most of the latest Redis API.
-As method only only works when also implemented on the server side,
-some doesn't work with an old redis server version.
+This client implements most of the latest API.
+As method only works when also implemented on the server side,
+some doesn't work with an old server version.
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -127,8 +125,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-%patch -P0 -p1
-
# Use system library
rm -r liblzf
@@ -193,6 +189,8 @@ extension = %{pecl_name}.so
;redis.session.lock_retries = 100
;redis.session.lock_wait_time = 20000
;redis.session.early_refresh = 0
+;redis.session.compression = none
+;redis.session.compression_level = 3
EOF
@@ -220,15 +218,16 @@ peclconf() {
cd %{sources}
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
cd ../NTS
peclconf %{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
peclconf %{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
@@ -236,12 +235,12 @@ make %{?_smp_mflags}
%{?dtsenable}
# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
# Install the ZTS stuff
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -338,6 +337,20 @@ exit $ret
%changelog
+* Sat Oct 5 2024 Remi Collet <remi@remirepo.net> - 6.1.0-1
+- update to 6.1.0
+
+* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 6.1.0~RC2-1
+- update to 6.1.0RC2
+
+* Mon Sep 23 2024 Remi Collet <remi@remirepo.net> - 6.1.0~RC2-0
+- test build for upcoming 6.1.0RC2
+
+* Mon Aug 5 2024 Remi Collet <remi@remirepo.net> - 6.1.0~RC1-1
+- update to 6.1.0RC1
+- open https://github.com/phpredis/phpredis/pull/2532 missing file
+- drop support for PHP < 7.4
+
* Thu Jul 11 2024 Remi Collet <remi@remirepo.net> - 6.0.2-2
- add upstream patch for PHP 8.4
- allow to build with valkey