summaryrefslogtreecommitdiffstats
path: root/php-pecl-redis6.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-09-16 09:07:43 +0200
committerRemi Collet <remi@php.net>2024-09-16 09:07:43 +0200
commit5b1e772c6b5e68509728752a7b963a89dc03baf5 (patch)
tree1fadbf7fc942f0e8b836b6b93206d66743ad6f26 /php-pecl-redis6.spec
parentce66a541e21323ade4904a8697a06158cd099678 (diff)
update to 6.1.0RC1HEADmaster
open https://github.com/phpredis/phpredis/pull/2532 missing file drop support for PHP < 7.4
Diffstat (limited to 'php-pecl-redis6.spec')
-rw-r--r--php-pecl-redis6.spec30
1 files changed, 19 insertions, 11 deletions
diff --git a/php-pecl-redis6.spec b/php-pecl-redis6.spec
index 04d0456..2f17c9c 100644
--- a/php-pecl-redis6.spec
+++ b/php-pecl-redis6.spec
@@ -30,24 +30,24 @@
# after 20-json, 40-igbinary and 40-msgpack
%global ini_name 50-%{pecl_name}.ini
-%global upstream_version 6.0.2
-#global upstream_prever RC2
+%global upstream_version 6.1.0
+%global upstream_prever RC1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
Summary: Extension for communicating with the Redis key-value store
Name: %{?scl_prefix}php-pecl-redis6
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/redis
Source0: https://pecl.php.net/get/%{sources}.tgz
-
-Patch0: %{pecl_name}-upstream.patch
+Source1: https://raw.githubusercontent.com/phpredis/phpredis/%{upstream_version}%{?upstream_prever}/tests/SessionHelpers.php
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.2
+# see https://github.com/phpredis/phpredis/issues/2531#issuecomment-2268309251
+BuildRequires: %{?scl_prefix}php-devel >= 7.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
%if %{with igbinary}
@@ -127,7 +127,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-%patch -P0 -p1
+cp %{SOURCE1} tests/
# Use system library
rm -r liblzf
@@ -193,6 +193,8 @@ extension = %{pecl_name}.so
;redis.session.lock_retries = 100
;redis.session.lock_wait_time = 20000
;redis.session.early_refresh = 0
+;redis.session.compression = none
+;redis.session.compression_level = 3
EOF
@@ -220,15 +222,16 @@ peclconf() {
cd %{sources}
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
cd ../NTS
peclconf %{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
peclconf %{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
@@ -236,12 +239,12 @@ make %{?_smp_mflags}
%{?dtsenable}
# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
# Install the ZTS stuff
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -338,6 +341,11 @@ exit $ret
%changelog
+* Mon Aug 5 2024 Remi Collet <remi@remirepo.net> - 6.1.0~RC1-1
+- update to 6.1.0RC1
+- open https://github.com/phpredis/phpredis/pull/2532 missing file
+- drop support for PHP < 7.4
+
* Thu Jul 11 2024 Remi Collet <remi@remirepo.net> - 6.0.2-2
- add upstream patch for PHP 8.4
- allow to build with valkey