summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-21 07:15:16 +0100
committerRemi Collet <remi@remirepo.net>2020-02-21 07:15:16 +0100
commitde9950d5df2bcf1ce1fc004b14f142de70c3b8bd (patch)
tree69518f0cf097e60ff523073570db37180b4394dc
parent096ed5ea2e6309ce2f484ece0db964c5cc740b64 (diff)
update to 5.2.0RC2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--RedisSentinelTest.php113
-rw-r--r--php-pecl-redis5.spec9
4 files changed, 7 insertions, 121 deletions
diff --git a/PHPINFO b/PHPINFO
index 0ff7fe8..41d2d6d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,8 @@
redis
Redis Support => enabled
-Redis Version => 5.2.0RC1
-Redis Sentinel Version => 0.1RC1
+Redis Version => 5.2.0RC2
+Redis Sentinel Version => 0.1RC2
Available serializers => php, json, igbinary, msgpack
Available compression => lzf, zstd
diff --git a/REFLECTION b/REFLECTION
index e9ab96c..aa8f00b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #109 redis version 5.2.0RC1 ] {
+Extension [ <persistent> extension #110 redis version 5.2.0RC2 ] {
- Dependencies {
Dependency [ igbinary (Required) ]
diff --git a/RedisSentinelTest.php b/RedisSentinelTest.php
deleted file mode 100644
index b88e006..0000000
--- a/RedisSentinelTest.php
+++ /dev/null
@@ -1,113 +0,0 @@
-<?php defined('PHPREDIS_TESTRUN') or die("Use TestRedis.php to run tests!\n");
-
-require_once(dirname($_SERVER['PHP_SELF'])."/TestSuite.php");
-
-class Redis_Sentinel_Test extends TestSuite
-{
- const NAME = 'mymaster';
-
- /**
- * @var RedisSentinel
- */
- public $sentinel;
-
- /**
- * Common fields
- */
- protected $fields = [
- 'name',
- 'ip',
- 'port',
- 'runid',
- 'flags',
- 'link-pending-commands',
- 'link-refcount',
- 'last-ping-sent',
- 'last-ok-ping-reply',
- 'last-ping-reply',
- 'down-after-milliseconds',
- ];
-
- protected function newInstance()
- {
- return new RedisSentinel($this->getHost());
- }
-
- public function setUp()
- {
- $this->sentinel = $this->newInstance();
- }
-
- public function testCkquorum()
- {
- $this->assertTrue($this->sentinel->ckquorum(self::NAME));
- }
-
- public function testFailover()
- {
- $this->assertFalse($this->sentinel->failover(self::NAME));
- }
-
- public function testFlushconfig()
- {
- $this->assertTrue($this->sentinel->flushconfig());
- }
-
- public function testGetMasterAddrByName()
- {
- $result = $this->sentinel->getMasterAddrByName(self::NAME);
- $this->assertTrue(is_array($result));
- $this->assertEquals(2, count($result));
- }
-
- protected function checkFields(array $fields)
- {
- foreach ($this->fields as $k) {
- $this->assertTrue(array_key_exists($k, $fields));
- }
- }
-
- public function testMaster()
- {
- $result = $this->sentinel->master(self::NAME);
- $this->assertTrue(is_array($result));
- $this->checkFields($result);
- }
-
- public function testMasters()
- {
- $result = $this->sentinel->masters();
- $this->assertTrue(is_array($result));
- foreach ($result as $master) {
- $this->checkFields($master);
- }
- }
-
- public function testPing()
- {
- $this->assertTrue($this->sentinel->ping());
- }
-
- public function testReset()
- {
- $this->assertFalse($this->sentinel->reset('*'));
- }
-
- public function testSentinels()
- {
- $result = $this->sentinel->sentinels(self::NAME);
- $this->assertTrue(is_array($result));
- foreach ($result as $sentinel) {
- $this->checkFields($sentinel);
- }
- }
-
- public function testSlaves()
- {
- $result = $this->sentinel->slaves(self::NAME);
- $this->assertTrue(is_array($result));
- foreach ($result as $slave) {
- $this->checkFields($slave);
- }
- }
-}
diff --git a/php-pecl-redis5.spec b/php-pecl-redis5.spec
index c1b1875..7a835fd 100644
--- a/php-pecl-redis5.spec
+++ b/php-pecl-redis5.spec
@@ -25,7 +25,7 @@
%global ini_name 50-%{pecl_name}.ini
%global upstream_version 5.2.0
-%global upstream_prever RC1
+%global upstream_prever RC2
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis5
@@ -35,8 +35,6 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstr
License: PHP
URL: https://pecl.php.net/package/redis
-Source1: https://raw.githubusercontent.com/phpredis/phpredis/c58fb7316a82a6c5fceaaba83f3598f4212f8582/tests/RedisSentinelTest.php
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -130,8 +128,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-cp %{SOURCE1} tests/
-
# Use system library
rm -r liblzf
@@ -345,6 +341,9 @@ fi
%changelog
+* Fri Feb 21 2020 Remi Collet <remi@remirepo.net> - 5.2.0~RC2-1
+- update to 5.2.0RC2
+
* Mon Feb 17 2020 Remi Collet <remi@remirepo.net> - 5.2.0~RC1-1
- update to 5.2.0RC1