summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-17 10:24:22 +0100
committerRemi Collet <remi@php.net>2021-11-17 10:24:22 +0100
commitbcde0ac48186ef2011aad71693fe951aa1922520 (patch)
treebc82c3280445defe9333f17b3df9ffbabc9738a6
parent4efcbe82b99c2018370ce0041be720afbd22efe1 (diff)
update to 5.3.5RC1
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION107
-rw-r--r--php-pecl-redis5.spec14
3 files changed, 113 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index bc71421..5e6166d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
redis
Redis Support => enabled
-Redis Version => 5.3.4
+Redis Version => 5.3.5RC1
Redis Sentinel Version => 0.1
Available serializers => php, json, igbinary, msgpack
Available compression => lzf, zstd, lz4
@@ -32,6 +32,8 @@ redis.clusters.timeout => 0 => 0
redis.pconnect.pooling_enabled => 1 => 1
redis.pconnect.connection_limit => 0 => 0
redis.pconnect.echo_check_liveness => 1 => 1
+redis.pconnect.pool_detect_dirty => 0 => 0
+redis.pconnect.pool_poll_timeout => 0 => 0
redis.pconnect.pool_pattern => no value => no value
redis.session.locking_enabled => 0 => 0
redis.session.lock_expire => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index 377a9ef..ece7296 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 redis version 5.3.4 ] {
+Extension [ <persistent> extension #126 redis version 5.3.5RC1 ] {
- Dependencies {
Dependency [ igbinary (Required) ]
@@ -80,6 +80,12 @@ Extension [ <persistent> extension #117 redis version 5.3.4 ] {
Entry [ redis.pconnect.echo_check_liveness <ALL> ]
Current = '1'
}
+ Entry [ redis.pconnect.pool_detect_dirty <ALL> ]
+ Current = '0'
+ }
+ Entry [ redis.pconnect.pool_poll_timeout <ALL> ]
+ Current = '0'
+ }
Entry [ redis.pconnect.pool_pattern <ALL> ]
Current = ''
}
@@ -100,7 +106,7 @@ Extension [ <persistent> extension #117 redis version 5.3.4 ] {
- Classes [6] {
Class [ <internal:redis> class Redis ] {
- - Constants [37] {
+ - Constants [48] {
Constant [ public int REDIS_NOT_FOUND ] { 0 }
Constant [ public int REDIS_STRING ] { 1 }
Constant [ public int REDIS_SET ] { 2 }
@@ -138,6 +144,17 @@ Extension [ <persistent> extension #117 redis version 5.3.4 ] {
Constant [ public int SCAN_NOPREFIX ] { 3 }
Constant [ public string AFTER ] { after }
Constant [ public string BEFORE ] { before }
+ Constant [ public int OPT_MAX_RETRIES ] { 11 }
+ Constant [ public int OPT_BACKOFF_ALGORITHM ] { 12 }
+ Constant [ public int BACKOFF_ALGORITHM_DEFAULT ] { 0 }
+ Constant [ public int BACKOFF_ALGORITHM_CONSTANT ] { 6 }
+ Constant [ public int BACKOFF_ALGORITHM_UNIFORM ] { 5 }
+ Constant [ public int BACKOFF_ALGORITHM_EXPONENTIAL ] { 4 }
+ Constant [ public int BACKOFF_ALGORITHM_FULL_JITTER ] { 2 }
+ Constant [ public int BACKOFF_ALGORITHM_EQUAL_JITTER ] { 3 }
+ Constant [ public int BACKOFF_ALGORITHM_DECORRELATED_JITTER ] { 1 }
+ Constant [ public int OPT_BACKOFF_BASE ] { 13 }
+ Constant [ public int OPT_BACKOFF_CAP ] { 14 }
}
- Static properties [0] {
@@ -149,7 +166,7 @@ Extension [ <persistent> extension #117 redis version 5.3.4 ] {
- Properties [0] {
}
- - Methods [235] {
+ - Methods [240] {
Method [ <internal:redis, ctor> public method __construct ] {
- Parameters [0] {
@@ -183,6 +200,34 @@ Extension [ <persistent> extension #117 redis version 5.3.4 ] {
}
}
+ Method [ <internal:redis> public method _pack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:redis> public method _unpack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:redis> public method _compress ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:redis> public method _uncompress ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
Method [ <internal:redis> public method acl ] {
- Parameters [2] {
@@ -1193,6 +1238,15 @@ Extension [ <persistent> extension #117 redis version 5.3.4 ] {
}
}
+ Method [ <internal:redis> public method sMisMember ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $member ]
+ Parameter #2 [ <optional> ...$other_members ]
+ }
+ }
+
Method [ <internal:redis> public method sMove ] {
- Parameters [3] {
@@ -2303,7 +2357,7 @@ Extension [ <persistent> extension #117 redis version 5.3.4 ] {
Class [ <internal:redis> class RedisCluster ] {
- - Constants [41] {
+ - Constants [52] {
Constant [ public int REDIS_NOT_FOUND ] { 0 }
Constant [ public int REDIS_STRING ] { 1 }
Constant [ public int REDIS_SET ] { 2 }
@@ -2338,13 +2392,24 @@ Extension [ <persistent> extension #117 redis version 5.3.4 ] {
Constant [ public int SCAN_NORETRY ] { 0 }
Constant [ public int SCAN_PREFIX ] { 2 }
Constant [ public int SCAN_NOPREFIX ] { 3 }
+ Constant [ public string AFTER ] { after }
+ Constant [ public string BEFORE ] { before }
Constant [ public int OPT_SLAVE_FAILOVER ] { 5 }
Constant [ public int FAILOVER_NONE ] { 0 }
Constant [ public int FAILOVER_ERROR ] { 1 }
Constant [ public int FAILOVER_DISTRIBUTE ] { 2 }
Constant [ public int FAILOVER_DISTRIBUTE_SLAVES ] { 3 }
- Constant [ public string AFTER ] { after }
- Constant [ public string BEFORE ] { before }
+ Constant [ public int OPT_MAX_RETRIES ] { 11 }
+ Constant [ public int OPT_BACKOFF_ALGORITHM ] { 12 }
+ Constant [ public int BACKOFF_ALGORITHM_DEFAULT ] { 0 }
+ Constant [ public int BACKOFF_ALGORITHM_CONSTANT ] { 6 }
+ Constant [ public int BACKOFF_ALGORITHM_UNIFORM ] { 5 }
+ Constant [ public int BACKOFF_ALGORITHM_EXPONENTIAL ] { 4 }
+ Constant [ public int BACKOFF_ALGORITHM_FULL_JITTER ] { 2 }
+ Constant [ public int BACKOFF_ALGORITHM_EQUAL_JITTER ] { 3 }
+ Constant [ public int BACKOFF_ALGORITHM_DECORRELATED_JITTER ] { 1 }
+ Constant [ public int OPT_BACKOFF_BASE ] { 13 }
+ Constant [ public int OPT_BACKOFF_CAP ] { 14 }
}
- Static properties [0] {
@@ -2356,7 +2421,7 @@ Extension [ <persistent> extension #117 redis version 5.3.4 ] {
- Properties [0] {
}
- - Methods [186] {
+ - Methods [190] {
Method [ <internal:redis, ctor> public method __construct ] {
- Parameters [6] {
@@ -2402,6 +2467,34 @@ Extension [ <persistent> extension #117 redis version 5.3.4 ] {
}
}
+ Method [ <internal:redis> public method _compress ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:redis> public method _uncompress ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:redis> public method _pack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:redis> public method _unpack ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
Method [ <internal:redis> public method acl ] {
- Parameters [3] {
diff --git a/php-pecl-redis5.spec b/php-pecl-redis5.spec
index f6b2c46..f5c3be8 100644
--- a/php-pecl-redis5.spec
+++ b/php-pecl-redis5.spec
@@ -25,13 +25,13 @@
# after 20-json, 40-igbinary and 40-msgpack
%global ini_name 50-%{pecl_name}.ini
-%global upstream_version 5.3.4
-#global upstream_prever RC2
+%global upstream_version 5.3.5
+%global upstream_prever RC1
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis5
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/redis
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -190,6 +190,8 @@ extension = %{pecl_name}.so
;redis.pconnect.pooling_enabled = 1
;redis.pconnect.connection_limit = 0
;redis.pconnect.echo_check_liveness = 1
+;redis.pconnect.pool_detect_dirty = 0
+;redis.pconnect.pool_poll_timeout = 0
;redis.pconnect.pool_pattern => ''
;redis.session.lock_expire = 0
;redis.session.lock_retries = 10
@@ -306,7 +308,8 @@ $TEST_PHP_EXECUTABLE $TEST_PHP_ARGS TestRedis.php || ret=1
: Cleanup
if [ -f $pidfile ]; then
- %{_root_bindir}/redis-cli -p $port shutdown
+ %{_root_bindir}/redis-cli -p $port shutdown nosave
+ sleep 2
fi
cat $PWD/redis.log
@@ -351,6 +354,9 @@ fi
%changelog
+* Wed Nov 17 2021 Remi Collet <remi@remirepo.net> - 5.3.5~RC1-1
+- update to 5.3.5RC1
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 5.3.4-2
- rebuild for 8.1.0RC1