summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-02 08:39:28 +0100
committerRemi Collet <remi@php.net>2022-02-02 08:39:28 +0100
commit2f6bfc703d280764a37e886bd4f5c2e20ce254e0 (patch)
treea3d5eca0a2377d14c624f8824a532a841d864280
parent2ce2597845992445c0103e774086fe67213005dd (diff)
update to 5.3.7RC1
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION44
-rw-r--r--php-pecl-redis5.spec7
3 files changed, 48 insertions, 5 deletions
diff --git a/PHPINFO b/PHPINFO
index b2822e6..c634fbf 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
redis
Redis Support => enabled
-Redis Version => 5.3.6
+Redis Version => 5.3.7RC1
Redis Sentinel Version => 0.1
Available serializers => php, json, igbinary, msgpack
Available compression => lzf, zstd, lz4
diff --git a/REFLECTION b/REFLECTION
index 7bf412a..29c43b0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 redis version 5.3.6 ] {
+Extension [ <persistent> extension #117 redis version 5.3.7RC1 ] {
- Dependencies {
Dependency [ igbinary (Required) ]
@@ -2157,7 +2157,7 @@ Extension [ <persistent> extension #117 redis version 5.3.6 ] {
- Properties [0] {
}
- - Methods [29] {
+ - Methods [33] {
Method [ <internal:redis> public method __call ] {
- Parameters [2] {
@@ -2265,6 +2265,16 @@ Extension [ <persistent> extension #117 redis version 5.3.6 ] {
}
}
+ Method [ <internal:redis> public method hscan ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> &$i_iterator ]
+ Parameter #2 [ <optional> $str_pattern = <default> ]
+ Parameter #3 [ <optional> $i_count = <default> ]
+ }
+ }
+
Method [ <internal:redis> public method info ] {
- Parameters [0] {
@@ -2312,6 +2322,16 @@ Extension [ <persistent> extension #117 redis version 5.3.6 ] {
}
}
+ Method [ <internal:redis> public method scan ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> &$iterator ]
+ Parameter #1 [ <required> $node ]
+ Parameter #2 [ <optional> $pattern = <default> ]
+ Parameter #3 [ <optional> $count = <default> ]
+ }
+ }
+
Method [ <internal:redis> public method select ] {
- Parameters [1] {
@@ -2327,6 +2347,16 @@ Extension [ <persistent> extension #117 redis version 5.3.6 ] {
}
}
+ Method [ <internal:redis> public method sscan ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> &$i_iterator ]
+ Parameter #2 [ <optional> $str_pattern = <default> ]
+ Parameter #3 [ <optional> $i_count = <default> ]
+ }
+ }
+
Method [ <internal:redis> public method unlink ] {
- Parameters [0] {
@@ -2339,6 +2369,16 @@ Extension [ <persistent> extension #117 redis version 5.3.6 ] {
}
}
+ Method [ <internal:redis> public method zscan ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> &$i_iterator ]
+ Parameter #2 [ <optional> $str_pattern = <default> ]
+ Parameter #3 [ <optional> $i_count = <default> ]
+ }
+ }
+
Method [ <internal:redis> public method delete ] {
- Parameters [1] {
diff --git a/php-pecl-redis5.spec b/php-pecl-redis5.spec
index fd5f43a..22f32e2 100644
--- a/php-pecl-redis5.spec
+++ b/php-pecl-redis5.spec
@@ -25,8 +25,8 @@
# after 20-json, 40-igbinary and 40-msgpack
%global ini_name 50-%{pecl_name}.ini
-%global upstream_version 5.3.6
-#global upstream_prever RC1
+%global upstream_version 5.3.7
+%global upstream_prever RC1
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis5
@@ -354,6 +354,9 @@ fi
%changelog
+* Wed Feb 2 2022 Remi Collet <remi@remirepo.net> - 5.3.7~RC1-1
+- update to 5.3.7RC1
+
* Tue Jan 18 2022 Remi Collet <remi@remirepo.net> - 5.3.6-1
- update to 5.3.6