summaryrefslogtreecommitdiffstats
path: root/php-pecl-redis4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-redis4.spec')
-rw-r--r--php-pecl-redis4.spec15
1 files changed, 12 insertions, 3 deletions
diff --git a/php-pecl-redis4.spec b/php-pecl-redis4.spec
index 2303ee6..78d5d49 100644
--- a/php-pecl-redis4.spec
+++ b/php-pecl-redis4.spec
@@ -34,7 +34,7 @@
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: PHP
URL: http://pecl.php.net/package/redis
@@ -46,6 +46,8 @@ Source3: https://raw.githubusercontent.com/phpredis/phpredis/develop/tests
# See https://github.com/phpredis/phpredis/pull/1365
Patch0: 1365.patch
+# See https://github.com/phpredis/phpredis/pull/1366
+Patch1: 1366.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -133,6 +135,7 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
cp %{SOURCE1} %{SOURCE2} %{SOURCE3} tests/
%patch0 -p1 -b .pr1365
+%patch1 -p1 -b .pr1366
# Use system library
rm -r liblzf
@@ -281,12 +284,13 @@ sed -e "s/6379/$port/" -i *.php
# Run the test Suite
ret=0
-export PHPCMD="%{__php} --no-php-ini \
+export TEST_PHP_EXECUTABLE=%{__php}
+export TEST_PHP_ARGS="--no-php-ini \
%if %{with_igbin}
--define extension=igbinary.so \
%endif
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so"
-$PHPCMD TestRedis.php || ret=1
+$TEST_PHP_EXECUTABLE $TEST_PHP_ARGS TestRedis.php || ret=1
# Cleanup
if [ -f $pidfile ]; then
@@ -335,6 +339,11 @@ fi
%changelog
+* Fri Jun 8 2018 Remi Collet <remi@remirepo.net> - 4.1.0~RC1-2
+- test build with 7.3
+- open https://github.com/phpredis/phpredis/pull/1366
+ Fix: Warning: time() expects exactly 0 parameters, 1 given ...
+
* Fri Jun 8 2018 Remi Collet <remi@remirepo.net> - 4.1.0~RC1-1
- update to 4.1.0RC1
- open https://github.com/phpredis/phpredis/pull/1365