summaryrefslogtreecommitdiffstats
path: root/php-pecl-redis4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-redis4.spec')
-rw-r--r--php-pecl-redis4.spec74
1 files changed, 45 insertions, 29 deletions
diff --git a/php-pecl-redis4.spec b/php-pecl-redis4.spec
index 3f9389e..6db0534 100644
--- a/php-pecl-redis4.spec
+++ b/php-pecl-redis4.spec
@@ -1,7 +1,4 @@
-# remirepo spec file for php-pecl-redis
-# adapted for scl, from
-#
-# Fedora spec file for php-pecl-redis
+# remirepo spec file for php-pecl-redis4
#
# Copyright (c) 2012-2018 Remi Collet
# License: CC-BY-SA
@@ -27,11 +24,11 @@
# after 40-igbinary
%global ini_name 50-%{pecl_name}.ini
%endif
-%global upstream_version 3.1.6
-#global upstream_prever RC2
+%global upstream_version 4.0.0
+%global upstream_prever RC1
Summary: Extension for communicating with the Redis key-value store
-Name: %{?sub_prefix}php-pecl-redis
+Name: %{?sub_prefix}php-pecl-redis4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -44,6 +41,7 @@ BuildRequires: %{?scl_prefix}php-pear
%if %{with_igbin}
BuildRequires: %{?sub_prefix}php-pecl-igbinary-devel
%endif
+BuildRequires: liblzf-devel
# to run Test suite
%if %{with_tests}
BuildRequires: redis >= 3
@@ -61,36 +59,33 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
+
+%if 0%{?fedora} >= 99
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 4
+%else
+# A single version can be installed
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 4
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56u-pecl-%{pecl_name}4 <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name}4 <= %{version}
%endif
%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70u-pecl-%{pecl_name}4 <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name}4 <= %{version}
%endif
%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71u-pecl-%{pecl_name}4 <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name}4 <= %{version}
%endif
%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72u-pecl-%{pecl_name}4 <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name}4 <= %{version}
%endif
%endif
@@ -120,9 +115,13 @@ mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/COPYING/s/role="doc"/role="src"/' } \
+ -e '/liblzf/d' \
-i package.xml
cd NTS
+# Use system library
+rm -r liblzf
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_REDIS_VERSION/{s/.* "//;s/".*$//;p}' php_redis.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -152,15 +151,22 @@ extension = %{pecl_name}.so
;session.save_path = "tcp://host1:6379?weight=1, tcp://host2:6379?weight=2&timeout=2.5, tcp://host3:6379?weight=2"
; Configuration
-;redis.arrays.names = ''
-;redis.arrays.hosts = ''
-;redis.arrays.previous = ''
+;redis.arrays.autorehash = ''
+;redis.arrays.connecttimeout = ''
+;redis.arrays.distributor = ''
;redis.arrays.functions = ''
+;redis.arrays.hosts = ''
;redis.arrays.index = ''
-;redis.arrays.autorehash = ''
+;redis.arrays.lazyconnect = ''
+;redis.arrays.names = ''
+;redis.arrays.pconnect = ''
+;redis.arrays.previous = ''
+;redis.arrays.readtimeout = ''
+;redis.arrays.retryinterval = ''
+;redis.clusters.persistent = ''
+;redis.clusters.read_timeout = ''
;redis.clusters.seeds = ''
;redis.clusters.timeout = ''
-;redis.clusters.read_timeout = ''
EOF
@@ -175,6 +181,8 @@ cd NTS
%if %{with_igbin}
--enable-redis-igbinary \
%endif
+ --enable-redis-lzf \
+ --with-liblzf \
--with-php-config=%{_bindir}/php-config
make %{?_smp_mflags}
@@ -187,6 +195,8 @@ cd ../ZTS
%if %{with_igbin}
--enable-redis-igbinary \
%endif
+ --enable-redis-lzf \
+ --with-liblzf \
--with-php-config=%{_bindir}/zts-php-config
make %{?_smp_mflags}
%endif
@@ -305,6 +315,12 @@ fi
%changelog
+* Wed Feb 7 2018 Remi Collet <remi@remirepo.net> - 4.0.0~RC1-1
+- update to 4.0.0RC1
+- rename to php-pecl-redis4
+- enable lzf support
+- update configuration for new options
+
* Wed Jan 3 2018 Remi Collet <remi@remirepo.net> - 3.1.6-1
- Update to 3.1.6