summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-08 05:51:20 +0100
committerRemi Collet <remi@remirepo.net>2018-02-08 05:53:01 +0100
commitededdd74af7211f1fd5be84db712db58e0f9e2ab (patch)
tree70286fdf66761e3571934df071b95cf4472cf1e5
parent1e6765655c20feb3a6a441af2fe52b891be15f2e (diff)
add patch to skip online test from
https://github.com/phpredis/phpredis/pull/1304 (cherry picked from commit bfabdcf824f76d9b24cee465805cb18cc97db006)
-rw-r--r--php-pecl-redis4.spec10
-rw-r--r--redis-tests.patch28
2 files changed, 37 insertions, 1 deletions
diff --git a/php-pecl-redis4.spec b/php-pecl-redis4.spec
index 23762bc..f770c22 100644
--- a/php-pecl-redis4.spec
+++ b/php-pecl-redis4.spec
@@ -24,12 +24,14 @@
Summary: Extension for communicating with the Redis key-value store
Name: php-pecl-redis4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 3%{?dist}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/redis
+Patch0: %{pecl_name}-tests.patch
+
BuildRequires: php-devel
BuildRequires: php-pear
BuildRequires: php-pecl-igbinary-devel
@@ -80,6 +82,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b .pr
+
# Use system library
rm -r liblzf
@@ -246,6 +250,10 @@ exit $ret
%changelog
+* Wed Feb 7 2018 Remi Collet <remi@remirepo.net> - 4.0.0~RC1-3
+- add patch to skip online test from
+ https://github.com/phpredis/phpredis/pull/1304
+
* Wed Feb 7 2018 Remi Collet <remi@remirepo.net> - 4.0.0~RC1-2
- cleanup for Fedora review
diff --git a/redis-tests.patch b/redis-tests.patch
new file mode 100644
index 0000000..07dbb42
--- /dev/null
+++ b/redis-tests.patch
@@ -0,0 +1,28 @@
+From 627bd89b45ba09b689e692a23370e5d82d9829a1 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 8 Feb 2018 05:47:28 +0100
+Subject: [PATCH] skip online test
+
+---
+ tests/RedisTest.php | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/tests/RedisTest.php b/tests/RedisTest.php
+index 4c0b7884..4d807a78 100644
+--- a/tests/RedisTest.php
++++ b/tests/RedisTest.php
+@@ -5164,9 +5164,13 @@ public function testMultipleConnect() {
+ }
+
+ public function testConnectException() {
++ $host = 'github.com';
++ if (gethostbyname($host) === $host) {
++ return $this->markTestSkipped('online test');
++ }
+ $redis = new Redis();
+ try {
+- $redis->connect('github.com', 6379, 0.01);
++ $redis->connect($host, 6379, 0.01);
+ } catch (Exception $e) {
+ $this->assertTrue(strpos($e, "timed out") !== false);
+ }