summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-03 09:57:15 +0100
committerRemi Collet <remi@remirepo.net>2018-03-03 09:57:15 +0100
commit674a1d0f85eb6175bb3d5090784c95c767648135 (patch)
tree8c88675d465738c9cd756c282442b1eb7fc53138
parent05a70758e60e67c13c6fe4ef2838370fc43032b8 (diff)
v4.0.0RC2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-redis4.spec11
-rw-r--r--redis-tests.patch28
3 files changed, 7 insertions, 34 deletions
diff --git a/REFLECTION b/REFLECTION
index 6638d6b..21b91e2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #188 redis version 4.0.0RC1 ] {
+Extension [ <persistent> extension #188 redis version 4.0.0RC2 ] {
- Dependencies {
Dependency [ igbinary (Required) ]
diff --git a/php-pecl-redis4.spec b/php-pecl-redis4.spec
index 4f9aa72..a537127 100644
--- a/php-pecl-redis4.spec
+++ b/php-pecl-redis4.spec
@@ -29,18 +29,17 @@
%global ini_name 50-%{pecl_name}.ini
%endif
%global upstream_version 4.0.0
-%global upstream_prever RC1
+%global upstream_prever RC2
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis4
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: PHP
URL: http://pecl.php.net/package/redis
-Patch0: %{pecl_name}-tests.patch
-
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
%if %{with_igbin}
@@ -124,7 +123,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr
# Use system library
rm -r liblzf
@@ -323,6 +321,9 @@ fi
%changelog
+* Sat Mar 3 2018 Remi Collet <remi@remirepo.net> - 4.0.0~RC2-1
+- update to 4.0.0RC2
+
* Wed Feb 7 2018 Remi Collet <remi@remirepo.net> - 4.0.0~RC1-4
- re-enable s390x build (was a temporary failure)
diff --git a/redis-tests.patch b/redis-tests.patch
deleted file mode 100644
index 07dbb42..0000000
--- a/redis-tests.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 627bd89b45ba09b689e692a23370e5d82d9829a1 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 8 Feb 2018 05:47:28 +0100
-Subject: [PATCH] skip online test
-
----
- tests/RedisTest.php | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/tests/RedisTest.php b/tests/RedisTest.php
-index 4c0b7884..4d807a78 100644
---- a/tests/RedisTest.php
-+++ b/tests/RedisTest.php
-@@ -5164,9 +5164,13 @@ public function testMultipleConnect() {
- }
-
- public function testConnectException() {
-+ $host = 'github.com';
-+ if (gethostbyname($host) === $host) {
-+ return $this->markTestSkipped('online test');
-+ }
- $redis = new Redis();
- try {
-- $redis->connect('github.com', 6379, 0.01);
-+ $redis->connect($host, 6379, 0.01);
- } catch (Exception $e) {
- $this->assertTrue(strpos($e, "timed out") !== false);
- }