summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-redis.spec8
-rw-r--r--redis-pr840.patch22
2 files changed, 29 insertions, 1 deletions
diff --git a/php-pecl-redis.spec b/php-pecl-redis.spec
index 93fe0f6..d37e657 100644
--- a/php-pecl-redis.spec
+++ b/php-pecl-redis.spec
@@ -33,12 +33,14 @@
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis
Version: 2.2.8
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/redis
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: %{pecl_name}-pr840.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -110,6 +112,7 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{version} NTS
cd NTS
+%patch0 -p1 -b .pr840
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_REDIS_VERSION/{s/.* "//;s/".*$//;p}' php_redis.h)
@@ -294,6 +297,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Jun 17 2016 Remi Collet <remi@fedoraproject.org> - 2.2.8-2
+- test build for https://github.com/phpredis/phpredis/issues/742
+
* Thu Jun 9 2016 Remi Collet <remi@fedoraproject.org> - 2.2.8-1
- Update to 2.2.8 (stable)
diff --git a/redis-pr840.patch b/redis-pr840.patch
new file mode 100644
index 0000000..aea8aae
--- /dev/null
+++ b/redis-pr840.patch
@@ -0,0 +1,22 @@
+From 909f803f5a9d0af114ab86ce47dbcdcd3f387c8b Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Fri, 17 Jun 2016 12:34:11 +0200
+Subject: [PATCH] use str_efree to fix #742
+
+---
+ redis_commands.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/redis_commands.c b/redis_commands.c
+index a84f760..2f84577 100644
+--- a/redis_commands.c
++++ b/redis_commands.c
+@@ -1298,7 +1298,7 @@ int redis_set_cmd(INTERNAL_FUNCTION_PARAMETERS, RedisSock *redis_sock,
+ CMD_SET_SLOT(slot,key,key_len);
+
+ if(key_free) efree(key);
+- if(val_free) efree(val);
++ if(val_free) str_efree(val);
+
+ return SUCCESS;
+ }