summaryrefslogtreecommitdiffstats
path: root/php-pecl-redis.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-20 09:18:59 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-20 09:18:59 +0100
commitf390374a9d3043e063a9949a3adb91763b75595b (patch)
tree00d32d1c555ab5f784b4500dda69c1e082591e17 /php-pecl-redis.spec
parent39417a257692c10d14efc9f037fdce69d77a69bd (diff)
php-pecl-redis: fix tests
Diffstat (limited to 'php-pecl-redis.spec')
-rw-r--r--php-pecl-redis.spec7
1 files changed, 4 insertions, 3 deletions
diff --git a/php-pecl-redis.spec b/php-pecl-redis.spec
index c412123..e1be964 100644
--- a/php-pecl-redis.spec
+++ b/php-pecl-redis.spec
@@ -174,7 +174,8 @@ sed -e s/testClient/SKIP_testClient/ \
# Launch redis server
mkdir -p {run,log,lib}/redis
-sed -e "s:/var:$PWD:" \
+sed -e "s:/^pidfile.*$:/pidfile $PWD/run/redis.pid:" \
+ -e "s:/var:$PWD:" \
-e "/daemonize/s/no/yes/" \
/etc/redis.conf >redis.conf
# port number to allow 32/64 build at same time
@@ -200,8 +201,8 @@ ret=0
TestRedis.php || ret=1
# Cleanup
-if [ -f run/redis/redis.pid ]; then
- kill $(cat run/redis/redis.pid)
+if [ -f run/redis.pid ]; then
+ kill $(cat run/redis.pid)
fi
exit $ret