summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-09 08:13:59 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-09 08:13:59 +0200
commitc64825bf0b9b939adbad22f45570fdcec5337d1d (patch)
treeb13fbf7356a800a0473630b02c315ac3b0b025b3
parent7464b70023ad27b7030edc720c47db52dd7a78f8 (diff)
php-pecl-redis: 2.2.8 (php 5)
-rw-r--r--REFLECTION649
-rw-r--r--php-pecl-redis.spec33
2 files changed, 657 insertions, 25 deletions
diff --git a/REFLECTION b/REFLECTION
index 09661f8..ee05efa 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #178 redis version 2.2.7 ] {
+Extension [ <persistent> extension #206 redis version 2.2.8 ] {
- INI {
Entry [ redis.arrays.names <ALL> ]
@@ -19,9 +19,18 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
Entry [ redis.arrays.autorehash <ALL> ]
Current = ''
}
+ Entry [ redis.clusters.seeds <ALL> ]
+ Current = ''
+ }
+ Entry [ redis.clusters.timeout <ALL> ]
+ Current = ''
+ }
+ Entry [ redis.clusters.read_timeout <ALL> ]
+ Current = ''
+ }
}
- - Classes [3] {
+ - Classes [5] {
Class [ <internal:redis> class Redis ] {
- Constants [20] {
@@ -31,9 +40,9 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
Constant [ integer REDIS_LIST ] { 3 }
Constant [ integer REDIS_ZSET ] { 4 }
Constant [ integer REDIS_HASH ] { 5 }
+ Constant [ integer PIPELINE ] { 2 }
Constant [ integer ATOMIC ] { 0 }
Constant [ integer MULTI ] { 1 }
- Constant [ integer PIPELINE ] { 2 }
Constant [ integer OPT_SERIALIZER ] { 1 }
Constant [ integer OPT_PREFIX ] { 2 }
Constant [ integer OPT_READ_TIMEOUT ] { 3 }
@@ -56,7 +65,7 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
- Properties [0] {
}
- - Methods [201] {
+ - Methods [206] {
Method [ <internal:redis, ctor> public method __construct ] {
}
@@ -216,6 +225,9 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
Method [ <internal:redis> public method sAdd ] {
}
+ Method [ <internal:redis> public method sAddArray ] {
+ }
+
Method [ <internal:redis> public method sSize ] {
}
@@ -291,9 +303,6 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
Method [ <internal:redis> public method info ] {
}
- Method [ <internal:redis> public method resetStat ] {
- }
-
Method [ <internal:redis> public method select ] {
}
@@ -339,7 +348,7 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
Method [ <internal:redis> public method zRange ] {
}
- Method [ <internal:redis> public method zReverseRange ] {
+ Method [ <internal:redis> public method zRevRange ] {
}
Method [ <internal:redis> public method zRangeByScore ] {
@@ -351,6 +360,15 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
Method [ <internal:redis> public method zRangeByLex ] {
}
+ Method [ <internal:redis> public method zRevRangeByLex ] {
+ }
+
+ Method [ <internal:redis> public method zLexCount ] {
+ }
+
+ Method [ <internal:redis> public method zRemRangeByLex ] {
+ }
+
Method [ <internal:redis> public method zCount ] {
}
@@ -465,6 +483,9 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
Method [ <internal:redis> public method time ] {
}
+ Method [ <internal:redis> public method role ] {
+ }
+
Method [ <internal:redis> public method eval ] {
}
@@ -504,6 +525,9 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
Method [ <internal:redis> public method client ] {
}
+ Method [ <internal:redis> public method command ] {
+ }
+
Method [ <internal:redis> public method scan ] {
- Parameters [3] {
@@ -564,7 +588,7 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
Method [ <internal:redis> public method slowlog ] {
}
- Method [ <internal:redis> public method rawCommand ] {
+ Method [ <internal:redis> public method rawcommand ] {
}
Method [ <internal:redis> public method getHost ] {
@@ -675,7 +699,7 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
Method [ <internal:redis> public method sismember ] {
}
- Method [ <internal:redis> public method zrevrange ] {
+ Method [ <internal:redis> public method zReverseRange ] {
}
Method [ <internal:redis> public method sendEcho ] {
@@ -792,6 +816,549 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
}
}
+ Class [ <internal:redis> class RedisCluster ] {
+
+ - Constants [24] {
+ Constant [ integer REDIS_NOT_FOUND ] { 0 }
+ Constant [ integer REDIS_STRING ] { 1 }
+ Constant [ integer REDIS_SET ] { 2 }
+ Constant [ integer REDIS_LIST ] { 3 }
+ Constant [ integer REDIS_ZSET ] { 4 }
+ Constant [ integer REDIS_HASH ] { 5 }
+ Constant [ integer ATOMIC ] { 0 }
+ Constant [ integer MULTI ] { 1 }
+ Constant [ integer OPT_SERIALIZER ] { 1 }
+ Constant [ integer OPT_PREFIX ] { 2 }
+ Constant [ integer OPT_READ_TIMEOUT ] { 3 }
+ Constant [ integer SERIALIZER_NONE ] { 0 }
+ Constant [ integer SERIALIZER_PHP ] { 1 }
+ Constant [ integer OPT_SCAN ] { 4 }
+ Constant [ integer SCAN_RETRY ] { 1 }
+ Constant [ integer SCAN_NORETRY ] { 0 }
+ Constant [ integer OPT_SLAVE_FAILOVER ] { 5 }
+ Constant [ integer FAILOVER_NONE ] { 0 }
+ Constant [ integer FAILOVER_ERROR ] { 1 }
+ Constant [ integer FAILOVER_DISTRIBUTE ] { 2 }
+ Constant [ integer FAILOVER_DISTRIBUTE_SLAVES ] { 3 }
+ Constant [ integer SERIALIZER_IGBINARY ] { 2 }
+ Constant [ string AFTER ] { after }
+ Constant [ string BEFORE ] { before }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [158] {
+ Method [ <internal:redis, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:redis> public method close ] {
+ }
+
+ Method [ <internal:redis> public method get ] {
+ }
+
+ Method [ <internal:redis> public method set ] {
+ }
+
+ Method [ <internal:redis> public method mget ] {
+ }
+
+ Method [ <internal:redis> public method mset ] {
+ }
+
+ Method [ <internal:redis> public method msetnx ] {
+ }
+
+ Method [ <internal:redis> public method del ] {
+ }
+
+ Method [ <internal:redis> public method setex ] {
+ }
+
+ Method [ <internal:redis> public method psetex ] {
+ }
+
+ Method [ <internal:redis> public method setnx ] {
+ }
+
+ Method [ <internal:redis> public method getset ] {
+ }
+
+ Method [ <internal:redis> public method exists ] {
+ }
+
+ Method [ <internal:redis> public method keys ] {
+ }
+
+ Method [ <internal:redis> public method type ] {
+ }
+
+ Method [ <internal:redis> public method lpop ] {
+ }
+
+ Method [ <internal:redis> public method rpop ] {
+ }
+
+ Method [ <internal:redis> public method lset ] {
+ }
+
+ Method [ <internal:redis> public method spop ] {
+ }
+
+ Method [ <internal:redis> public method lpush ] {
+ }
+
+ Method [ <internal:redis> public method rpush ] {
+ }
+
+ Method [ <internal:redis> public method blpop ] {
+ }
+
+ Method [ <internal:redis> public method brpop ] {
+ }
+
+ Method [ <internal:redis> public method rpushx ] {
+ }
+
+ Method [ <internal:redis> public method lpushx ] {
+ }
+
+ Method [ <internal:redis> public method linsert ] {
+ }
+
+ Method [ <internal:redis> public method lindex ] {
+ }
+
+ Method [ <internal:redis> public method lrem ] {
+ }
+
+ Method [ <internal:redis> public method brpoplpush ] {
+ }
+
+ Method [ <internal:redis> public method rpoplpush ] {
+ }
+
+ Method [ <internal:redis> public method llen ] {
+ }
+
+ Method [ <internal:redis> public method scard ] {
+ }
+
+ Method [ <internal:redis> public method smembers ] {
+ }
+
+ Method [ <internal:redis> public method sismember ] {
+ }
+
+ Method [ <internal:redis> public method sadd ] {
+ }
+
+ Method [ <internal:redis> public method saddarray ] {
+ }
+
+ Method [ <internal:redis> public method srem ] {
+ }
+
+ Method [ <internal:redis> public method sunion ] {
+ }
+
+ Method [ <internal:redis> public method sunionstore ] {
+ }
+
+ Method [ <internal:redis> public method sinter ] {
+ }
+
+ Method [ <internal:redis> public method sinterstore ] {
+ }
+
+ Method [ <internal:redis> public method sdiff ] {
+ }
+
+ Method [ <internal:redis> public method sdiffstore ] {
+ }
+
+ Method [ <internal:redis> public method srandmember ] {
+ }
+
+ Method [ <internal:redis> public method strlen ] {
+ }
+
+ Method [ <internal:redis> public method persist ] {
+ }
+
+ Method [ <internal:redis> public method ttl ] {
+ }
+
+ Method [ <internal:redis> public method pttl ] {
+ }
+
+ Method [ <internal:redis> public method zcard ] {
+ }
+
+ Method [ <internal:redis> public method zcount ] {
+ }
+
+ Method [ <internal:redis> public method zremrangebyscore ] {
+ }
+
+ Method [ <internal:redis> public method zscore ] {
+ }
+
+ Method [ <internal:redis> public method zadd ] {
+ }
+
+ Method [ <internal:redis> public method zincrby ] {
+ }
+
+ Method [ <internal:redis> public method hlen ] {
+ }
+
+ Method [ <internal:redis> public method hkeys ] {
+ }
+
+ Method [ <internal:redis> public method hvals ] {
+ }
+
+ Method [ <internal:redis> public method hget ] {
+ }
+
+ Method [ <internal:redis> public method hgetall ] {
+ }
+
+ Method [ <internal:redis> public method hexists ] {
+ }
+
+ Method [ <internal:redis> public method hincrby ] {
+ }
+
+ Method [ <internal:redis> public method hset ] {
+ }
+
+ Method [ <internal:redis> public method hsetnx ] {
+ }
+
+ Method [ <internal:redis> public method hmget ] {
+ }
+
+ Method [ <internal:redis> public method hmset ] {
+ }
+
+ Method [ <internal:redis> public method hdel ] {
+ }
+
+ Method [ <internal:redis> public method hincrbyfloat ] {
+ }
+
+ Method [ <internal:redis> public method dump ] {
+ }
+
+ Method [ <internal:redis> public method zrank ] {
+ }
+
+ Method [ <internal:redis> public method zrevrank ] {
+ }
+
+ Method [ <internal:redis> public method incr ] {
+ }
+
+ Method [ <internal:redis> public method decr ] {
+ }
+
+ Method [ <internal:redis> public method incrby ] {
+ }
+
+ Method [ <internal:redis> public method decrby ] {
+ }
+
+ Method [ <internal:redis> public method incrbyfloat ] {
+ }
+
+ Method [ <internal:redis> public method expire ] {
+ }
+
+ Method [ <internal:redis> public method pexpire ] {
+ }
+
+ Method [ <internal:redis> public method expireat ] {
+ }
+
+ Method [ <internal:redis> public method pexpireat ] {
+ }
+
+ Method [ <internal:redis> public method append ] {
+ }
+
+ Method [ <internal:redis> public method getbit ] {
+ }
+
+ Method [ <internal:redis> public method setbit ] {
+ }
+
+ Method [ <internal:redis> public method bitop ] {
+ }
+
+ Method [ <internal:redis> public method bitpos ] {
+ }
+
+ Method [ <internal:redis> public method bitcount ] {
+ }
+
+ Method [ <internal:redis> public method lget ] {
+ }
+
+ Method [ <internal:redis> public method getrange ] {
+ }
+
+ Method [ <internal:redis> public method ltrim ] {
+ }
+
+ Method [ <internal:redis> public method lrange ] {
+ }
+
+ Method [ <internal:redis> public method zremrangebyrank ] {
+ }
+
+ Method [ <internal:redis> public method publish ] {
+ }
+
+ Method [ <internal:redis> public method rename ] {
+ }
+
+ Method [ <internal:redis> public method renamenx ] {
+ }
+
+ Method [ <internal:redis> public method pfcount ] {
+ }
+
+ Method [ <internal:redis> public method pfadd ] {
+ }
+
+ Method [ <internal:redis> public method pfmerge ] {
+ }
+
+ Method [ <internal:redis> public method setrange ] {
+ }
+
+ Method [ <internal:redis> public method restore ] {
+ }
+
+ Method [ <internal:redis> public method smove ] {
+ }
+
+ Method [ <internal:redis> public method zrange ] {
+ }
+
+ Method [ <internal:redis> public method zrevrange ] {
+ }
+
+ Method [ <internal:redis> public method zrangebyscore ] {
+ }
+
+ Method [ <internal:redis> public method zrevrangebyscore ] {
+ }
+
+ Method [ <internal:redis> public method zrangebylex ] {
+ }
+
+ Method [ <internal:redis> public method zrevrangebylex ] {
+ }
+
+ Method [ <internal:redis> public method zlexcount ] {
+ }
+
+ Method [ <internal:redis> public method zremrangebylex ] {
+ }
+
+ Method [ <internal:redis> public method zunionstore ] {
+ }
+
+ Method [ <internal:redis> public method zinterstore ] {
+ }
+
+ Method [ <internal:redis> public method zrem ] {
+ }
+
+ Method [ <internal:redis> public method sort ] {
+ }
+
+ Method [ <internal:redis> public method object ] {
+ }
+
+ Method [ <internal:redis> public method subscribe ] {
+ }
+
+ Method [ <internal:redis> public method psubscribe ] {
+ }
+
+ Method [ <internal:redis> public method unsubscribe ] {
+ }
+
+ Method [ <internal:redis> public method punsubscribe ] {
+ }
+
+ Method [ <internal:redis> public method eval ] {
+ }
+
+ Method [ <internal:redis> public method evalsha ] {
+ }
+
+ Method [ <internal:redis> public method scan ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> &$i_iterator ]
+ Parameter #1 [ <required> $str_node ]
+ Parameter #2 [ <optional> $str_pattern ]
+ Parameter #3 [ <optional> $i_count ]
+ }
+ }
+
+ Method [ <internal:redis> public method sscan ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> &$i_iterator ]
+ Parameter #2 [ <optional> $str_pattern ]
+ Parameter #3 [ <optional> $i_count ]
+ }
+ }
+
+ Method [ <internal:redis> public method zscan ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> &$i_iterator ]
+ Parameter #2 [ <optional> $str_pattern ]
+ Parameter #3 [ <optional> $i_count ]
+ }
+ }
+
+ Method [ <internal:redis> public method hscan ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $str_key ]
+ Parameter #1 [ <required> &$i_iterator ]
+ Parameter #2 [ <optional> $str_pattern ]
+ Parameter #3 [ <optional> $i_count ]
+ }
+ }
+
+ Method [ <internal:redis> public method getmode ] {
+ }
+
+ Method [ <internal:redis> public method getlasterror ] {
+ }
+
+ Method [ <internal:redis> public method clearlasterror ] {
+ }
+
+ Method [ <internal:redis> public method getoption ] {
+ }
+
+ Method [ <internal:redis> public method setoption ] {
+ }
+
+ Method [ <internal:redis> public method _prefix ] {
+ }
+
+ Method [ <internal:redis> public method _serialize ] {
+ }
+
+ Method [ <internal:redis> public method _unserialize ] {
+ }
+
+ Method [ <internal:redis> public method _masters ] {
+ }
+
+ Method [ <internal:redis> public method _redir ] {
+ }
+
+ Method [ <internal:redis> public method multi ] {
+ }
+
+ Method [ <internal:redis> public method exec ] {
+ }
+
+ Method [ <internal:redis> public method discard ] {
+ }
+
+ Method [ <internal:redis> public method watch ] {
+ }
+
+ Method [ <internal:redis> public method unwatch ] {
+ }
+
+ Method [ <internal:redis> public method save ] {
+ }
+
+ Method [ <internal:redis> public method bgsave ] {
+ }
+
+ Method [ <internal:redis> public method flushdb ] {
+ }
+
+ Method [ <internal:redis> public method flushall ] {
+ }
+
+ Method [ <internal:redis> public method dbsize ] {
+ }
+
+ Method [ <internal:redis> public method bgrewriteaof ] {
+ }
+
+ Method [ <internal:redis> public method lastsave ] {
+ }
+
+ Method [ <internal:redis> public method info ] {
+ }
+
+ Method [ <internal:redis> public method role ] {
+ }
+
+ Method [ <internal:redis> public method time ] {
+ }
+
+ Method [ <internal:redis> public method randomkey ] {
+ }
+
+ Method [ <internal:redis> public method ping ] {
+ }
+
+ Method [ <internal:redis> public method echo ] {
+ }
+
+ Method [ <internal:redis> public method command ] {
+ }
+
+ Method [ <internal:redis> public method rawcommand ] {
+ }
+
+ Method [ <internal:redis> public method cluster ] {
+ }
+
+ Method [ <internal:redis> public method client ] {
+ }
+
+ Method [ <internal:redis> public method config ] {
+ }
+
+ Method [ <internal:redis> public method pubsub ] {
+ }
+
+ Method [ <internal:redis> public method script ] {
+ }
+
+ Method [ <internal:redis> public method slowlog ] {
+ }
+ }
+ }
+
Class [ <internal:redis> class RedisException extends RuntimeException ] {
- Constants [0] {
@@ -810,7 +1377,7 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -820,6 +1387,66 @@ Extension [ <persistent> extension #178 redis version 2.2.7 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:redis> class RedisClusterException extends RuntimeException ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
diff --git a/php-pecl-redis.spec b/php-pecl-redis.spec
index f1f8069..93fe0f6 100644
--- a/php-pecl-redis.spec
+++ b/php-pecl-redis.spec
@@ -15,9 +15,9 @@
%else
%global sub_prefix %{scl_prefix}
%endif
+%scl_package php-pecl-redis
%endif
-%{?scl: %scl_package php-pecl-redis}
%global pecl_name redis
%global with_zts 0%{?__ztsphp:1}
@@ -32,14 +32,12 @@
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis
-Version: 2.2.7
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.2.8
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/redis
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://github.com/nicolasff/phpredis/issues/332 - missing tests
-Source1: https://github.com/phpredis/phpredis/archive/%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel
@@ -101,7 +99,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
-%setup -q -c -a 1
+%setup -q -c
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -110,8 +108,6 @@ sed -e 's/role="test"/role="src"/' \
# rename source folder
mv %{pecl_name}-%{version} NTS
-# tests folder from github archive
-mv phpredis-%{version}/tests NTS/tests
cd NTS
@@ -142,6 +138,17 @@ extension = %{pecl_name}.so
;session.save_handler = %{pecl_name}
;session.save_path = "tcp://host1:6379?weight=1, tcp://host2:6379?weight=2&timeout=2.5, tcp://host3:6379?weight=2"
+
+; Configuration
+;redis.arrays.names = ''
+;redis.arrays.hosts = ''
+;redis.arrays.previous = ''
+;redis.arrays.functions = ''
+;redis.arrays.index = ''
+;redis.arrays.autorehash = ''
+;redis.clusters.seeds = ''
+;redis.clusters.timeout = ''
+;redis.clusters.read_timeout = ''
EOF
@@ -207,11 +214,6 @@ done
%if %{with_tests}
cd NTS/tests
-# this test requires redis >= 2.6.9
-# https://github.com/nicolasff/phpredis/pull/333
-sed -e s/testClient/SKIP_testClient/ \
- -i TestRedis.php
-
# Launch redis server
mkdir -p {run,log,lib}/redis
sed -e "s:/^pidfile.*$:/pidfile $PWD/run/redis.pid:" \
@@ -230,7 +232,7 @@ port=6382
%endif
%endif
sed -e "s/6379/$port/" -i redis.conf
-sed -e "s/6379/$port/" -i TestRedis.php
+sed -e "s/6379/$port/" -i *.php
%{_bindir}/redis-server ./redis.conf
# Run the test Suite
@@ -292,6 +294,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Jun 9 2016 Remi Collet <remi@fedoraproject.org> - 2.2.8-1
+- Update to 2.2.8 (stable)
+
* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 2.2.7-3
- adapt for F24