summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-03 11:49:45 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-03 11:49:45 +0100
commit709c0b4106d5e4b9027c15a502bea3312370ffcd (patch)
tree8a9c7ccb737a50f7cdda0ad738775ef934b9f8f8
parentf9645495a45bc0e59b63826309c3d13463adf642 (diff)
php-pecl-redis: 2.2.8-dev, enable igbinary support
-rw-r--r--REFLECTION-PHP78
-rw-r--r--php-pecl-redis-php7.spec9
2 files changed, 11 insertions, 6 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index 9bac0a4..12c58f9 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #85 redis version 2.2.8-dev ] {
+Extension [ <persistent> extension #88 redis version 2.2.8-dev ] {
- INI {
Entry [ redis.arrays.names <ALL> ]
@@ -33,7 +33,7 @@ Extension [ <persistent> extension #85 redis version 2.2.8-dev ] {
- Classes [5] {
Class [ <internal:redis> class Redis ] {
- - Constants [19] {
+ - Constants [20] {
Constant [ integer REDIS_NOT_FOUND ] { 0 }
Constant [ integer REDIS_STRING ] { 1 }
Constant [ integer REDIS_SET ] { 2 }
@@ -51,6 +51,7 @@ Extension [ <persistent> extension #85 redis version 2.2.8-dev ] {
Constant [ integer OPT_SCAN ] { 4 }
Constant [ integer SCAN_RETRY ] { 1 }
Constant [ integer SCAN_NORETRY ] { 0 }
+ Constant [ integer SERIALIZER_IGBINARY ] { 2 }
Constant [ string AFTER ] { after }
Constant [ string BEFORE ] { before }
}
@@ -817,7 +818,7 @@ Extension [ <persistent> extension #85 redis version 2.2.8-dev ] {
Class [ <internal:redis> class RedisCluster ] {
- - Constants [22] {
+ - Constants [23] {
Constant [ integer REDIS_NOT_FOUND ] { 0 }
Constant [ integer REDIS_STRING ] { 1 }
Constant [ integer REDIS_SET ] { 2 }
@@ -838,6 +839,7 @@ Extension [ <persistent> extension #85 redis version 2.2.8-dev ] {
Constant [ integer FAILOVER_NONE ] { 0 }
Constant [ integer FAILOVER_ERROR ] { 1 }
Constant [ integer FAILOVER_DISTRIBUTE ] { 2 }
+ Constant [ integer SERIALIZER_IGBINARY ] { 2 }
Constant [ string AFTER ] { after }
Constant [ string BEFORE ] { before }
}
diff --git a/php-pecl-redis-php7.spec b/php-pecl-redis-php7.spec
index 041b233..3b493f0 100644
--- a/php-pecl-redis-php7.spec
+++ b/php-pecl-redis-php7.spec
@@ -31,7 +31,7 @@
%global pecl_name redis
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{?_with_tests:1}
-%global with_igbin 0
+%global with_igbin 1
%if "%{php_version}" < "5.6"
# after igbinary
%global ini_name %{pecl_name}.ini
@@ -44,7 +44,7 @@ Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis
Version: 2.2.8
%if 0%{?gh_date}
-Release: 0.4.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
@@ -330,6 +330,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Mar 3 2016 Remi Collet <remi@fedoraproject.org> - 2.2.8-0.5.20160215git2887ad1
+- enable igbinary support
+
* Fri Feb 19 2016 Remi Collet <remi@fedoraproject.org> - 2.2.8-0.4.20160215git2887ad1
- refresh
@@ -407,4 +410,4 @@ rm -rf %{buildroot}
- enable ZTS build
* Tue Aug 28 2012 Remi Collet <remi@fedoraproject.org> - 2.2.1-1
-- initial package \ No newline at end of file
+- initial package