summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-21 06:59:48 +0100
committerRemi Collet <remi@remirepo.net>2017-12-21 06:59:48 +0100
commit6771cd2d981c671fbb0c83ecc8a5de8f7bcdbcdc (patch)
treea533f40f3cc210896e0c7e75a062ede48862a910
parent70c08a71848f740b80887e6418aa70a418025f8a (diff)
v3.1.5
-rw-r--r--REFLECTION90
-rw-r--r--php-pecl-redis.spec5
2 files changed, 49 insertions, 46 deletions
diff --git a/REFLECTION b/REFLECTION
index 4b9cdae..16d847a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #184 redis version 3.1.5RC2 ] {
+Extension [ <persistent> extension #185 redis version 3.1.5 ] {
- Dependencies {
Dependency [ igbinary (Required) ]
@@ -38,26 +38,26 @@ Extension [ <persistent> extension #184 redis version 3.1.5RC2 ] {
Class [ <internal:redis> class Redis ] {
- Constants [20] {
- Constant [ integer REDIS_NOT_FOUND ] { 0 }
- Constant [ integer REDIS_STRING ] { 1 }
- Constant [ integer REDIS_SET ] { 2 }
- Constant [ integer REDIS_LIST ] { 3 }
- Constant [ integer REDIS_ZSET ] { 4 }
- Constant [ integer REDIS_HASH ] { 5 }
- Constant [ integer PIPELINE ] { 2 }
- Constant [ integer ATOMIC ] { 0 }
- Constant [ integer MULTI ] { 1 }
- Constant [ integer OPT_SERIALIZER ] { 1 }
- Constant [ integer OPT_PREFIX ] { 2 }
- Constant [ integer OPT_READ_TIMEOUT ] { 3 }
- Constant [ integer SERIALIZER_NONE ] { 0 }
- Constant [ integer SERIALIZER_PHP ] { 1 }
- Constant [ integer SERIALIZER_IGBINARY ] { 2 }
- Constant [ integer OPT_SCAN ] { 4 }
- Constant [ integer SCAN_RETRY ] { 1 }
- Constant [ integer SCAN_NORETRY ] { 0 }
- Constant [ string AFTER ] { after }
- Constant [ string BEFORE ] { before }
+ Constant [ public integer REDIS_NOT_FOUND ] { 0 }
+ Constant [ public integer REDIS_STRING ] { 1 }
+ Constant [ public integer REDIS_SET ] { 2 }
+ Constant [ public integer REDIS_LIST ] { 3 }
+ Constant [ public integer REDIS_ZSET ] { 4 }
+ Constant [ public integer REDIS_HASH ] { 5 }
+ Constant [ public integer PIPELINE ] { 2 }
+ Constant [ public integer ATOMIC ] { 0 }
+ Constant [ public integer MULTI ] { 1 }
+ Constant [ public integer OPT_SERIALIZER ] { 1 }
+ Constant [ public integer OPT_PREFIX ] { 2 }
+ Constant [ public integer OPT_READ_TIMEOUT ] { 3 }
+ Constant [ public integer SERIALIZER_NONE ] { 0 }
+ Constant [ public integer SERIALIZER_PHP ] { 1 }
+ Constant [ public integer SERIALIZER_IGBINARY ] { 2 }
+ Constant [ public integer OPT_SCAN ] { 4 }
+ Constant [ public integer SCAN_RETRY ] { 1 }
+ Constant [ public integer SCAN_NORETRY ] { 0 }
+ Constant [ public string AFTER ] { after }
+ Constant [ public string BEFORE ] { before }
}
- Static properties [0] {
@@ -844,30 +844,30 @@ Extension [ <persistent> extension #184 redis version 3.1.5RC2 ] {
Class [ <internal:redis> class RedisCluster ] {
- Constants [24] {
- Constant [ integer REDIS_NOT_FOUND ] { 0 }
- Constant [ integer REDIS_STRING ] { 1 }
- Constant [ integer REDIS_SET ] { 2 }
- Constant [ integer REDIS_LIST ] { 3 }
- Constant [ integer REDIS_ZSET ] { 4 }
- Constant [ integer REDIS_HASH ] { 5 }
- Constant [ integer ATOMIC ] { 0 }
- Constant [ integer MULTI ] { 1 }
- Constant [ integer OPT_SERIALIZER ] { 1 }
- Constant [ integer OPT_PREFIX ] { 2 }
- Constant [ integer OPT_READ_TIMEOUT ] { 3 }
- Constant [ integer SERIALIZER_NONE ] { 0 }
- Constant [ integer SERIALIZER_PHP ] { 1 }
- Constant [ integer SERIALIZER_IGBINARY ] { 2 }
- Constant [ integer OPT_SCAN ] { 4 }
- Constant [ integer SCAN_RETRY ] { 1 }
- Constant [ integer SCAN_NORETRY ] { 0 }
- Constant [ integer OPT_SLAVE_FAILOVER ] { 5 }
- Constant [ integer FAILOVER_NONE ] { 0 }
- Constant [ integer FAILOVER_ERROR ] { 1 }
- Constant [ integer FAILOVER_DISTRIBUTE ] { 2 }
- Constant [ integer FAILOVER_DISTRIBUTE_SLAVES ] { 3 }
- Constant [ string AFTER ] { after }
- Constant [ string BEFORE ] { before }
+ Constant [ public integer REDIS_NOT_FOUND ] { 0 }
+ Constant [ public integer REDIS_STRING ] { 1 }
+ Constant [ public integer REDIS_SET ] { 2 }
+ Constant [ public integer REDIS_LIST ] { 3 }
+ Constant [ public integer REDIS_ZSET ] { 4 }
+ Constant [ public integer REDIS_HASH ] { 5 }
+ Constant [ public integer ATOMIC ] { 0 }
+ Constant [ public integer MULTI ] { 1 }
+ Constant [ public integer OPT_SERIALIZER ] { 1 }
+ Constant [ public integer OPT_PREFIX ] { 2 }
+ Constant [ public integer OPT_READ_TIMEOUT ] { 3 }
+ Constant [ public integer SERIALIZER_NONE ] { 0 }
+ Constant [ public integer SERIALIZER_PHP ] { 1 }
+ Constant [ public integer SERIALIZER_IGBINARY ] { 2 }
+ Constant [ public integer OPT_SCAN ] { 4 }
+ Constant [ public integer SCAN_RETRY ] { 1 }
+ Constant [ public integer SCAN_NORETRY ] { 0 }
+ Constant [ public integer OPT_SLAVE_FAILOVER ] { 5 }
+ Constant [ public integer FAILOVER_NONE ] { 0 }
+ Constant [ public integer FAILOVER_ERROR ] { 1 }
+ Constant [ public integer FAILOVER_DISTRIBUTE ] { 2 }
+ Constant [ public integer FAILOVER_DISTRIBUTE_SLAVES ] { 3 }
+ Constant [ public string AFTER ] { after }
+ Constant [ public string BEFORE ] { before }
}
- Static properties [0] {
diff --git a/php-pecl-redis.spec b/php-pecl-redis.spec
index 1ba3868..a5bcc91 100644
--- a/php-pecl-redis.spec
+++ b/php-pecl-redis.spec
@@ -28,7 +28,7 @@
%global ini_name 50-%{pecl_name}.ini
%endif
%global upstream_version 3.1.5
-%global upstream_prever RC2
+#global upstream_prever RC2
Summary: Extension for communicating with the Redis key-value store
Name: %{?sub_prefix}php-pecl-redis
@@ -305,6 +305,9 @@ fi
%changelog
+* Thu Dec 21 2017 Remi Collet <remi@remirepo.net> - 3.1.5-1
+- update to 3.1.5 (stable)
+
* Mon Dec 11 2017 Remi Collet <remi@remirepo.net> - 3.1.5~RC2-1
- update to 3.1.5RC2 (beta)