summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION148
-rw-r--r--php-pecl-rdkafka6.spec64
3 files changed, 192 insertions, 26 deletions
diff --git a/PHPINFO b/PHPINFO
index b68551f..ca55913 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,6 +3,6 @@ rdkafka
rdkafka support => enabled
version => 6.0.3
-build date => Jul 4 2022 00:00:00
-librdkafka version (runtime) => 1.9.0
-librdkafka version (build) => 1.9.0.255
+build date => Jan 19 2023 00:00:00
+librdkafka version (runtime) => 2.0.0
+librdkafka version (build) => 2.0.0.255
diff --git a/REFLECTION b/REFLECTION
index fdfe788..124e729 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
+Extension [ <persistent> extension #120 rdkafka version 6.0.3 ] {
- Constants [184] {
Constant [ int RD_KAFKA_CONSUMER ] { 1 }
@@ -11,8 +11,8 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Constant [ int RD_KAFKA_PURGE_F_QUEUE ] { 1 }
Constant [ int RD_KAFKA_PURGE_F_INFLIGHT ] { 2 }
Constant [ int RD_KAFKA_PURGE_F_NON_BLOCKING ] { 4 }
- Constant [ int RD_KAFKA_VERSION ] { 17367295 }
- Constant [ int RD_KAFKA_BUILD_VERSION ] { 17367295 }
+ Constant [ int RD_KAFKA_VERSION ] { 33554687 }
+ Constant [ int RD_KAFKA_BUILD_VERSION ] { 33554687 }
Constant [ int RD_KAFKA_RESP_ERR__BEGIN ] { -200 }
Constant [ int RD_KAFKA_RESP_ERR__BAD_MSG ] { -199 }
Constant [ int RD_KAFKA_RESP_ERR__BAD_COMPRESSION ] { -198 }
@@ -265,6 +265,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> string $broker_list ]
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method getMetadata ] {
@@ -274,12 +275,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #1 [ <required> ?RdKafka\Topic $only_topic ]
Parameter #2 [ <required> int $timeout_ms ]
}
+ - Tentative return [ RdKafka\Metadata ]
}
Method [ <internal:rdkafka> public method getOutQLen ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal, deprecated:rdkafka> public method metadata ] {
@@ -289,6 +292,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #1 [ <required> ?RdKafka\Topic $only_topic ]
Parameter #2 [ <required> int $timeout_ms ]
}
+ - Tentative return [ RdKafka\Metadata ]
}
Method [ <internal, deprecated:rdkafka> public method setLogLevel ] {
@@ -296,6 +300,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $level ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method newTopic ] {
@@ -304,12 +309,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> string $topic_name ]
Parameter #1 [ <optional> ?RdKafka\TopicConf $topic_conf = null ]
}
+ - Tentative return [ RdKafka\Topic ]
}
Method [ <internal, deprecated:rdkafka> public method outqLen ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method poll ] {
@@ -317,6 +324,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeout_ms ]
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method flush ] {
@@ -324,6 +332,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeout_ms ]
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method purge ] {
@@ -331,6 +340,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $purge_flags ]
}
+ - Tentative return [ int ]
}
Method [ <internal, deprecated:rdkafka> public method setLogger ] {
@@ -338,6 +348,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $logger ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method queryWatermarkOffsets ] {
@@ -349,6 +360,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #3 [ <required> int &$high ]
Parameter #4 [ <required> int $timeout_ms ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method offsetsForTimes ] {
@@ -357,6 +369,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> array $topic_partitions ]
Parameter #1 [ <required> int $timeout_ms ]
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka> public method pausePartitions ] {
@@ -364,6 +377,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> array $topic_partitions ]
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka> public method resumePartitions ] {
@@ -371,6 +385,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> array $topic_partitions ]
}
+ - Tentative return [ array ]
}
}
}
@@ -390,7 +405,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
}
- Methods [17] {
- Method [ <internal:rdkafka, overwrites RdKafka, ctor> public method __construct ] {
+ Method [ <internal:rdkafka, ctor> public method __construct ] {
- Parameters [1] {
Parameter #0 [ <optional> ?RdKafka\Conf $conf = null ]
@@ -401,6 +416,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ RdKafka\Queue ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method addBrokers ] {
@@ -408,6 +424,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> string $broker_list ]
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method getMetadata ] {
@@ -417,12 +434,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #1 [ <required> ?RdKafka\Topic $only_topic ]
Parameter #2 [ <required> int $timeout_ms ]
}
+ - Tentative return [ RdKafka\Metadata ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method getOutQLen ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal, deprecated:rdkafka, inherits RdKafka> public method metadata ] {
@@ -432,6 +451,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #1 [ <required> ?RdKafka\Topic $only_topic ]
Parameter #2 [ <required> int $timeout_ms ]
}
+ - Tentative return [ RdKafka\Metadata ]
}
Method [ <internal, deprecated:rdkafka, inherits RdKafka> public method setLogLevel ] {
@@ -439,6 +459,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $level ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method newTopic ] {
@@ -447,12 +468,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> string $topic_name ]
Parameter #1 [ <optional> ?RdKafka\TopicConf $topic_conf = null ]
}
+ - Tentative return [ RdKafka\Topic ]
}
Method [ <internal, deprecated:rdkafka, inherits RdKafka> public method outqLen ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method poll ] {
@@ -460,6 +483,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeout_ms ]
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method flush ] {
@@ -467,6 +491,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeout_ms ]
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method purge ] {
@@ -474,6 +499,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $purge_flags ]
}
+ - Tentative return [ int ]
}
Method [ <internal, deprecated:rdkafka, inherits RdKafka> public method setLogger ] {
@@ -481,6 +507,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $logger ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method queryWatermarkOffsets ] {
@@ -492,6 +519,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #3 [ <required> int &$high ]
Parameter #4 [ <required> int $timeout_ms ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method offsetsForTimes ] {
@@ -500,6 +528,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> array $topic_partitions ]
Parameter #1 [ <required> int $timeout_ms ]
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method pausePartitions ] {
@@ -507,6 +536,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> array $topic_partitions ]
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method resumePartitions ] {
@@ -514,6 +544,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> array $topic_partitions ]
}
+ - Tentative return [ array ]
}
}
}
@@ -533,7 +564,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
}
- Methods [20] {
- Method [ <internal:rdkafka, overwrites RdKafka, ctor> public method __construct ] {
+ Method [ <internal:rdkafka, ctor> public method __construct ] {
- Parameters [1] {
Parameter #0 [ <optional> ?RdKafka\Conf $conf = null ]
@@ -545,12 +576,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeout_ms ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method beginTransaction ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method commitTransaction ] {
@@ -558,6 +591,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeout_ms ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method abortTransaction ] {
@@ -565,6 +599,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeout_ms ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method addBrokers ] {
@@ -572,6 +607,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> string $broker_list ]
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method getMetadata ] {
@@ -581,12 +617,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #1 [ <required> ?RdKafka\Topic $only_topic ]
Parameter #2 [ <required> int $timeout_ms ]
}
+ - Tentative return [ RdKafka\Metadata ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method getOutQLen ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal, deprecated:rdkafka, inherits RdKafka> public method metadata ] {
@@ -596,6 +634,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #1 [ <required> ?RdKafka\Topic $only_topic ]
Parameter #2 [ <required> int $timeout_ms ]
}
+ - Tentative return [ RdKafka\Metadata ]
}
Method [ <internal, deprecated:rdkafka, inherits RdKafka> public method setLogLevel ] {
@@ -603,6 +642,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $level ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method newTopic ] {
@@ -611,12 +651,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> string $topic_name ]
Parameter #1 [ <optional> ?RdKafka\TopicConf $topic_conf = null ]
}
+ - Tentative return [ RdKafka\Topic ]
}
Method [ <internal, deprecated:rdkafka, inherits RdKafka> public method outqLen ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method poll ] {
@@ -624,6 +666,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeout_ms ]
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method flush ] {
@@ -631,6 +674,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeout_ms ]
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method purge ] {
@@ -638,6 +682,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $purge_flags ]
}
+ - Tentative return [ int ]
}
Method [ <internal, deprecated:rdkafka, inherits RdKafka> public method setLogger ] {
@@ -645,6 +690,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $logger ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method queryWatermarkOffsets ] {
@@ -656,6 +702,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #3 [ <required> int &$high ]
Parameter #4 [ <required> int $timeout_ms ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method offsetsForTimes ] {
@@ -664,6 +711,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> array $topic_partitions ]
Parameter #1 [ <required> int $timeout_ms ]
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method pausePartitions ] {
@@ -671,6 +719,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> array $topic_partitions ]
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka, inherits RdKafka> public method resumePartitions ] {
@@ -678,6 +727,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> array $topic_partitions ]
}
+ - Tentative return [ array ]
}
}
}
@@ -696,8 +746,8 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -714,6 +764,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -798,6 +849,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka> public method set ] {
@@ -806,6 +858,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> string $name ]
Parameter #1 [ <required> string $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal, deprecated:rdkafka> public method setDefaultTopicConf ] {
@@ -813,6 +866,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> RdKafka\TopicConf $topic_conf ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method setErrorCb ] {
@@ -820,6 +874,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method setDrMsgCb ] {
@@ -827,6 +882,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method setStatsCb ] {
@@ -834,6 +890,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method setRebalanceCb ] {
@@ -841,6 +898,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method setConsumeCb ] {
@@ -848,6 +906,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method setOffsetCommitCb ] {
@@ -855,6 +914,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method setLogCb ] {
@@ -862,6 +922,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> callable $callback ]
}
+ - Tentative return [ void ]
}
}
}
@@ -891,6 +952,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka> public method set ] {
@@ -899,6 +961,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> string $name ]
Parameter #1 [ <required> string $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method setPartitioner ] {
@@ -906,6 +969,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $partitioner ]
}
+ - Tentative return [ void ]
}
}
}
@@ -924,8 +988,8 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Properties [8] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ private string $error_string ]
Property [ private bool $isFatal ]
Property [ private bool $isRetriable ]
@@ -949,30 +1013,35 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:rdkafka> public method isFatal ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:rdkafka> public method isRetriable ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:rdkafka> public method transactionRequiresAbort ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -1062,12 +1131,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <optional> ?array $topic_partitions = null ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method getAssignment ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka> public method commit ] {
@@ -1075,12 +1146,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <optional> RdKafka\Message|array|null $message_or_offsets = null ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method close ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method commitAsync ] {
@@ -1088,6 +1161,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <optional> RdKafka\Message|array|null $message_or_offsets = null ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method consume ] {
@@ -1095,6 +1169,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeout_ms ]
}
+ - Tentative return [ RdKafka\Message ]
}
Method [ <internal:rdkafka> public method subscribe ] {
@@ -1102,18 +1177,21 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> array $topics ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method getSubscription ] {
- Parameters [0] {
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka> public method unsubscribe ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method getMetadata ] {
@@ -1123,6 +1201,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #1 [ <required> ?RdKafka\Topic $only_topic ]
Parameter #2 [ <required> int $timeout_ms ]
}
+ - Tentative return [ RdKafka\Metadata ]
}
Method [ <internal:rdkafka> public method newTopic ] {
@@ -1131,6 +1210,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> string $topic_name ]
Parameter #1 [ <optional> ?RdKafka\TopicConf $topic_conf = null ]
}
+ - Tentative return [ RdKafka\KafkaConsumerTopic ]
}
Method [ <internal:rdkafka> public method getCommittedOffsets ] {
@@ -1139,6 +1219,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> array $topic_partitions ]
Parameter #1 [ <required> int $timeout_ms ]
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka> public method getOffsetPositions ] {
@@ -1146,6 +1227,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> array $topic_partitions ]
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka> public method queryWatermarkOffsets ] {
@@ -1157,6 +1239,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #3 [ <required> int &$high ]
Parameter #4 [ <required> int $timeout_ms ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method offsetsForTimes ] {
@@ -1165,6 +1248,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> array $topic_partitions ]
Parameter #1 [ <required> int $timeout_ms ]
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka> public method pausePartitions ] {
@@ -1172,6 +1256,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> array $topic_partitions ]
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka> public method resumePartitions ] {
@@ -1179,6 +1264,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> array $topic_partitions ]
}
+ - Tentative return [ array ]
}
}
}
@@ -1212,6 +1298,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ ?string ]
}
}
}
@@ -1235,24 +1322,28 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method getOrigBrokerName ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:rdkafka> public method getBrokers ] {
- Parameters [0] {
}
+ - Tentative return [ RdKafka\Metadata\Collection ]
}
Method [ <internal:rdkafka> public method getTopics ] {
- Parameters [0] {
}
+ - Tentative return [ RdKafka\Metadata\Collection ]
}
}
}
@@ -1276,18 +1367,21 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:rdkafka> public method getErr ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method getPartitions ] {
- Parameters [0] {
}
+ - Tentative return [ RdKafka\Metadata\Collection ]
}
}
}
@@ -1311,18 +1405,21 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method getHost ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
Method [ <internal:rdkafka> public method getPort ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
}
}
@@ -1346,30 +1443,35 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method getErr ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method getLeader ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method getReplicas ] {
- Parameters [0] {
}
+ - Tentative return [ RdKafka\Metadata\Collection ]
}
Method [ <internal:rdkafka> public method getIsrs ] {
- Parameters [0] {
}
+ - Tentative return [ RdKafka\Metadata\Collection ]
}
}
}
@@ -1393,36 +1495,42 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:rdkafka, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
}
}
@@ -1455,6 +1563,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ ?string ]
}
Method [ <internal:rdkafka> public method setTopic ] {
@@ -1462,12 +1571,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> string $topic_name ]
}
+ - Tentative return [ RdKafka\TopicPartition ]
}
Method [ <internal:rdkafka> public method getPartition ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method setPartition ] {
@@ -1475,12 +1586,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $partition ]
}
+ - Tentative return [ RdKafka\TopicPartition ]
}
Method [ <internal:rdkafka> public method getOffset ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method setOffset ] {
@@ -1488,12 +1601,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $offset ]
}
+ - Tentative return [ RdKafka\TopicPartition ]
}
Method [ <internal:rdkafka> public method getErr ] {
- Parameters [0] {
}
+ - Tentative return [ ?int ]
}
}
}
@@ -1524,6 +1639,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeout_ms ]
}
+ - Tentative return [ ?RdKafka\Message ]
}
}
}
@@ -1547,6 +1663,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
}
}
@@ -1579,6 +1696,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #1 [ <required> int $offset ]
Parameter #2 [ <required> RdKafka\Queue $queue ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method consumeCallback ] {
@@ -1588,6 +1706,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #1 [ <required> int $timeout_ms ]
Parameter #2 [ <required> callable $callback ]
}
+ - Tentative return [ int ]
}
Method [ <internal:rdkafka> public method consumeStart ] {
@@ -1596,6 +1715,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> int $partition ]
Parameter #1 [ <required> int $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method consumeStop ] {
@@ -1603,6 +1723,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $partition ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method consume ] {
@@ -1611,6 +1732,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> int $partition ]
Parameter #1 [ <required> int $timeout_ms ]
}
+ - Tentative return [ ?RdKafka\Message ]
}
Method [ <internal:rdkafka> public method consumeBatch ] {
@@ -1620,6 +1742,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #1 [ <required> int $timeout_ms ]
Parameter #2 [ <required> int $batch_size ]
}
+ - Tentative return [ array ]
}
Method [ <internal:rdkafka> public method offsetStore ] {
@@ -1628,12 +1751,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> int $partition ]
Parameter #1 [ <required> int $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, inherits RdKafka\Topic> public method getName ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
}
}
@@ -1665,12 +1790,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #0 [ <required> int $partition ]
Parameter #1 [ <required> int $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, inherits RdKafka\Topic> public method getName ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
}
}
@@ -1705,6 +1832,7 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #3 [ <optional> ?string $key = null ]
Parameter #4 [ <optional> ?string $msg_opaque = null ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka> public method producev ] {
@@ -1718,12 +1846,14 @@ Extension [ <persistent> extension #118 rdkafka version 6.0.3 ] {
Parameter #5 [ <optional> ?int $timestamp_ms = null ]
Parameter #6 [ <optional> ?string $msg_opaque = null ]
}
+ - Tentative return [ void ]
}
Method [ <internal:rdkafka, inherits RdKafka\Topic> public method getName ] {
- Parameters [0] {
}
+ - Tentative return [ string ]
}
}
}
diff --git a/php-pecl-rdkafka6.spec b/php-pecl-rdkafka6.spec
index 11d5d87..12a3716 100644
--- a/php-pecl-rdkafka6.spec
+++ b/php-pecl-rdkafka6.spec
@@ -1,14 +1,17 @@
# remirepo/fedora spec file for php-pecl-rdkafka6
#
-# Copyright (c) 2015-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
+
+# use library installed in /opt
+%bcond_without move_to_opt
+
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-rdkafka
+%scl_package php-pecl-rdkafka6
%endif
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -16,38 +19,46 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
%global ini_name 40-%{pecl_name}.ini
+%if %{with move_to_opt}
+# Disable RPATH check
+%global __arch_install_post /bin/true
+%global __brp_check_rpaths /bin/true
+
+%global buildver %(PKG_CONFIG_PATH=/opt/%{?vendeur:%{vendeur}/}librdkafka/%{_lib}/pkgconfig pkg-config --silence-errors --modversion rdkafka 2>/dev/null || echo 65536)
+%else
%global buildver %(pkg-config --silence-errors --modversion rdkafka 2>/dev/null || echo 65536)
+%endif
%global upstream_version 6.0.3
#global upstream_prever RC2
Summary: Kafka client based on librdkafka
-Name: %{?sub_prefix}php-pecl-%{pecl_name}6
+Name: %{?scl_prefix}php-pecl-%{pecl_name}6
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: librdkafka1php-devel >= 1.9
+%if %{with move_to_opt}
+BuildRequires: %{?vendeur:%{vendeur}-}librdkafka-devel >= 2
+Requires: %{?vendeur:%{vendeur}-}librdkafka%{?_isa} >= %{buildver}
+%else
+BuildRequires: librdkafka-devel >= 1.4
+%endif
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Requires: librdkafka1php%{?_isa} >= %{buildver}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9 || "%{php_version}" >= "8.1"
Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 5
@@ -64,6 +75,11 @@ Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}4 < 5
Provides: %{?scl_prefix}php-pecl-%{pecl_name}4 = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}4%{?_isa} = %{version}-%{release}
+%if %{with move_to_opt}
+%{?filter_requires_in: %filter_requires_in %{_libdir}/.*\.so$}
+ %endif
+%{?filter_setup}
+
%description
This extension is a librdkafka binding providing a working client for Kafka.
@@ -104,11 +120,22 @@ EOF
%build
%{?dtsenable}
+%if %{with move_to_opt}
+# not yet used
+export PKG_CONFIG_PATH=/opt/%{?vendeur:%{vendeur}/}librdkafka/%{_lib}/pkgconfig
+%endif
+
cd NTS
%{_bindir}/phpize
%configure \
--with-php-config=%{_bindir}/php-config \
- --with-rdkafka
+ --with-libdir=%{_lib} \
+%if %{with move_to_opt}
+ --with-rdkafka=/opt/%{?vendeur:%{vendeur}/}librdkafka
+%else
+ --with-rdkafka
+%endif
+
make %{?_smp_mflags}
%if %{with_zts}
@@ -116,7 +143,13 @@ cd ../ZTS
%{_bindir}/zts-phpize
%configure \
--with-php-config=%{_bindir}/zts-php-config \
- --with-rdkafka
+ --with-libdir=%{_lib} \
+%if %{with move_to_opt}
+ --with-rdkafka=/opt/%{?vendeur:%{vendeur}/}librdkafka
+%else
+ --with-rdkafka
+%endif
+
make %{?_smp_mflags}
%endif
@@ -201,6 +234,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Jan 19 2023 Remi Collet <remi@remirepo.net> - 6.0.3-2
+- rebuild using remi-librdkafka 2.0.1
+
* Mon Jul 4 2022 Remi Collet <remi@remirepo.net> - 6.0.3-1
- update to 6.0.3 (no change)
- rebuild with librdkafka 1.9.0