summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-27 10:23:55 +0100
committerRemi Collet <remi@remirepo.net>2021-01-27 10:23:55 +0100
commit1c2ec694de8ac98ec1d8971c119b371ed687ebd0 (patch)
tree069b325bf78dd22290631e5a2d06fe7f12cc8dd7
parent2cba3b9c616225411c7946c2da41a6f41bf5d621 (diff)
rebuild with librdkafka version 1.6.0
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION17
-rw-r--r--php-pecl-rdkafka5.spec15
3 files changed, 26 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index 8388039..b943ece 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,6 +3,6 @@ rdkafka
rdkafka support => enabled
version => 5.0.0
-build date => Jan 14 2021 00:00:00
-librdkafka version (runtime) => 1.5.3
-librdkafka version (build) => 1.5.3.255
+build date => Jan 27 2021 00:00:00
+librdkafka version (runtime) => 1.6.0
+librdkafka version (build) => 1.6.0.255
diff --git a/REFLECTION b/REFLECTION
index 1d0f749..36e94f1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
Extension [ <persistent> extension #99 rdkafka version 5.0.0 ] {
- - Constants [172] {
+ - Constants [183] {
Constant [ int RD_KAFKA_CONSUMER ] { 1 }
Constant [ int RD_KAFKA_OFFSET_BEGINNING ] { -2 }
Constant [ int RD_KAFKA_OFFSET_END ] { -1 }
@@ -11,8 +11,8 @@ Extension [ <persistent> extension #99 rdkafka version 5.0.0 ] {
Constant [ int RD_KAFKA_PURGE_F_QUEUE ] { 1 }
Constant [ int RD_KAFKA_PURGE_F_INFLIGHT ] { 2 }
Constant [ int RD_KAFKA_PURGE_F_NON_BLOCKING ] { 4 }
- Constant [ int RD_KAFKA_VERSION ] { 17105919 }
- Constant [ int RD_KAFKA_BUILD_VERSION ] { 17105919 }
+ Constant [ int RD_KAFKA_VERSION ] { 17170687 }
+ Constant [ int RD_KAFKA_BUILD_VERSION ] { 17170687 }
Constant [ int RD_KAFKA_RESP_ERR__BEGIN ] { -200 }
Constant [ int RD_KAFKA_RESP_ERR__BAD_MSG ] { -199 }
Constant [ int RD_KAFKA_RESP_ERR__BAD_COMPRESSION ] { -198 }
@@ -71,6 +71,8 @@ Extension [ <persistent> extension #99 rdkafka version 5.0.0 ] {
Constant [ int RD_KAFKA_RESP_ERR__NOT_CONFIGURED ] { -145 }
Constant [ int RD_KAFKA_RESP_ERR__FENCED ] { -144 }
Constant [ int RD_KAFKA_RESP_ERR__APPLICATION ] { -143 }
+ Constant [ int RD_KAFKA_RESP_ERR__ASSIGNMENT_LOST ] { -142 }
+ Constant [ int RD_KAFKA_RESP_ERR__NOOP ] { -141 }
Constant [ int RD_KAFKA_RESP_ERR__END ] { -100 }
Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN ] { -1 }
Constant [ int RD_KAFKA_RESP_ERR_NO_ERROR ] { 0 }
@@ -162,6 +164,15 @@ Extension [ <persistent> extension #99 rdkafka version 5.0.0 ] {
Constant [ int RD_KAFKA_RESP_ERR_GROUP_SUBSCRIBED_TO_TOPIC ] { 86 }
Constant [ int RD_KAFKA_RESP_ERR_INVALID_RECORD ] { 87 }
Constant [ int RD_KAFKA_RESP_ERR_UNSTABLE_OFFSET_COMMIT ] { 88 }
+ Constant [ int RD_KAFKA_RESP_ERR_THROTTLING_QUOTA_EXCEEDED ] { 89 }
+ Constant [ int RD_KAFKA_RESP_ERR_PRODUCER_FENCED ] { 90 }
+ Constant [ int RD_KAFKA_RESP_ERR_RESOURCE_NOT_FOUND ] { 91 }
+ Constant [ int RD_KAFKA_RESP_ERR_DUPLICATE_RESOURCE ] { 92 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNACCEPTABLE_CREDENTIAL ] { 93 }
+ Constant [ int RD_KAFKA_RESP_ERR_INCONSISTENT_VOTER_SET ] { 94 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_UPDATE_VERSION ] { 95 }
+ Constant [ int RD_KAFKA_RESP_ERR_FEATURE_UPDATE_FAILED ] { 96 }
+ Constant [ int RD_KAFKA_RESP_ERR_PRINCIPAL_DESERIALIZATION_FAILURE ] { 97 }
Constant [ int RD_KAFKA_CONF_UNKNOWN ] { -2 }
Constant [ int RD_KAFKA_CONF_INVALID ] { -1 }
Constant [ int RD_KAFKA_CONF_OK ] { 0 }
diff --git a/php-pecl-rdkafka5.spec b/php-pecl-rdkafka5.spec
index 3825e66..2239007 100644
--- a/php-pecl-rdkafka5.spec
+++ b/php-pecl-rdkafka5.spec
@@ -21,14 +21,14 @@
Summary: Kafka client based on librdkafka
Name: %{?sub_prefix}php-pecl-%{pecl_name}5
Version: 5.0.0
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: librdkafka1php-devel
+BuildRequires: librdkafka1php-devel >= 1.6
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
@@ -50,14 +50,14 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 5
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}4 < 5
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}4 = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}4%{?_isa} = %{version}-%{release}
%else
# A single version can be installed
Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 5
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name}4 < 5
%endif
+# no BC break (only PHP supported versions)
+Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name}4 < 5
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}4 = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}4%{?_isa} = %{version}-%{release}
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -203,6 +203,9 @@ cd ../ZTS
%changelog
+* Wed Jan 27 2021 Remi Collet <remi@remirepo.net> - 5.0.0-2
+- rebuild with librdkafka version 1.6.0
+
* Thu Jan 14 2021 Remi Collet <remi@remirepo.net> - 5.0.0-1
- update to 5.0.0
- rename to php-pecl-rdkafka5