summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION12
-rw-r--r--php-pecl-rdkafka4.spec23
3 files changed, 25 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index 8bdaca3..7027572 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
rdkafka
rdkafka support => enabled
-version => 4.0.3
-build date => Feb 7 2020 00:00:00
-librdkafka version (runtime) => 1.3.0
-librdkafka version (build) => 1.3.0.255
+version => 4.0.4
+build date => Oct 8 2020 00:00:00
+librdkafka version (runtime) => 1.5.0
+librdkafka version (build) => 1.5.0.255
diff --git a/REFLECTION b/REFLECTION
index 251a179..1aa657f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #91 rdkafka version 4.0.3 ] {
+Extension [ <persistent> extension #97 rdkafka version 4.0.4 ] {
- - Constants [162] {
+ - Constants [166] {
Constant [ int RD_KAFKA_CONSUMER ] { 1 }
Constant [ int RD_KAFKA_OFFSET_BEGINNING ] { -2 }
Constant [ int RD_KAFKA_OFFSET_END ] { -1 }
@@ -11,8 +11,8 @@ Extension [ <persistent> extension #91 rdkafka version 4.0.3 ] {
Constant [ int RD_KAFKA_PURGE_F_QUEUE ] { 1 }
Constant [ int RD_KAFKA_PURGE_F_INFLIGHT ] { 2 }
Constant [ int RD_KAFKA_PURGE_F_NON_BLOCKING ] { 4 }
- Constant [ int RD_KAFKA_VERSION ] { 16974079 }
- Constant [ int RD_KAFKA_BUILD_VERSION ] { 16974079 }
+ Constant [ int RD_KAFKA_VERSION ] { 17105151 }
+ Constant [ int RD_KAFKA_BUILD_VERSION ] { 17105151 }
Constant [ int RD_KAFKA_RESP_ERR__BEGIN ] { -200 }
Constant [ int RD_KAFKA_RESP_ERR__BAD_MSG ] { -199 }
Constant [ int RD_KAFKA_RESP_ERR__BAD_COMPRESSION ] { -198 }
@@ -68,6 +68,9 @@ Extension [ <persistent> extension #91 rdkafka version 4.0.3 ] {
Constant [ int RD_KAFKA_RESP_ERR__GAPLESS_GUARANTEE ] { -148 }
Constant [ int RD_KAFKA_RESP_ERR__MAX_POLL_EXCEEDED ] { -147 }
Constant [ int RD_KAFKA_RESP_ERR__UNKNOWN_BROKER ] { -146 }
+ Constant [ int RD_KAFKA_RESP_ERR__NOT_CONFIGURED ] { -145 }
+ Constant [ int RD_KAFKA_RESP_ERR__FENCED ] { -144 }
+ Constant [ int RD_KAFKA_RESP_ERR__APPLICATION ] { -143 }
Constant [ int RD_KAFKA_RESP_ERR__END ] { -100 }
Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN ] { -1 }
Constant [ int RD_KAFKA_RESP_ERR_NO_ERROR ] { 0 }
@@ -152,6 +155,7 @@ Extension [ <persistent> extension #91 rdkafka version 4.0.3 ] {
Constant [ int RD_KAFKA_RESP_ERR_MEMBER_ID_REQUIRED ] { 79 }
Constant [ int RD_KAFKA_RESP_ERR_PREFERRED_LEADER_NOT_AVAILABLE ] { 80 }
Constant [ int RD_KAFKA_RESP_ERR_GROUP_MAX_SIZE_REACHED ] { 81 }
+ Constant [ int RD_KAFKA_RESP_ERR_FENCED_INSTANCE_ID ] { 82 }
Constant [ int RD_KAFKA_CONF_UNKNOWN ] { -2 }
Constant [ int RD_KAFKA_CONF_INVALID ] { -1 }
Constant [ int RD_KAFKA_CONF_OK ] { 0 }
diff --git a/php-pecl-rdkafka4.spec b/php-pecl-rdkafka4.spec
index 3faa30d..cc5de83 100644
--- a/php-pecl-rdkafka4.spec
+++ b/php-pecl-rdkafka4.spec
@@ -20,21 +20,21 @@
Summary: Kafka client based on librdkafka
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.0.3
+Version: 4.0.4
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: librdkafka-devel >= 0.11
+BuildRequires: librdkafka1php-devel
BuildRequires: %{?scl_prefix}php-devel > 5.6
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Requires: librdkafka%{?_isa} >= %{buildver}
+Requires: librdkafka1php%{?_isa} >= %{buildver}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -54,19 +54,16 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{relea
Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 4
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -207,6 +204,12 @@ cd ../ZTS
%changelog
+* Thu Oct 8 2020 Remi Collet <remi@remirepo.net> - 4.0.4-1
+- update to 4.0.4
+
+* Sun Jun 21 2020 Remi Collet <remi@remirepo.net> - 4.0.3-2
+- rebuild using librdkafka1php 1.4.4
+
* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 4.0.3-1
- update to 4.0.3