summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-07 08:33:52 +0100
committerRemi Collet <remi@remirepo.net>2020-12-07 08:33:52 +0100
commitc08445fb95d5bde206a28d4748a76df3ecb6b1b5 (patch)
treeccf85b7eb816624802ae238a366082155eece87b
parentf368f73bbc2147de3243cd84470948398c56cd1e (diff)
update to 4.1.0
-rw-r--r--.gitignore2
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION133
-rw-r--r--php-pecl-rdkafka4.spec15
4 files changed, 139 insertions, 19 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/PHPINFO b/PHPINFO
index 7027572..e7f5ffc 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
rdkafka
rdkafka support => enabled
-version => 4.0.4
-build date => Oct 8 2020 00:00:00
-librdkafka version (runtime) => 1.5.0
-librdkafka version (build) => 1.5.0.255
+version => 4.1.0
+build date => Dec 7 2020 00:00:00
+librdkafka version (runtime) => 1.5.2
+librdkafka version (build) => 1.5.2.255
diff --git a/REFLECTION b/REFLECTION
index 1aa657f..15ec1e5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #97 rdkafka version 4.0.4 ] {
+Extension [ <persistent> extension #97 rdkafka version 4.1.0 ] {
- - Constants [166] {
+ - Constants [172] {
Constant [ int RD_KAFKA_CONSUMER ] { 1 }
Constant [ int RD_KAFKA_OFFSET_BEGINNING ] { -2 }
Constant [ int RD_KAFKA_OFFSET_END ] { -1 }
@@ -11,8 +11,8 @@ Extension [ <persistent> extension #97 rdkafka version 4.0.4 ] {
Constant [ int RD_KAFKA_PURGE_F_QUEUE ] { 1 }
Constant [ int RD_KAFKA_PURGE_F_INFLIGHT ] { 2 }
Constant [ int RD_KAFKA_PURGE_F_NON_BLOCKING ] { 4 }
- Constant [ int RD_KAFKA_VERSION ] { 17105151 }
- Constant [ int RD_KAFKA_BUILD_VERSION ] { 17105151 }
+ Constant [ int RD_KAFKA_VERSION ] { 17105663 }
+ Constant [ int RD_KAFKA_BUILD_VERSION ] { 17105663 }
Constant [ int RD_KAFKA_RESP_ERR__BEGIN ] { -200 }
Constant [ int RD_KAFKA_RESP_ERR__BAD_MSG ] { -199 }
Constant [ int RD_KAFKA_RESP_ERR__BAD_COMPRESSION ] { -198 }
@@ -156,6 +156,12 @@ Extension [ <persistent> extension #97 rdkafka version 4.0.4 ] {
Constant [ int RD_KAFKA_RESP_ERR_PREFERRED_LEADER_NOT_AVAILABLE ] { 80 }
Constant [ int RD_KAFKA_RESP_ERR_GROUP_MAX_SIZE_REACHED ] { 81 }
Constant [ int RD_KAFKA_RESP_ERR_FENCED_INSTANCE_ID ] { 82 }
+ Constant [ int RD_KAFKA_RESP_ERR_ELIGIBLE_LEADERS_NOT_AVAILABLE ] { 83 }
+ Constant [ int RD_KAFKA_RESP_ERR_ELECTION_NOT_NEEDED ] { 84 }
+ Constant [ int RD_KAFKA_RESP_ERR_NO_REASSIGNMENT_IN_PROGRESS ] { 85 }
+ Constant [ int RD_KAFKA_RESP_ERR_GROUP_SUBSCRIBED_TO_TOPIC ] { 86 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_RECORD ] { 87 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNSTABLE_OFFSET_COMMIT ] { 88 }
Constant [ int RD_KAFKA_CONF_UNKNOWN ] { -2 }
Constant [ int RD_KAFKA_CONF_INVALID ] { -1 }
Constant [ int RD_KAFKA_CONF_OK ] { 0 }
@@ -205,7 +211,7 @@ Extension [ <persistent> extension #97 rdkafka version 4.0.4 ] {
}
}
- - Classes [19] {
+ - Classes [20] {
Class [ <internal:rdkafka> abstract class RdKafka ] {
- Constants [0] {
@@ -467,7 +473,7 @@ Extension [ <persistent> extension #97 rdkafka version 4.0.4 ] {
- Properties [0] {
}
- - Methods [14] {
+ - Methods [18] {
Method [ <internal:rdkafka, ctor> public method __construct ] {
- Parameters [1] {
@@ -475,6 +481,33 @@ Extension [ <persistent> extension #97 rdkafka version 4.0.4 ] {
}
}
+ Method [ <internal:rdkafka> public method initTransactions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeout_ms ]
+ }
+ }
+
+ Method [ <internal:rdkafka> public method beginTransaction ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:rdkafka> public method commitTransaction ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeout_ms ]
+ }
+ }
+
+ Method [ <internal:rdkafka> public method abortTransaction ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeout_ms ]
+ }
+ }
+
Method [ <internal:rdkafka, inherits RdKafka> public method addBrokers ] {
- Parameters [1] {
@@ -770,6 +803,94 @@ Extension [ <persistent> extension #97 rdkafka version 4.0.4 ] {
}
}
+ Class [ <internal:rdkafka> class RdKafka\KafkaErrorException extends RdKafka\Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [8] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> private $error_string ]
+ Property [ <default> private $isFatal ]
+ Property [ <default> private $isRetriable ]
+ Property [ <default> private $transactionRequiresAbort ]
+ }
+
+ - Methods [14] {
+ Method [ <internal:rdkafka, overwrites Exception, ctor> public method __construct ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <required> $code ]
+ Parameter #2 [ <required> $error_string ]
+ Parameter #3 [ <required> $isFatal ]
+ Parameter #4 [ <required> $isRetriable ]
+ Parameter #5 [ <required> $transactionRequiresAbort ]
+ }
+ }
+
+ Method [ <internal:rdkafka> public method getErrorString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:rdkafka> public method isFatal ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:rdkafka> public method isRetriable ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:rdkafka> public method transactionRequiresAbort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:rdkafka> class RdKafka\KafkaConsumer ] {
- Constants [0] {
diff --git a/php-pecl-rdkafka4.spec b/php-pecl-rdkafka4.spec
index cc5de83..5f7b6de 100644
--- a/php-pecl-rdkafka4.spec
+++ b/php-pecl-rdkafka4.spec
@@ -20,7 +20,7 @@
Summary: Kafka client based on librdkafka
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.0.4
+Version: 4.1.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
@@ -67,12 +67,6 @@ Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
This extension is a librdkafka binding providing a working client for Kafka.
@@ -178,14 +172,14 @@ cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if %{with_zts}
cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%endif
@@ -204,6 +198,9 @@ cd ../ZTS
%changelog
+* Mon Dec 7 2020 Remi Collet <remi@remirepo.net> - 4.1.0-1
+- update to 4.1.0
+
* Thu Oct 8 2020 Remi Collet <remi@remirepo.net> - 4.0.4-1
- update to 4.0.4