summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-09 08:46:15 +0100
committerRemi Collet <remi@remirepo.net>2019-12-09 08:46:15 +0100
commit9b9e1cca10b4804af74be730ab292fed86a19884 (patch)
tree0f18c95a315fed56c7b3ba62ee155f9932b6e4f4
parente56d3445d400e03225ddc564cca02a1600b3b6b7 (diff)
v4.0.1
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION340
-rw-r--r--php-pecl-rdkafka4.spec7
3 files changed, 183 insertions, 172 deletions
diff --git a/PHPINFO b/PHPINFO
index d4c8296..a3161ff 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
rdkafka
rdkafka support => enabled
-version => 4.0.0
-build date => Oct 5 2019 07:50:42
-librdkafka version (runtime) => 1.2.0
-librdkafka version (build) => 1.2.0.255
+version => 4.0.1
+build date => Dec 9 2019 00:00:00
+librdkafka version (runtime) => 1.3.0
+librdkafka version (build) => 1.3.0.255
diff --git a/REFLECTION b/REFLECTION
index 7ec44e4..ccca4df 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,167 +1,168 @@
-Extension [ <persistent> extension #136 rdkafka version 4.0.0 ] {
-
- - Constants [161] {
- Constant [ integer RD_KAFKA_CONSUMER ] { 1 }
- Constant [ integer RD_KAFKA_OFFSET_BEGINNING ] { -2 }
- Constant [ integer RD_KAFKA_OFFSET_END ] { -1 }
- Constant [ integer RD_KAFKA_OFFSET_STORED ] { -1000 }
- Constant [ integer RD_KAFKA_PARTITION_UA ] { -1 }
- Constant [ integer RD_KAFKA_PRODUCER ] { 0 }
- Constant [ integer RD_KAFKA_MSG_F_BLOCK ] { 4 }
- Constant [ integer RD_KAFKA_PURGE_F_QUEUE ] { 1 }
- Constant [ integer RD_KAFKA_PURGE_F_INFLIGHT ] { 2 }
- Constant [ integer RD_KAFKA_PURGE_F_NON_BLOCKING ] { 4 }
- Constant [ integer RD_KAFKA_VERSION ] { 16908543 }
- Constant [ integer RD_KAFKA_BUILD_VERSION ] { 16908543 }
- Constant [ integer RD_KAFKA_RESP_ERR__BEGIN ] { -200 }
- Constant [ integer RD_KAFKA_RESP_ERR__BAD_MSG ] { -199 }
- Constant [ integer RD_KAFKA_RESP_ERR__BAD_COMPRESSION ] { -198 }
- Constant [ integer RD_KAFKA_RESP_ERR__DESTROY ] { -197 }
- Constant [ integer RD_KAFKA_RESP_ERR__FAIL ] { -196 }
- Constant [ integer RD_KAFKA_RESP_ERR__TRANSPORT ] { -195 }
- Constant [ integer RD_KAFKA_RESP_ERR__CRIT_SYS_RESOURCE ] { -194 }
- Constant [ integer RD_KAFKA_RESP_ERR__RESOLVE ] { -193 }
- Constant [ integer RD_KAFKA_RESP_ERR__MSG_TIMED_OUT ] { -192 }
- Constant [ integer RD_KAFKA_RESP_ERR__PARTITION_EOF ] { -191 }
- Constant [ integer RD_KAFKA_RESP_ERR__UNKNOWN_PARTITION ] { -190 }
- Constant [ integer RD_KAFKA_RESP_ERR__FS ] { -189 }
- Constant [ integer RD_KAFKA_RESP_ERR__UNKNOWN_TOPIC ] { -188 }
- Constant [ integer RD_KAFKA_RESP_ERR__ALL_BROKERS_DOWN ] { -187 }
- Constant [ integer RD_KAFKA_RESP_ERR__INVALID_ARG ] { -186 }
- Constant [ integer RD_KAFKA_RESP_ERR__TIMED_OUT ] { -185 }
- Constant [ integer RD_KAFKA_RESP_ERR__QUEUE_FULL ] { -184 }
- Constant [ integer RD_KAFKA_RESP_ERR__ISR_INSUFF ] { -183 }
- Constant [ integer RD_KAFKA_RESP_ERR__NODE_UPDATE ] { -182 }
- Constant [ integer RD_KAFKA_RESP_ERR__SSL ] { -181 }
- Constant [ integer RD_KAFKA_RESP_ERR__WAIT_COORD ] { -180 }
- Constant [ integer RD_KAFKA_RESP_ERR__UNKNOWN_GROUP ] { -179 }
- Constant [ integer RD_KAFKA_RESP_ERR__IN_PROGRESS ] { -178 }
- Constant [ integer RD_KAFKA_RESP_ERR__PREV_IN_PROGRESS ] { -177 }
- Constant [ integer RD_KAFKA_RESP_ERR__EXISTING_SUBSCRIPTION ] { -176 }
- Constant [ integer RD_KAFKA_RESP_ERR__ASSIGN_PARTITIONS ] { -175 }
- Constant [ integer RD_KAFKA_RESP_ERR__REVOKE_PARTITIONS ] { -174 }
- Constant [ integer RD_KAFKA_RESP_ERR__CONFLICT ] { -173 }
- Constant [ integer RD_KAFKA_RESP_ERR__STATE ] { -172 }
- Constant [ integer RD_KAFKA_RESP_ERR__UNKNOWN_PROTOCOL ] { -171 }
- Constant [ integer RD_KAFKA_RESP_ERR__NOT_IMPLEMENTED ] { -170 }
- Constant [ integer RD_KAFKA_RESP_ERR__AUTHENTICATION ] { -169 }
- Constant [ integer RD_KAFKA_RESP_ERR__NO_OFFSET ] { -168 }
- Constant [ integer RD_KAFKA_RESP_ERR__OUTDATED ] { -167 }
- Constant [ integer RD_KAFKA_RESP_ERR__TIMED_OUT_QUEUE ] { -166 }
- Constant [ integer RD_KAFKA_RESP_ERR__UNSUPPORTED_FEATURE ] { -165 }
- Constant [ integer RD_KAFKA_RESP_ERR__WAIT_CACHE ] { -164 }
- Constant [ integer RD_KAFKA_RESP_ERR__INTR ] { -163 }
- Constant [ integer RD_KAFKA_RESP_ERR__KEY_SERIALIZATION ] { -162 }
- Constant [ integer RD_KAFKA_RESP_ERR__VALUE_SERIALIZATION ] { -161 }
- Constant [ integer RD_KAFKA_RESP_ERR__KEY_DESERIALIZATION ] { -160 }
- Constant [ integer RD_KAFKA_RESP_ERR__VALUE_DESERIALIZATION ] { -159 }
- Constant [ integer RD_KAFKA_RESP_ERR__PARTIAL ] { -158 }
- Constant [ integer RD_KAFKA_RESP_ERR__READ_ONLY ] { -157 }
- Constant [ integer RD_KAFKA_RESP_ERR__NOENT ] { -156 }
- Constant [ integer RD_KAFKA_RESP_ERR__UNDERFLOW ] { -155 }
- Constant [ integer RD_KAFKA_RESP_ERR__INVALID_TYPE ] { -154 }
- Constant [ integer RD_KAFKA_RESP_ERR__RETRY ] { -153 }
- Constant [ integer RD_KAFKA_RESP_ERR__PURGE_QUEUE ] { -152 }
- Constant [ integer RD_KAFKA_RESP_ERR__PURGE_INFLIGHT ] { -151 }
- Constant [ integer RD_KAFKA_RESP_ERR__FATAL ] { -150 }
- Constant [ integer RD_KAFKA_RESP_ERR__INCONSISTENT ] { -149 }
- Constant [ integer RD_KAFKA_RESP_ERR__GAPLESS_GUARANTEE ] { -148 }
- Constant [ integer RD_KAFKA_RESP_ERR__MAX_POLL_EXCEEDED ] { -147 }
- Constant [ integer RD_KAFKA_RESP_ERR__END ] { -100 }
- Constant [ integer RD_KAFKA_RESP_ERR_UNKNOWN ] { -1 }
- Constant [ integer RD_KAFKA_RESP_ERR_NO_ERROR ] { 0 }
- Constant [ integer RD_KAFKA_RESP_ERR_OFFSET_OUT_OF_RANGE ] { 1 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_MSG ] { 2 }
- Constant [ integer RD_KAFKA_RESP_ERR_UNKNOWN_TOPIC_OR_PART ] { 3 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_MSG_SIZE ] { 4 }
- Constant [ integer RD_KAFKA_RESP_ERR_LEADER_NOT_AVAILABLE ] { 5 }
- Constant [ integer RD_KAFKA_RESP_ERR_NOT_LEADER_FOR_PARTITION ] { 6 }
- Constant [ integer RD_KAFKA_RESP_ERR_REQUEST_TIMED_OUT ] { 7 }
- Constant [ integer RD_KAFKA_RESP_ERR_BROKER_NOT_AVAILABLE ] { 8 }
- Constant [ integer RD_KAFKA_RESP_ERR_REPLICA_NOT_AVAILABLE ] { 9 }
- Constant [ integer RD_KAFKA_RESP_ERR_MSG_SIZE_TOO_LARGE ] { 10 }
- Constant [ integer RD_KAFKA_RESP_ERR_STALE_CTRL_EPOCH ] { 11 }
- Constant [ integer RD_KAFKA_RESP_ERR_OFFSET_METADATA_TOO_LARGE ] { 12 }
- Constant [ integer RD_KAFKA_RESP_ERR_NETWORK_EXCEPTION ] { 13 }
- Constant [ integer RD_KAFKA_RESP_ERR_GROUP_LOAD_IN_PROGRESS ] { 14 }
- Constant [ integer RD_KAFKA_RESP_ERR_GROUP_COORDINATOR_NOT_AVAILABLE ] { 15 }
- Constant [ integer RD_KAFKA_RESP_ERR_NOT_COORDINATOR_FOR_GROUP ] { 16 }
- Constant [ integer RD_KAFKA_RESP_ERR_TOPIC_EXCEPTION ] { 17 }
- Constant [ integer RD_KAFKA_RESP_ERR_RECORD_LIST_TOO_LARGE ] { 18 }
- Constant [ integer RD_KAFKA_RESP_ERR_NOT_ENOUGH_REPLICAS ] { 19 }
- Constant [ integer RD_KAFKA_RESP_ERR_NOT_ENOUGH_REPLICAS_AFTER_APPEND ] { 20 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_REQUIRED_ACKS ] { 21 }
- Constant [ integer RD_KAFKA_RESP_ERR_ILLEGAL_GENERATION ] { 22 }
- Constant [ integer RD_KAFKA_RESP_ERR_INCONSISTENT_GROUP_PROTOCOL ] { 23 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_GROUP_ID ] { 24 }
- Constant [ integer RD_KAFKA_RESP_ERR_UNKNOWN_MEMBER_ID ] { 25 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_SESSION_TIMEOUT ] { 26 }
- Constant [ integer RD_KAFKA_RESP_ERR_REBALANCE_IN_PROGRESS ] { 27 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_COMMIT_OFFSET_SIZE ] { 28 }
- Constant [ integer RD_KAFKA_RESP_ERR_TOPIC_AUTHORIZATION_FAILED ] { 29 }
- Constant [ integer RD_KAFKA_RESP_ERR_GROUP_AUTHORIZATION_FAILED ] { 30 }
- Constant [ integer RD_KAFKA_RESP_ERR_CLUSTER_AUTHORIZATION_FAILED ] { 31 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_TIMESTAMP ] { 32 }
- Constant [ integer RD_KAFKA_RESP_ERR_UNSUPPORTED_SASL_MECHANISM ] { 33 }
- Constant [ integer RD_KAFKA_RESP_ERR_ILLEGAL_SASL_STATE ] { 34 }
- Constant [ integer RD_KAFKA_RESP_ERR_UNSUPPORTED_VERSION ] { 35 }
- Constant [ integer RD_KAFKA_RESP_ERR_TOPIC_ALREADY_EXISTS ] { 36 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_PARTITIONS ] { 37 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_REPLICATION_FACTOR ] { 38 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_REPLICA_ASSIGNMENT ] { 39 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_CONFIG ] { 40 }
- Constant [ integer RD_KAFKA_RESP_ERR_NOT_CONTROLLER ] { 41 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_REQUEST ] { 42 }
- Constant [ integer RD_KAFKA_RESP_ERR_UNSUPPORTED_FOR_MESSAGE_FORMAT ] { 43 }
- Constant [ integer RD_KAFKA_RESP_ERR_POLICY_VIOLATION ] { 44 }
- Constant [ integer RD_KAFKA_RESP_ERR_OUT_OF_ORDER_SEQUENCE_NUMBER ] { 45 }
- Constant [ integer RD_KAFKA_RESP_ERR_DUPLICATE_SEQUENCE_NUMBER ] { 46 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_PRODUCER_EPOCH ] { 47 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_TXN_STATE ] { 48 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_PRODUCER_ID_MAPPING ] { 49 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_TRANSACTION_TIMEOUT ] { 50 }
- Constant [ integer RD_KAFKA_RESP_ERR_CONCURRENT_TRANSACTIONS ] { 51 }
- Constant [ integer RD_KAFKA_RESP_ERR_TRANSACTION_COORDINATOR_FENCED ] { 52 }
- Constant [ integer RD_KAFKA_RESP_ERR_TRANSACTIONAL_ID_AUTHORIZATION_FAILED ] { 53 }
- Constant [ integer RD_KAFKA_RESP_ERR_SECURITY_DISABLED ] { 54 }
- Constant [ integer RD_KAFKA_RESP_ERR_OPERATION_NOT_ATTEMPTED ] { 55 }
- Constant [ integer RD_KAFKA_RESP_ERR_KAFKA_STORAGE_ERROR ] { 56 }
- Constant [ integer RD_KAFKA_RESP_ERR_LOG_DIR_NOT_FOUND ] { 57 }
- Constant [ integer RD_KAFKA_RESP_ERR_SASL_AUTHENTICATION_FAILED ] { 58 }
- Constant [ integer RD_KAFKA_RESP_ERR_UNKNOWN_PRODUCER_ID ] { 59 }
- Constant [ integer RD_KAFKA_RESP_ERR_REASSIGNMENT_IN_PROGRESS ] { 60 }
- Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_AUTH_DISABLED ] { 61 }
- Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_NOT_FOUND ] { 62 }
- Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_OWNER_MISMATCH ] { 63 }
- Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_REQUEST_NOT_ALLOWED ] { 64 }
- Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_AUTHORIZATION_FAILED ] { 65 }
- Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_EXPIRED ] { 66 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_PRINCIPAL_TYPE ] { 67 }
- Constant [ integer RD_KAFKA_RESP_ERR_NON_EMPTY_GROUP ] { 68 }
- Constant [ integer RD_KAFKA_RESP_ERR_GROUP_ID_NOT_FOUND ] { 69 }
- Constant [ integer RD_KAFKA_RESP_ERR_FETCH_SESSION_ID_NOT_FOUND ] { 70 }
- Constant [ integer RD_KAFKA_RESP_ERR_INVALID_FETCH_SESSION_EPOCH ] { 71 }
- Constant [ integer RD_KAFKA_RESP_ERR_LISTENER_NOT_FOUND ] { 72 }
- Constant [ integer RD_KAFKA_RESP_ERR_TOPIC_DELETION_DISABLED ] { 73 }
- Constant [ integer RD_KAFKA_RESP_ERR_FENCED_LEADER_EPOCH ] { 74 }
- Constant [ integer RD_KAFKA_RESP_ERR_UNKNOWN_LEADER_EPOCH ] { 75 }
- Constant [ integer RD_KAFKA_RESP_ERR_UNSUPPORTED_COMPRESSION_TYPE ] { 76 }
- Constant [ integer RD_KAFKA_RESP_ERR_STALE_BROKER_EPOCH ] { 77 }
- Constant [ integer RD_KAFKA_RESP_ERR_OFFSET_NOT_AVAILABLE ] { 78 }
- Constant [ integer RD_KAFKA_RESP_ERR_MEMBER_ID_REQUIRED ] { 79 }
- Constant [ integer RD_KAFKA_RESP_ERR_PREFERRED_LEADER_NOT_AVAILABLE ] { 80 }
- Constant [ integer RD_KAFKA_RESP_ERR_GROUP_MAX_SIZE_REACHED ] { 81 }
- Constant [ integer RD_KAFKA_CONF_UNKNOWN ] { -2 }
- Constant [ integer RD_KAFKA_CONF_INVALID ] { -1 }
- Constant [ integer RD_KAFKA_CONF_OK ] { 0 }
- Constant [ integer RD_KAFKA_MSG_PARTITIONER_RANDOM ] { 2 }
- Constant [ integer RD_KAFKA_MSG_PARTITIONER_CONSISTENT ] { 3 }
- Constant [ integer RD_KAFKA_MSG_PARTITIONER_CONSISTENT_RANDOM ] { 4 }
- Constant [ integer RD_KAFKA_MSG_PARTITIONER_MURMUR2 ] { 5 }
- Constant [ integer RD_KAFKA_MSG_PARTITIONER_MURMUR2_RANDOM ] { 6 }
- Constant [ integer RD_KAFKA_LOG_PRINT ] { 100 }
- Constant [ integer RD_KAFKA_LOG_SYSLOG ] { 101 }
- Constant [ integer RD_KAFKA_LOG_SYSLOG_PRINT ] { 102 }
+Extension [ <persistent> extension #134 rdkafka version 4.0.1 ] {
+
+ - Constants [162] {
+ Constant [ int RD_KAFKA_CONSUMER ] { 1 }
+ Constant [ int RD_KAFKA_OFFSET_BEGINNING ] { -2 }
+ Constant [ int RD_KAFKA_OFFSET_END ] { -1 }
+ Constant [ int RD_KAFKA_OFFSET_STORED ] { -1000 }
+ Constant [ int RD_KAFKA_PARTITION_UA ] { -1 }
+ Constant [ int RD_KAFKA_PRODUCER ] { 0 }
+ Constant [ int RD_KAFKA_MSG_F_BLOCK ] { 4 }
+ Constant [ int RD_KAFKA_PURGE_F_QUEUE ] { 1 }
+ Constant [ int RD_KAFKA_PURGE_F_INFLIGHT ] { 2 }
+ Constant [ int RD_KAFKA_PURGE_F_NON_BLOCKING ] { 4 }
+ Constant [ int RD_KAFKA_VERSION ] { 16974079 }
+ Constant [ int RD_KAFKA_BUILD_VERSION ] { 16974079 }
+ Constant [ int RD_KAFKA_RESP_ERR__BEGIN ] { -200 }
+ Constant [ int RD_KAFKA_RESP_ERR__BAD_MSG ] { -199 }
+ Constant [ int RD_KAFKA_RESP_ERR__BAD_COMPRESSION ] { -198 }
+ Constant [ int RD_KAFKA_RESP_ERR__DESTROY ] { -197 }
+ Constant [ int RD_KAFKA_RESP_ERR__FAIL ] { -196 }
+ Constant [ int RD_KAFKA_RESP_ERR__TRANSPORT ] { -195 }
+ Constant [ int RD_KAFKA_RESP_ERR__CRIT_SYS_RESOURCE ] { -194 }
+ Constant [ int RD_KAFKA_RESP_ERR__RESOLVE ] { -193 }
+ Constant [ int RD_KAFKA_RESP_ERR__MSG_TIMED_OUT ] { -192 }
+ Constant [ int RD_KAFKA_RESP_ERR__PARTITION_EOF ] { -191 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNKNOWN_PARTITION ] { -190 }
+ Constant [ int RD_KAFKA_RESP_ERR__FS ] { -189 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNKNOWN_TOPIC ] { -188 }
+ Constant [ int RD_KAFKA_RESP_ERR__ALL_BROKERS_DOWN ] { -187 }
+ Constant [ int RD_KAFKA_RESP_ERR__INVALID_ARG ] { -186 }
+ Constant [ int RD_KAFKA_RESP_ERR__TIMED_OUT ] { -185 }
+ Constant [ int RD_KAFKA_RESP_ERR__QUEUE_FULL ] { -184 }
+ Constant [ int RD_KAFKA_RESP_ERR__ISR_INSUFF ] { -183 }
+ Constant [ int RD_KAFKA_RESP_ERR__NODE_UPDATE ] { -182 }
+ Constant [ int RD_KAFKA_RESP_ERR__SSL ] { -181 }
+ Constant [ int RD_KAFKA_RESP_ERR__WAIT_COORD ] { -180 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNKNOWN_GROUP ] { -179 }
+ Constant [ int RD_KAFKA_RESP_ERR__IN_PROGRESS ] { -178 }
+ Constant [ int RD_KAFKA_RESP_ERR__PREV_IN_PROGRESS ] { -177 }
+ Constant [ int RD_KAFKA_RESP_ERR__EXISTING_SUBSCRIPTION ] { -176 }
+ Constant [ int RD_KAFKA_RESP_ERR__ASSIGN_PARTITIONS ] { -175 }
+ Constant [ int RD_KAFKA_RESP_ERR__REVOKE_PARTITIONS ] { -174 }
+ Constant [ int RD_KAFKA_RESP_ERR__CONFLICT ] { -173 }
+ Constant [ int RD_KAFKA_RESP_ERR__STATE ] { -172 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNKNOWN_PROTOCOL ] { -171 }
+ Constant [ int RD_KAFKA_RESP_ERR__NOT_IMPLEMENTED ] { -170 }
+ Constant [ int RD_KAFKA_RESP_ERR__AUTHENTICATION ] { -169 }
+ Constant [ int RD_KAFKA_RESP_ERR__NO_OFFSET ] { -168 }
+ Constant [ int RD_KAFKA_RESP_ERR__OUTDATED ] { -167 }
+ Constant [ int RD_KAFKA_RESP_ERR__TIMED_OUT_QUEUE ] { -166 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNSUPPORTED_FEATURE ] { -165 }
+ Constant [ int RD_KAFKA_RESP_ERR__WAIT_CACHE ] { -164 }
+ Constant [ int RD_KAFKA_RESP_ERR__INTR ] { -163 }
+ Constant [ int RD_KAFKA_RESP_ERR__KEY_SERIALIZATION ] { -162 }
+ Constant [ int RD_KAFKA_RESP_ERR__VALUE_SERIALIZATION ] { -161 }
+ Constant [ int RD_KAFKA_RESP_ERR__KEY_DESERIALIZATION ] { -160 }
+ Constant [ int RD_KAFKA_RESP_ERR__VALUE_DESERIALIZATION ] { -159 }
+ Constant [ int RD_KAFKA_RESP_ERR__PARTIAL ] { -158 }
+ Constant [ int RD_KAFKA_RESP_ERR__READ_ONLY ] { -157 }
+ Constant [ int RD_KAFKA_RESP_ERR__NOENT ] { -156 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNDERFLOW ] { -155 }
+ Constant [ int RD_KAFKA_RESP_ERR__INVALID_TYPE ] { -154 }
+ Constant [ int RD_KAFKA_RESP_ERR__RETRY ] { -153 }
+ Constant [ int RD_KAFKA_RESP_ERR__PURGE_QUEUE ] { -152 }
+ Constant [ int RD_KAFKA_RESP_ERR__PURGE_INFLIGHT ] { -151 }
+ Constant [ int RD_KAFKA_RESP_ERR__FATAL ] { -150 }
+ Constant [ int RD_KAFKA_RESP_ERR__INCONSISTENT ] { -149 }
+ Constant [ int RD_KAFKA_RESP_ERR__GAPLESS_GUARANTEE ] { -148 }
+ Constant [ int RD_KAFKA_RESP_ERR__MAX_POLL_EXCEEDED ] { -147 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNKNOWN_BROKER ] { -146 }
+ Constant [ int RD_KAFKA_RESP_ERR__END ] { -100 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN ] { -1 }
+ Constant [ int RD_KAFKA_RESP_ERR_NO_ERROR ] { 0 }
+ Constant [ int RD_KAFKA_RESP_ERR_OFFSET_OUT_OF_RANGE ] { 1 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_MSG ] { 2 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN_TOPIC_OR_PART ] { 3 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_MSG_SIZE ] { 4 }
+ Constant [ int RD_KAFKA_RESP_ERR_LEADER_NOT_AVAILABLE ] { 5 }
+ Constant [ int RD_KAFKA_RESP_ERR_NOT_LEADER_FOR_PARTITION ] { 6 }
+ Constant [ int RD_KAFKA_RESP_ERR_REQUEST_TIMED_OUT ] { 7 }
+ Constant [ int RD_KAFKA_RESP_ERR_BROKER_NOT_AVAILABLE ] { 8 }
+ Constant [ int RD_KAFKA_RESP_ERR_REPLICA_NOT_AVAILABLE ] { 9 }
+ Constant [ int RD_KAFKA_RESP_ERR_MSG_SIZE_TOO_LARGE ] { 10 }
+ Constant [ int RD_KAFKA_RESP_ERR_STALE_CTRL_EPOCH ] { 11 }
+ Constant [ int RD_KAFKA_RESP_ERR_OFFSET_METADATA_TOO_LARGE ] { 12 }
+ Constant [ int RD_KAFKA_RESP_ERR_NETWORK_EXCEPTION ] { 13 }
+ Constant [ int RD_KAFKA_RESP_ERR_COORDINATOR_LOAD_IN_PROGRESS ] { 14 }
+ Constant [ int RD_KAFKA_RESP_ERR_COORDINATOR_NOT_AVAILABLE ] { 15 }
+ Constant [ int RD_KAFKA_RESP_ERR_NOT_COORDINATOR ] { 16 }
+ Constant [ int RD_KAFKA_RESP_ERR_TOPIC_EXCEPTION ] { 17 }
+ Constant [ int RD_KAFKA_RESP_ERR_RECORD_LIST_TOO_LARGE ] { 18 }
+ Constant [ int RD_KAFKA_RESP_ERR_NOT_ENOUGH_REPLICAS ] { 19 }
+ Constant [ int RD_KAFKA_RESP_ERR_NOT_ENOUGH_REPLICAS_AFTER_APPEND ] { 20 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_REQUIRED_ACKS ] { 21 }
+ Constant [ int RD_KAFKA_RESP_ERR_ILLEGAL_GENERATION ] { 22 }
+ Constant [ int RD_KAFKA_RESP_ERR_INCONSISTENT_GROUP_PROTOCOL ] { 23 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_GROUP_ID ] { 24 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN_MEMBER_ID ] { 25 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_SESSION_TIMEOUT ] { 26 }
+ Constant [ int RD_KAFKA_RESP_ERR_REBALANCE_IN_PROGRESS ] { 27 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_COMMIT_OFFSET_SIZE ] { 28 }
+ Constant [ int RD_KAFKA_RESP_ERR_TOPIC_AUTHORIZATION_FAILED ] { 29 }
+ Constant [ int RD_KAFKA_RESP_ERR_GROUP_AUTHORIZATION_FAILED ] { 30 }
+ Constant [ int RD_KAFKA_RESP_ERR_CLUSTER_AUTHORIZATION_FAILED ] { 31 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_TIMESTAMP ] { 32 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNSUPPORTED_SASL_MECHANISM ] { 33 }
+ Constant [ int RD_KAFKA_RESP_ERR_ILLEGAL_SASL_STATE ] { 34 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNSUPPORTED_VERSION ] { 35 }
+ Constant [ int RD_KAFKA_RESP_ERR_TOPIC_ALREADY_EXISTS ] { 36 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_PARTITIONS ] { 37 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_REPLICATION_FACTOR ] { 38 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_REPLICA_ASSIGNMENT ] { 39 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_CONFIG ] { 40 }
+ Constant [ int RD_KAFKA_RESP_ERR_NOT_CONTROLLER ] { 41 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_REQUEST ] { 42 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNSUPPORTED_FOR_MESSAGE_FORMAT ] { 43 }
+ Constant [ int RD_KAFKA_RESP_ERR_POLICY_VIOLATION ] { 44 }
+ Constant [ int RD_KAFKA_RESP_ERR_OUT_OF_ORDER_SEQUENCE_NUMBER ] { 45 }
+ Constant [ int RD_KAFKA_RESP_ERR_DUPLICATE_SEQUENCE_NUMBER ] { 46 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_PRODUCER_EPOCH ] { 47 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_TXN_STATE ] { 48 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_PRODUCER_ID_MAPPING ] { 49 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_TRANSACTION_TIMEOUT ] { 50 }
+ Constant [ int RD_KAFKA_RESP_ERR_CONCURRENT_TRANSACTIONS ] { 51 }
+ Constant [ int RD_KAFKA_RESP_ERR_TRANSACTION_COORDINATOR_FENCED ] { 52 }
+ Constant [ int RD_KAFKA_RESP_ERR_TRANSACTIONAL_ID_AUTHORIZATION_FAILED ] { 53 }
+ Constant [ int RD_KAFKA_RESP_ERR_SECURITY_DISABLED ] { 54 }
+ Constant [ int RD_KAFKA_RESP_ERR_OPERATION_NOT_ATTEMPTED ] { 55 }
+ Constant [ int RD_KAFKA_RESP_ERR_KAFKA_STORAGE_ERROR ] { 56 }
+ Constant [ int RD_KAFKA_RESP_ERR_LOG_DIR_NOT_FOUND ] { 57 }
+ Constant [ int RD_KAFKA_RESP_ERR_SASL_AUTHENTICATION_FAILED ] { 58 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN_PRODUCER_ID ] { 59 }
+ Constant [ int RD_KAFKA_RESP_ERR_REASSIGNMENT_IN_PROGRESS ] { 60 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_AUTH_DISABLED ] { 61 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_NOT_FOUND ] { 62 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_OWNER_MISMATCH ] { 63 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_REQUEST_NOT_ALLOWED ] { 64 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_AUTHORIZATION_FAILED ] { 65 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_EXPIRED ] { 66 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_PRINCIPAL_TYPE ] { 67 }
+ Constant [ int RD_KAFKA_RESP_ERR_NON_EMPTY_GROUP ] { 68 }
+ Constant [ int RD_KAFKA_RESP_ERR_GROUP_ID_NOT_FOUND ] { 69 }
+ Constant [ int RD_KAFKA_RESP_ERR_FETCH_SESSION_ID_NOT_FOUND ] { 70 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_FETCH_SESSION_EPOCH ] { 71 }
+ Constant [ int RD_KAFKA_RESP_ERR_LISTENER_NOT_FOUND ] { 72 }
+ Constant [ int RD_KAFKA_RESP_ERR_TOPIC_DELETION_DISABLED ] { 73 }
+ Constant [ int RD_KAFKA_RESP_ERR_FENCED_LEADER_EPOCH ] { 74 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN_LEADER_EPOCH ] { 75 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNSUPPORTED_COMPRESSION_TYPE ] { 76 }
+ Constant [ int RD_KAFKA_RESP_ERR_STALE_BROKER_EPOCH ] { 77 }
+ Constant [ int RD_KAFKA_RESP_ERR_OFFSET_NOT_AVAILABLE ] { 78 }
+ Constant [ int RD_KAFKA_RESP_ERR_MEMBER_ID_REQUIRED ] { 79 }
+ Constant [ int RD_KAFKA_RESP_ERR_PREFERRED_LEADER_NOT_AVAILABLE ] { 80 }
+ Constant [ int RD_KAFKA_RESP_ERR_GROUP_MAX_SIZE_REACHED ] { 81 }
+ Constant [ int RD_KAFKA_CONF_UNKNOWN ] { -2 }
+ Constant [ int RD_KAFKA_CONF_INVALID ] { -1 }
+ Constant [ int RD_KAFKA_CONF_OK ] { 0 }
+ Constant [ int RD_KAFKA_MSG_PARTITIONER_RANDOM ] { 2 }
+ Constant [ int RD_KAFKA_MSG_PARTITIONER_CONSISTENT ] { 3 }
+ Constant [ int RD_KAFKA_MSG_PARTITIONER_CONSISTENT_RANDOM ] { 4 }
+ Constant [ int RD_KAFKA_MSG_PARTITIONER_MURMUR2 ] { 5 }
+ Constant [ int RD_KAFKA_MSG_PARTITIONER_MURMUR2_RANDOM ] { 6 }
+ Constant [ int RD_KAFKA_LOG_PRINT ] { 100 }
+ Constant [ int RD_KAFKA_LOG_SYSLOG ] { 101 }
+ Constant [ int RD_KAFKA_LOG_SYSLOG_PRINT ] { 102 }
}
- Functions {
@@ -1277,7 +1278,7 @@ Extension [ <persistent> extension #136 rdkafka version 4.0.0 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:rdkafka, ctor> private method __construct ] {
- Parameters [0] {
@@ -1293,6 +1294,15 @@ Extension [ <persistent> extension #136 rdkafka version 4.0.0 ] {
}
}
+ Method [ <internal:rdkafka> public method consumeCallback ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $partition ]
+ Parameter #1 [ <required> $timeout_ms ]
+ Parameter #2 [ <required> $callback ]
+ }
+ }
+
Method [ <internal:rdkafka> public method consumeStart ] {
- Parameters [2] {
diff --git a/php-pecl-rdkafka4.spec b/php-pecl-rdkafka4.spec
index 17c4ff5..4a08b08 100644
--- a/php-pecl-rdkafka4.spec
+++ b/php-pecl-rdkafka4.spec
@@ -20,7 +20,7 @@
Summary: Kafka client based on librdkafka
Name: %{?sub_prefix}php-pecl-%{pecl_name}4
-Version: 4.0.0
+Version: 4.0.1
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
URL: http://pecl.php.net/package/%{pecl_name}
@@ -91,8 +91,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%setup -q -c
mv %{pecl_name}-%{version} NTS
-mv package2.xml package.xml
-
# Don't install tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
@@ -213,6 +211,9 @@ cd ../ZTS
%changelog
+* Mon Dec 9 2019 Remi Collet <remi@remirepo.net> - 4.0.1-1
+- update to 4.0.1
+
* Sat Oct 5 2019 Remi Collet <remi@remirepo.net> - 4.0.0-1
- update to 4.0.0
- rename to php-pecl-rdkafka4