summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-18 12:13:49 +0200
committerRemi Collet <remi@remirepo.net>2019-04-18 12:13:49 +0200
commita60ead42903830779e3e1095e6454ee95a78aeda (patch)
tree8b1e62090cc824f4cedc007a686575f08ca7216a
parent0e690769dbec9740e687805a2599a31f589c0805 (diff)
- update to 3.1.0
- raise dependency on PHP 5.6
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION88
-rw-r--r--php-pecl-rdkafka.spec33
3 files changed, 94 insertions, 35 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..b9aa931
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,8 @@
+
+rdkafka
+
+rdkafka support => enabled
+version => 3.1.0
+build date => Apr 18 2019 11:53:06
+librdkafka version (runtime) => 1.0.0
+librdkafka version (build) => 1.0.0.0
diff --git a/REFLECTION b/REFLECTION
index 482eef1..036b7ce 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,14 +1,14 @@
-Extension [ <persistent> extension #127 rdkafka version 3.0.5 ] {
+Extension [ <persistent> extension #138 rdkafka version 3.1.0 ] {
- - Constants [116] {
+ - Constants [147] {
Constant [ integer RD_KAFKA_CONSUMER ] { 1 }
Constant [ integer RD_KAFKA_OFFSET_BEGINNING ] { -2 }
Constant [ integer RD_KAFKA_OFFSET_END ] { -1 }
Constant [ integer RD_KAFKA_OFFSET_STORED ] { -1000 }
Constant [ integer RD_KAFKA_PARTITION_UA ] { -1 }
Constant [ integer RD_KAFKA_PRODUCER ] { 0 }
- Constant [ integer RD_KAFKA_VERSION ] { 721407 }
- Constant [ integer RD_KAFKA_BUILD_VERSION ] { 721407 }
+ Constant [ integer RD_KAFKA_VERSION ] { 16777471 }
+ Constant [ integer RD_KAFKA_BUILD_VERSION ] { 16777471 }
Constant [ integer RD_KAFKA_RESP_ERR__BEGIN ] { -200 }
Constant [ integer RD_KAFKA_RESP_ERR__BAD_MSG ] { -199 }
Constant [ integer RD_KAFKA_RESP_ERR__BAD_COMPRESSION ] { -198 }
@@ -51,6 +51,18 @@ Extension [ <persistent> extension #127 rdkafka version 3.0.5 ] {
Constant [ integer RD_KAFKA_RESP_ERR__VALUE_SERIALIZATION ] { -161 }
Constant [ integer RD_KAFKA_RESP_ERR__KEY_DESERIALIZATION ] { -160 }
Constant [ integer RD_KAFKA_RESP_ERR__VALUE_DESERIALIZATION ] { -159 }
+ Constant [ integer RD_KAFKA_RESP_ERR__PARTIAL ] { -158 }
+ Constant [ integer RD_KAFKA_RESP_ERR__READ_ONLY ] { -157 }
+ Constant [ integer RD_KAFKA_RESP_ERR__NOENT ] { -156 }
+ Constant [ integer RD_KAFKA_RESP_ERR__UNDERFLOW ] { -155 }
+ Constant [ integer RD_KAFKA_RESP_ERR__INVALID_TYPE ] { -154 }
+ Constant [ integer RD_KAFKA_RESP_ERR__RETRY ] { -153 }
+ Constant [ integer RD_KAFKA_RESP_ERR__PURGE_QUEUE ] { -152 }
+ Constant [ integer RD_KAFKA_RESP_ERR__PURGE_INFLIGHT ] { -151 }
+ Constant [ integer RD_KAFKA_RESP_ERR__FATAL ] { -150 }
+ Constant [ integer RD_KAFKA_RESP_ERR__INCONSISTENT ] { -149 }
+ Constant [ integer RD_KAFKA_RESP_ERR__GAPLESS_GUARANTEE ] { -148 }
+ Constant [ integer RD_KAFKA_RESP_ERR__MAX_POLL_EXCEEDED ] { -147 }
Constant [ integer RD_KAFKA_RESP_ERR__END ] { -100 }
Constant [ integer RD_KAFKA_RESP_ERR_UNKNOWN ] { -1 }
Constant [ integer RD_KAFKA_RESP_ERR_NO_ERROR ] { 0 }
@@ -109,6 +121,25 @@ Extension [ <persistent> extension #127 rdkafka version 3.0.5 ] {
Constant [ integer RD_KAFKA_RESP_ERR_TRANSACTIONAL_ID_AUTHORIZATION_FAILED ] { 53 }
Constant [ integer RD_KAFKA_RESP_ERR_SECURITY_DISABLED ] { 54 }
Constant [ integer RD_KAFKA_RESP_ERR_OPERATION_NOT_ATTEMPTED ] { 55 }
+ Constant [ integer RD_KAFKA_RESP_ERR_KAFKA_STORAGE_ERROR ] { 56 }
+ Constant [ integer RD_KAFKA_RESP_ERR_LOG_DIR_NOT_FOUND ] { 57 }
+ Constant [ integer RD_KAFKA_RESP_ERR_SASL_AUTHENTICATION_FAILED ] { 58 }
+ Constant [ integer RD_KAFKA_RESP_ERR_UNKNOWN_PRODUCER_ID ] { 59 }
+ Constant [ integer RD_KAFKA_RESP_ERR_REASSIGNMENT_IN_PROGRESS ] { 60 }
+ Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_AUTH_DISABLED ] { 61 }
+ Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_NOT_FOUND ] { 62 }
+ Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_OWNER_MISMATCH ] { 63 }
+ Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_REQUEST_NOT_ALLOWED ] { 64 }
+ Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_AUTHORIZATION_FAILED ] { 65 }
+ Constant [ integer RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_EXPIRED ] { 66 }
+ Constant [ integer RD_KAFKA_RESP_ERR_INVALID_PRINCIPAL_TYPE ] { 67 }
+ Constant [ integer RD_KAFKA_RESP_ERR_NON_EMPTY_GROUP ] { 68 }
+ Constant [ integer RD_KAFKA_RESP_ERR_GROUP_ID_NOT_FOUND ] { 69 }
+ Constant [ integer RD_KAFKA_RESP_ERR_FETCH_SESSION_ID_NOT_FOUND ] { 70 }
+ Constant [ integer RD_KAFKA_RESP_ERR_INVALID_FETCH_SESSION_EPOCH ] { 71 }
+ Constant [ integer RD_KAFKA_RESP_ERR_LISTENER_NOT_FOUND ] { 72 }
+ Constant [ integer RD_KAFKA_RESP_ERR_TOPIC_DELETION_DISABLED ] { 73 }
+ Constant [ integer RD_KAFKA_RESP_ERR_UNSUPPORTED_COMPRESSION_TYPE ] { 74 }
Constant [ integer RD_KAFKA_CONF_UNKNOWN ] { -2 }
Constant [ integer RD_KAFKA_CONF_INVALID ] { -1 }
Constant [ integer RD_KAFKA_CONF_OK ] { 0 }
@@ -510,7 +541,7 @@ Extension [ <persistent> extension #127 rdkafka version 3.0.5 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [10] {
Method [ <internal:rdkafka, ctor> public method __construct ] {
- Parameters [0] {
@@ -565,6 +596,20 @@ Extension [ <persistent> extension #127 rdkafka version 3.0.5 ] {
Parameter #0 [ <required> $callback ]
}
}
+
+ Method [ <internal:rdkafka> public method setConsumeCb ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
+
+ Method [ <internal:rdkafka> public method setOffsetCommitCb ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
}
}
@@ -597,7 +642,9 @@ Extension [ <persistent> extension #127 rdkafka version 3.0.5 ] {
Method [ <internal:rdkafka> public method set ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
}
}
@@ -627,7 +674,7 @@ Extension [ <persistent> extension #127 rdkafka version 3.0.5 ] {
Property [ <default> private $dr_msg_cb ]
}
- - Methods [11] {
+ - Methods [12] {
Method [ <internal:rdkafka, ctor> public method __construct ] {
- Parameters [1] {
@@ -704,6 +751,14 @@ Extension [ <persistent> extension #127 rdkafka version 3.0.5 ] {
Parameter #1 [ <optional> $topic_conf ]
}
}
+
+ Method [ <internal:rdkafka> public method getCommittedOffsets ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $topic_partitions ]
+ Parameter #1 [ <required> $timeout_ms ]
+ }
+ }
}
}
@@ -718,14 +773,16 @@ Extension [ <persistent> extension #127 rdkafka version 3.0.5 ] {
- Static methods [0] {
}
- - Properties [7] {
+ - Properties [9] {
Property [ <default> public $err ]
Property [ <default> public $topic_name ]
+ Property [ <default> public $timestamp ]
Property [ <default> public $partition ]
Property [ <default> public $payload ]
Property [ <default> public $len ]
Property [ <default> public $key ]
Property [ <default> public $offset ]
+ Property [ <default> public $headers ]
}
- Methods [1] {
@@ -1183,7 +1240,7 @@ Extension [ <persistent> extension #127 rdkafka version 3.0.5 ] {
- Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:rdkafka, ctor> private method __construct ] {
- Parameters [0] {
@@ -1195,8 +1252,19 @@ Extension [ <persistent> extension #127 rdkafka version 3.0.5 ] {
- Parameters [4] {
Parameter #0 [ <required> $partition ]
Parameter #1 [ <required> $msgflags ]
- Parameter #2 [ <required> $payload ]
+ Parameter #2 [ <optional> $payload ]
+ Parameter #3 [ <optional> $key ]
+ }
+ }
+
+ Method [ <internal:rdkafka> public method producev ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $partition ]
+ Parameter #1 [ <required> $msgflags ]
+ Parameter #2 [ <optional> $payload ]
Parameter #3 [ <optional> $key ]
+ Parameter #4 [ <optional> $headers ]
}
}
diff --git a/php-pecl-rdkafka.spec b/php-pecl-rdkafka.spec
index a2cc99c..af3cf34 100644
--- a/php-pecl-rdkafka.spec
+++ b/php-pecl-rdkafka.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-pecl-rdkafka
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -14,26 +14,21 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name rdkafka
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
%global buildver %(pkg-config --silence-errors --modversion rdkafka 2>/dev/null || echo 65536)
Summary: Kafka client based on librdkafka
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 3.0.5
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 3.1.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
-Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: librdkafka-devel > 0.8
-BuildRequires: %{?scl_prefix}php-devel > 5.3
+BuildRequires: %{?scl_prefix}php-devel > 5.6
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -52,22 +47,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
@@ -223,6 +202,10 @@ cd ../ZTS
%changelog
+* Thu Apr 18 2019 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+- raise dependency on PHP 5.6
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 3.0.5-3
- rebuild for 7.3.0beta2 new ABI