summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-08-16 14:56:40 +0200
committerRemi Collet <remi@remirepo.net>2018-08-16 14:56:40 +0200
commit7881c415922bc9407ff5c0a9a0692d27bb768f76 (patch)
treed598a04b1eb315c869f22c8b2c1d66ab26f81c0a
parentcb8de1966a7f2a537ae6d2336795e420305e419c (diff)
rebuild for 7.3.0beta2 new ABI
refresh patch for PHP 7.3
-rw-r--r--4.patch42
-rw-r--r--php-pecl-rar.spec6
2 files changed, 44 insertions, 4 deletions
diff --git a/4.patch b/4.patch
index c5b70ab..2f41707 100644
--- a/4.patch
+++ b/4.patch
@@ -1,7 +1,7 @@
From 1225c9240e0e368dad6ccc5f618e000560b4925d Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Tue, 26 Jun 2018 15:22:42 +0200
-Subject: [PATCH 1/2] relax tests for 7.3 (bool/boolean, main/count)
+Subject: [PATCH 1/3] relax tests for 7.3 (bool/boolean, main/count)
---
tests/002.phpt | 2 +-
@@ -93,11 +93,11 @@ index 39b8331..6ddd6f2 100644
From 5ca8d78562769fe38c0b8d1b2bcb586f18ca6dd5 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Wed, 18 Jul 2018 11:02:14 +0200
-Subject: [PATCH 2/2] fix for iterator changes in 7.3.0alpha4
+Subject: [PATCH 2/3] fix for iterator changes in 7.3.0alpha4
---
rar_error.c | 2 +-
- rararch.c | 104 ++++++++++++++++++++++++++++++++----------------------------
+ rararch.c | 104 +++++++++++++++++++++++++++-------------------------
2 files changed, 56 insertions(+), 50 deletions(-)
diff --git a/rar_error.c b/rar_error.c
@@ -243,3 +243,39 @@ index 1c065df..06ed9ca 100644
zend_class_implements(rararch_ce_ptr TSRMLS_CC, 1, zend_ce_traversable);
}
+
+From 5a0cd32191356ec3e6bd7c29d684fc8d9fac7032 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 16 Aug 2018 14:52:03 +0200
+Subject: [PATCH 3/3] new constant names in 7.3
+
+---
+ rar_stream.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/rar_stream.c b/rar_stream.c
+index ed2be60..3292148 100644
+--- a/rar_stream.c
++++ b/rar_stream.c
+@@ -293,7 +293,7 @@ static int _rar_stat_from_header(struct RARHeaderDataEx *header,
+ * SUBHEAD_TYPE_UOWNER), but it is not exposed in unRAR */
+ ssb->sb.st_uid = 0;
+ ssb->sb.st_gid = 0;
+-#ifdef HAVE_ST_RDEV
++#if defined(HAVE_ST_RDEV) || defined(HAVE_STRUCT_STAT_ST_RDEV)
+ ssb->sb.st_rdev = 0;
+ #endif
+ /* never mind signedness, we'll never get sizes big enough for that to
+@@ -324,10 +324,10 @@ static int _rar_stat_from_header(struct RARHeaderDataEx *header,
+ &ssb->sb.st_mtime);
+ }
+
+-#ifdef HAVE_ST_BLKSIZE
++#if defined(HAVE_ST_BLKSIZE) || defined(HAVE_STRUCT_STAT_ST_BLKSIZE)
+ ssb->sb.st_blksize = 0;
+ #endif
+-#ifdef HAVE_ST_BLOCKS
++#if defined(HAVE_ST_BLOCKS) || defined (HAVE_STRUCT_STAT_ST_BLOCKS)
+ ssb->sb.st_blocks = 0;
+ #endif
+ /* php_stat in filestat.c doesn't check this one, so don't touch it */
diff --git a/php-pecl-rar.spec b/php-pecl-rar.spec
index f58c56f..ef97fef 100644
--- a/php-pecl-rar.spec
+++ b/php-pecl-rar.spec
@@ -19,7 +19,7 @@
Summary: PHP extension for reading RAR archives
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 4.0.0
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP and Freeware with further limitations
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -227,6 +227,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 4.0.0-4
+- rebuild for 7.3.0beta2 new ABI
+- refresh patch for PHP 7.3
+
* Wed Jul 18 2018 Remi Collet <remi@remirepo.net> - 4.0.0-3
- rebuild for 7.3.0alpha4 new ABI