summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-07 09:45:25 +0100
committerRemi Collet <remi@remirepo.net>2020-12-07 09:45:25 +0100
commit62a4fa297ee807fa60f627f2138acaaf9268f2f4 (patch)
tree861c050bdf62794e8a46f94aa9882a6d945249b8
parent423cf6d6a23e147b70b3c89541bf3060ad9910a1 (diff)
update to 4.2.0
-rw-r--r--.gitignore2
-rw-r--r--4.patch281
-rw-r--r--PHPINFO7
-rw-r--r--REFLECTION108
-rw-r--r--php-pecl-rar.spec51
5 files changed, 79 insertions, 370 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/4.patch b/4.patch
deleted file mode 100644
index 2f41707..0000000
--- a/4.patch
+++ /dev/null
@@ -1,281 +0,0 @@
-From 1225c9240e0e368dad6ccc5f618e000560b4925d Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 26 Jun 2018 15:22:42 +0200
-Subject: [PATCH 1/3] relax tests for 7.3 (bool/boolean, main/count)
-
----
- tests/002.phpt | 2 +-
- tests/003.phpt | 2 +-
- tests/008.phpt | 2 +-
- tests/079.phpt | 4 ++--
- tests/092.phpt | 4 ++--
- 5 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/tests/002.phpt b/tests/002.phpt
-index f90617a..358aba8 100644
---- a/tests/002.phpt
-+++ b/tests/002.phpt
-@@ -163,6 +163,6 @@ array(2) {
-
- Warning: rar_open(): Failed to open %s: ERAR_EOPEN (file open error) in %s on line %d
-
--Warning: rar_list() expects parameter 1 to be RarArchive, boolean given in %s on line %d
-+Warning: rar_list() expects parameter 1 to be RarArchive, boo%s given in %s on line %d
- NULL
- Done
-diff --git a/tests/003.phpt b/tests/003.phpt
-index 2f0a6df..9b77d2f 100644
---- a/tests/003.phpt
-+++ b/tests/003.phpt
-@@ -89,6 +89,6 @@ object(RarEntry)#%d (%d) {
-
- Warning: rar_open(): Failed to open %s: ERAR_EOPEN (file open error) in %s on line %d
-
--Warning: rar_entry_get() expects parameter 1 to be RarArchive, boolean given in %s on line %d
-+Warning: rar_entry_get() expects parameter 1 to be RarArchive, boo%s given in %s on line %d
- NULL
- Done
-diff --git a/tests/008.phpt b/tests/008.phpt
-index f79c97a..f864c97 100644
---- a/tests/008.phpt
-+++ b/tests/008.phpt
-@@ -28,7 +28,7 @@ bool(false)
-
- Warning: rar_open(): Failed to open %s: ERAR_EOPEN (file open error) in %s on line %d
-
--Warning: rar_entry_get() expects parameter 1 to be RarArchive, boolean given in %s on line %d
-+Warning: rar_entry_get() expects parameter 1 to be RarArchive, boo%s given in %s on line %d
- NULL
-
- Done
-diff --git a/tests/079.phpt b/tests/079.phpt
-index f243b85..0ee005a 100644
---- a/tests/079.phpt
-+++ b/tests/079.phpt
-@@ -48,12 +48,12 @@ Count: 13
-
- * Closed file test (1):
-
--Warning: count(): The archive is already closed in %s on line %d
-+Warning: %s(): The archive is already closed in %s on line %d
- int(0)
-
- * Closed file test (2):
-
--Warning: count(): The archive is already closed in %s on line %d
-+Warning: %s(): The archive is already closed in %s on line %d
- int(0)
-
- * Closed file test (3, exceptions):
-diff --git a/tests/092.phpt b/tests/092.phpt
-index 39b8331..6ddd6f2 100644
---- a/tests/092.phpt
-+++ b/tests/092.phpt
-@@ -54,7 +54,7 @@ Warning: rar_allow_broken_set() expects exactly 2 parameters, 1 given in %s on l
- Warning: RarArchive::getEntries(): ERAR_EOPEN (file open error) in %s on line %d
- bool(false)
-
--Warning: count(): ERAR_EOPEN (file open error) in %s on line %d
-+Warning: %s(): ERAR_EOPEN (file open error) in %s on line %d
- int(0)
-
- * broken file; do not allow broken (explicit)
-@@ -62,7 +62,7 @@ int(0)
- Warning: RarArchive::getEntries(): ERAR_EOPEN (file open error) in %s on line %d
- bool(false)
-
--Warning: count(): ERAR_EOPEN (file open error) in %s on line %d
-+Warning: %s(): ERAR_EOPEN (file open error) in %s on line %d
- int(0)
-
- * broken file; allow broken
-
-From 5ca8d78562769fe38c0b8d1b2bcb586f18ca6dd5 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 18 Jul 2018 11:02:14 +0200
-Subject: [PATCH 2/3] fix for iterator changes in 7.3.0alpha4
-
----
- rar_error.c | 2 +-
- rararch.c | 104 +++++++++++++++++++++++++++-------------------------
- 2 files changed, 56 insertions(+), 50 deletions(-)
-
-diff --git a/rar_error.c b/rar_error.c
-index 447a19d..13a742b 100644
---- a/rar_error.c
-+++ b/rar_error.c
-@@ -252,7 +252,7 @@ void minit_rarerror(TSRMLS_D) /* {{{ */
- rarexception_ce_ptr->ce_flags |= ZEND_ACC_FINAL;
- zend_declare_property_bool(rarexception_ce_ptr, "usingExceptions",
- sizeof("usingExceptions") -1, 0L /* FALSE */,
-- ZEND_ACC_PRIVATE | ZEND_ACC_STATIC TSRMLS_CC);
-+ ZEND_ACC_STATIC TSRMLS_CC);
- }
- /* }}} */
-
-diff --git a/rararch.c b/rararch.c
-index 1c065df..06ed9ca 100644
---- a/rararch.c
-+++ b/rararch.c
-@@ -932,55 +932,6 @@ static void rararch_it_move_forward(zend_object_iterator *iter TSRMLS_DC);
- static void rararch_it_rewind(zend_object_iterator *iter TSRMLS_DC);
- /* }}} */
-
--/* {{{ rararch_it_get_iterator */
--static zend_object_iterator *rararch_it_get_iterator(zend_class_entry *ce,
-- zval *object,
-- int by_ref TSRMLS_DC)
--{
-- rararch_iterator *it;
-- rar_file_t *rar;
-- int res;
--
-- if (by_ref) {
-- php_error_docref(NULL TSRMLS_CC, E_ERROR,
-- "An iterator cannot be used with foreach by reference");
-- }
--
-- it = emalloc(sizeof *it);
--
--#if PHP_MAJOR_VERSION < 7
-- zval_add_ref(&object);
-- it->parent.data = object;
-- it->value = NULL;
--#else
-- zend_iterator_init((zend_object_iterator *) it);
-- ZVAL_COPY(&it->parent.data, object);
-- ZVAL_UNDEF(&it->value);
--#endif
--
-- it->parent.funcs = ce->iterator_funcs.funcs;
-- it->state = NULL;
--
-- res = _rar_get_file_resource_ex(object, &rar, 1 TSRMLS_CC);
-- if (res == FAILURE)
-- php_error_docref(NULL TSRMLS_CC, E_ERROR,
-- "Cannot fetch RarArchive object");
-- if (rar->arch_handle == NULL)
-- php_error_docref(NULL TSRMLS_CC, E_ERROR,
-- "The archive is already closed, cannot give an iterator");
-- res = _rar_list_files(rar TSRMLS_CC);
-- if (_rar_handle_error(res TSRMLS_CC) == FAILURE) {
-- /* if it failed, do not expose the possibly incomplete entry list */
-- it->empty_iterator = 1;
-- }
-- else
-- it->empty_iterator = 0;
--
-- _rar_entry_search_start(rar, RAR_SEARCH_TRAVERSE, &it->state TSRMLS_CC);
-- return (zend_object_iterator*) it;
--}
--/* }}} */
--
- /* {{{ rararch_it_invalidate_current */
- static void rararch_it_invalidate_current(zend_object_iterator *iter TSRMLS_DC)
- {
-@@ -1147,6 +1098,59 @@ static zend_object_iterator_funcs rararch_it_funcs = {
- };
- /* }}} */
-
-+/* {{{ rararch_it_get_iterator */
-+static zend_object_iterator *rararch_it_get_iterator(zend_class_entry *ce,
-+ zval *object,
-+ int by_ref TSRMLS_DC)
-+{
-+ rararch_iterator *it;
-+ rar_file_t *rar;
-+ int res;
-+
-+ if (by_ref) {
-+ php_error_docref(NULL TSRMLS_CC, E_ERROR,
-+ "An iterator cannot be used with foreach by reference");
-+ }
-+
-+ it = emalloc(sizeof *it);
-+
-+#if PHP_MAJOR_VERSION < 7
-+ zval_add_ref(&object);
-+ it->parent.data = object;
-+ it->value = NULL;
-+#else
-+ zend_iterator_init((zend_object_iterator *) it);
-+ ZVAL_COPY(&it->parent.data, object);
-+ ZVAL_UNDEF(&it->value);
-+#endif
-+
-+#if PHP_VERSION_ID < 70300
-+ it->parent.funcs = ce->iterator_funcs.funcs;
-+#else
-+ it->parent.funcs = &rararch_it_funcs;
-+#endif
-+ it->state = NULL;
-+
-+ res = _rar_get_file_resource_ex(object, &rar, 1 TSRMLS_CC);
-+ if (res == FAILURE)
-+ php_error_docref(NULL TSRMLS_CC, E_ERROR,
-+ "Cannot fetch RarArchive object");
-+ if (rar->arch_handle == NULL)
-+ php_error_docref(NULL TSRMLS_CC, E_ERROR,
-+ "The archive is already closed, cannot give an iterator");
-+ res = _rar_list_files(rar TSRMLS_CC);
-+ if (_rar_handle_error(res TSRMLS_CC) == FAILURE) {
-+ /* if it failed, do not expose the possibly incomplete entry list */
-+ it->empty_iterator = 1;
-+ }
-+ else
-+ it->empty_iterator = 0;
-+
-+ _rar_entry_search_start(rar, RAR_SEARCH_TRAVERSE, &it->state TSRMLS_CC);
-+ return (zend_object_iterator*) it;
-+}
-+/* }}} */
-+
- void minit_rararch(TSRMLS_D)
- {
- zend_class_entry ce;
-@@ -1170,7 +1174,9 @@ void minit_rararch(TSRMLS_D)
- rararch_ce_ptr->clone = NULL;
- rararch_ce_ptr->create_object = &rararch_ce_create_object;
- rararch_ce_ptr->get_iterator = rararch_it_get_iterator;
-+#if PHP_VERSION_ID < 70300
- rararch_ce_ptr->iterator_funcs.funcs = &rararch_it_funcs;
-+#endif
- zend_class_implements(rararch_ce_ptr TSRMLS_CC, 1, zend_ce_traversable);
- }
-
-
-From 5a0cd32191356ec3e6bd7c29d684fc8d9fac7032 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 16 Aug 2018 14:52:03 +0200
-Subject: [PATCH 3/3] new constant names in 7.3
-
----
- rar_stream.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/rar_stream.c b/rar_stream.c
-index ed2be60..3292148 100644
---- a/rar_stream.c
-+++ b/rar_stream.c
-@@ -293,7 +293,7 @@ static int _rar_stat_from_header(struct RARHeaderDataEx *header,
- * SUBHEAD_TYPE_UOWNER), but it is not exposed in unRAR */
- ssb->sb.st_uid = 0;
- ssb->sb.st_gid = 0;
--#ifdef HAVE_ST_RDEV
-+#if defined(HAVE_ST_RDEV) || defined(HAVE_STRUCT_STAT_ST_RDEV)
- ssb->sb.st_rdev = 0;
- #endif
- /* never mind signedness, we'll never get sizes big enough for that to
-@@ -324,10 +324,10 @@ static int _rar_stat_from_header(struct RARHeaderDataEx *header,
- &ssb->sb.st_mtime);
- }
-
--#ifdef HAVE_ST_BLKSIZE
-+#if defined(HAVE_ST_BLKSIZE) || defined(HAVE_STRUCT_STAT_ST_BLKSIZE)
- ssb->sb.st_blksize = 0;
- #endif
--#ifdef HAVE_ST_BLOCKS
-+#if defined(HAVE_ST_BLOCKS) || defined (HAVE_STRUCT_STAT_ST_BLOCKS)
- ssb->sb.st_blocks = 0;
- #endif
- /* php_stat in filestat.c doesn't check this one, so don't touch it */
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..200ef65
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,7 @@
+
+rar
+
+RAR support => enabled
+RAR EXT version => 4.2.0
+UnRAR version => 6.00 beta2 patch1 2020-11-12
+UnRAR API version => 8 extension 1
diff --git a/REFLECTION b/REFLECTION
index ab45bc3..ba9be69 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,12 +1,12 @@
-Extension [ <persistent> extension #120 rar version 4.0.0 ] {
+Extension [ <persistent> extension #117 rar version 4.2.0 ] {
- Constants [6] {
- Constant [ integer RAR_HOST_MSDOS ] { 0 }
- Constant [ integer RAR_HOST_OS2 ] { 1 }
- Constant [ integer RAR_HOST_WIN32 ] { 2 }
- Constant [ integer RAR_HOST_UNIX ] { 3 }
- Constant [ integer RAR_HOST_MACOS ] { 4 }
- Constant [ integer RAR_HOST_BEOS ] { 5 }
+ Constant [ int RAR_HOST_MSDOS ] { 0 }
+ Constant [ int RAR_HOST_OS2 ] { 1 }
+ Constant [ int RAR_HOST_WIN32 ] { 2 }
+ Constant [ int RAR_HOST_UNIX ] { 3 }
+ Constant [ int RAR_HOST_MACOS ] { 4 }
+ Constant [ int RAR_HOST_BEOS ] { 5 }
}
- Functions {
@@ -154,52 +154,52 @@ Extension [ <persistent> extension #120 rar version 4.0.0 ] {
Class [ <internal:rar> final class RarEntry ] {
- Constants [46] {
- Constant [ integer HOST_MSDOS ] { 0 }
- Constant [ integer HOST_OS2 ] { 1 }
- Constant [ integer HOST_WIN32 ] { 2 }
- Constant [ integer HOST_UNIX ] { 3 }
- Constant [ integer HOST_MACOS ] { 4 }
- Constant [ integer HOST_BEOS ] { 5 }
- Constant [ integer FSREDIR_UNIXSYMLINK ] { 1 }
- Constant [ integer FSREDIR_WINSYMLINK ] { 2 }
- Constant [ integer FSREDIR_JUNCTION ] { 3 }
- Constant [ integer FSREDIR_HARDLINK ] { 4 }
- Constant [ integer FSREDIR_FILECOPY ] { 5 }
- Constant [ integer ATTRIBUTE_WIN_READONLY ] { 1 }
- Constant [ integer ATTRIBUTE_WIN_HIDDEN ] { 2 }
- Constant [ integer ATTRIBUTE_WIN_SYSTEM ] { 4 }
- Constant [ integer ATTRIBUTE_WIN_DIRECTORY ] { 16 }
- Constant [ integer ATTRIBUTE_WIN_ARCHIVE ] { 32 }
- Constant [ integer ATTRIBUTE_WIN_DEVICE ] { 64 }
- Constant [ integer ATTRIBUTE_WIN_NORMAL ] { 128 }
- Constant [ integer ATTRIBUTE_WIN_TEMPORARY ] { 256 }
- Constant [ integer ATTRIBUTE_WIN_SPARSE_FILE ] { 512 }
- Constant [ integer ATTRIBUTE_WIN_REPARSE_POINT ] { 1024 }
- Constant [ integer ATTRIBUTE_WIN_COMPRESSED ] { 2048 }
- Constant [ integer ATTRIBUTE_WIN_OFFLINE ] { 4096 }
- Constant [ integer ATTRIBUTE_WIN_NOT_CONTENT_INDEXED ] { 8192 }
- Constant [ integer ATTRIBUTE_WIN_ENCRYPTED ] { 16384 }
- Constant [ integer ATTRIBUTE_WIN_VIRTUAL ] { 65536 }
- Constant [ integer ATTRIBUTE_UNIX_WORLD_EXECUTE ] { 1 }
- Constant [ integer ATTRIBUTE_UNIX_WORLD_WRITE ] { 2 }
- Constant [ integer ATTRIBUTE_UNIX_WORLD_READ ] { 4 }
- Constant [ integer ATTRIBUTE_UNIX_GROUP_EXECUTE ] { 8 }
- Constant [ integer ATTRIBUTE_UNIX_GROUP_WRITE ] { 16 }
- Constant [ integer ATTRIBUTE_UNIX_GROUP_READ ] { 32 }
- Constant [ integer ATTRIBUTE_UNIX_OWNER_EXECUTE ] { 64 }
- Constant [ integer ATTRIBUTE_UNIX_OWNER_WRITE ] { 128 }
- Constant [ integer ATTRIBUTE_UNIX_OWNER_READ ] { 256 }
- Constant [ integer ATTRIBUTE_UNIX_STICKY ] { 512 }
- Constant [ integer ATTRIBUTE_UNIX_SETGID ] { 1024 }
- Constant [ integer ATTRIBUTE_UNIX_SETUID ] { 2048 }
- Constant [ integer ATTRIBUTE_UNIX_FINAL_QUARTET ] { 61440 }
- Constant [ integer ATTRIBUTE_UNIX_FIFO ] { 4096 }
- Constant [ integer ATTRIBUTE_UNIX_CHAR_DEV ] { 8192 }
- Constant [ integer ATTRIBUTE_UNIX_DIRECTORY ] { 16384 }
- Constant [ integer ATTRIBUTE_UNIX_BLOCK_DEV ] { 24576 }
- Constant [ integer ATTRIBUTE_UNIX_REGULAR_FILE ] { 32768 }
- Constant [ integer ATTRIBUTE_UNIX_SYM_LINK ] { 40960 }
- Constant [ integer ATTRIBUTE_UNIX_SOCKET ] { 49152 }
+ Constant [ public int HOST_MSDOS ] { 0 }
+ Constant [ public int HOST_OS2 ] { 1 }
+ Constant [ public int HOST_WIN32 ] { 2 }
+ Constant [ public int HOST_UNIX ] { 3 }
+ Constant [ public int HOST_MACOS ] { 4 }
+ Constant [ public int HOST_BEOS ] { 5 }
+ Constant [ public int FSREDIR_UNIXSYMLINK ] { 1 }
+ Constant [ public int FSREDIR_WINSYMLINK ] { 2 }
+ Constant [ public int FSREDIR_JUNCTION ] { 3 }
+ Constant [ public int FSREDIR_HARDLINK ] { 4 }
+ Constant [ public int FSREDIR_FILECOPY ] { 5 }
+ Constant [ public int ATTRIBUTE_WIN_READONLY ] { 1 }
+ Constant [ public int ATTRIBUTE_WIN_HIDDEN ] { 2 }
+ Constant [ public int ATTRIBUTE_WIN_SYSTEM ] { 4 }
+ Constant [ public int ATTRIBUTE_WIN_DIRECTORY ] { 16 }
+ Constant [ public int ATTRIBUTE_WIN_ARCHIVE ] { 32 }
+ Constant [ public int ATTRIBUTE_WIN_DEVICE ] { 64 }
+ Constant [ public int ATTRIBUTE_WIN_NORMAL ] { 128 }
+ Constant [ public int ATTRIBUTE_WIN_TEMPORARY ] { 256 }
+ Constant [ public int ATTRIBUTE_WIN_SPARSE_FILE ] { 512 }
+ Constant [ public int ATTRIBUTE_WIN_REPARSE_POINT ] { 1024 }
+ Constant [ public int ATTRIBUTE_WIN_COMPRESSED ] { 2048 }
+ Constant [ public int ATTRIBUTE_WIN_OFFLINE ] { 4096 }
+ Constant [ public int ATTRIBUTE_WIN_NOT_CONTENT_INDEXED ] { 8192 }
+ Constant [ public int ATTRIBUTE_WIN_ENCRYPTED ] { 16384 }
+ Constant [ public int ATTRIBUTE_WIN_VIRTUAL ] { 65536 }
+ Constant [ public int ATTRIBUTE_UNIX_WORLD_EXECUTE ] { 1 }
+ Constant [ public int ATTRIBUTE_UNIX_WORLD_WRITE ] { 2 }
+ Constant [ public int ATTRIBUTE_UNIX_WORLD_READ ] { 4 }
+ Constant [ public int ATTRIBUTE_UNIX_GROUP_EXECUTE ] { 8 }
+ Constant [ public int ATTRIBUTE_UNIX_GROUP_WRITE ] { 16 }
+ Constant [ public int ATTRIBUTE_UNIX_GROUP_READ ] { 32 }
+ Constant [ public int ATTRIBUTE_UNIX_OWNER_EXECUTE ] { 64 }
+ Constant [ public int ATTRIBUTE_UNIX_OWNER_WRITE ] { 128 }
+ Constant [ public int ATTRIBUTE_UNIX_OWNER_READ ] { 256 }
+ Constant [ public int ATTRIBUTE_UNIX_STICKY ] { 512 }
+ Constant [ public int ATTRIBUTE_UNIX_SETGID ] { 1024 }
+ Constant [ public int ATTRIBUTE_UNIX_SETUID ] { 2048 }
+ Constant [ public int ATTRIBUTE_UNIX_FINAL_QUARTET ] { 61440 }
+ Constant [ public int ATTRIBUTE_UNIX_FIFO ] { 4096 }
+ Constant [ public int ATTRIBUTE_UNIX_CHAR_DEV ] { 8192 }
+ Constant [ public int ATTRIBUTE_UNIX_DIRECTORY ] { 16384 }
+ Constant [ public int ATTRIBUTE_UNIX_BLOCK_DEV ] { 24576 }
+ Constant [ public int ATTRIBUTE_UNIX_REGULAR_FILE ] { 32768 }
+ Constant [ public int ATTRIBUTE_UNIX_SYM_LINK ] { 40960 }
+ Constant [ public int ATTRIBUTE_UNIX_SOCKET ] { 49152 }
}
- Static properties [0] {
@@ -354,7 +354,7 @@ Extension [ <persistent> extension #120 rar version 4.0.0 ] {
}
- Static properties [1] {
- Property [ private static $usingExceptions ]
+ Property [ public static $usingExceptions ]
}
- Static methods [2] {
diff --git a/php-pecl-rar.spec b/php-pecl-rar.spec
index 86a2aaa..e879586 100644
--- a/php-pecl-rar.spec
+++ b/php-pecl-rar.spec
@@ -1,6 +1,6 @@
# spec file for php-pecl-rar
#
-# Copyright (c) 2013-2019 Remi Collet
+# Copyright (c) 2013-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -18,14 +18,12 @@
Summary: PHP extension for reading RAR archives
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 4.0.0
-Release: 6%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 4.2.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP and Freeware with further limitations
Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-
-Patch0: https://patch-diff.githubusercontent.com/raw/cataphract/php-rar/pull/4.patch
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -44,38 +42,17 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -97,8 +74,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr4
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_RAR_VERSION/{s/.* "//;s/".*$//;p}' php_rar.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -197,7 +172,7 @@ TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php --show-diff
+%{_bindir}/php -n run-tests8.php --show-diff
%if %{with_zts}
@@ -212,7 +187,7 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests8.php --show-diff
%endif
@@ -231,6 +206,12 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Dec 7 2020 Remi Collet <remi@remirepo.net> - 4.2.0-1
+- update to 4.2.0
+
+* Mon Oct 12 2020 Remi Collet <remi@remirepo.net> - 4.1.0-1
+- update to 4.1.0
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 4.0.0-6
- rebuild for 7.4.0RC1