summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-01 08:11:09 +0200
committerRemi Collet <remi@remirepo.net>2017-08-01 08:11:09 +0200
commit4a8311bcbf88187ae32c08c5c373ce405d06c41f (patch)
tree9c4027c3b762fee71df5a10b29a6256cb8b31238
parent59a60217e5a81b586f840320a8492da29825a40f (diff)
v4.0.0
-rw-r--r--.gitignore7
-rw-r--r--REFLECTION59
-rw-r--r--php-pecl-rar.spec47
3 files changed, 82 insertions, 31 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/REFLECTION b/REFLECTION
index d357b5f..ab45bc3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #121 rar version 3.0.2 ] {
+Extension [ <persistent> extension #120 rar version 4.0.0 ] {
- Constants [6] {
Constant [ integer RAR_HOST_MSDOS ] { 0 }
@@ -153,13 +153,18 @@ Extension [ <persistent> extension #121 rar version 3.0.2 ] {
Class [ <internal:rar> final class RarEntry ] {
- - Constants [41] {
+ - Constants [46] {
Constant [ integer HOST_MSDOS ] { 0 }
Constant [ integer HOST_OS2 ] { 1 }
Constant [ integer HOST_WIN32 ] { 2 }
Constant [ integer HOST_UNIX ] { 3 }
Constant [ integer HOST_MACOS ] { 4 }
Constant [ integer HOST_BEOS ] { 5 }
+ Constant [ integer FSREDIR_UNIXSYMLINK ] { 1 }
+ Constant [ integer FSREDIR_WINSYMLINK ] { 2 }
+ Constant [ integer FSREDIR_JUNCTION ] { 3 }
+ Constant [ integer FSREDIR_HARDLINK ] { 4 }
+ Constant [ integer FSREDIR_FILECOPY ] { 5 }
Constant [ integer ATTRIBUTE_WIN_READONLY ] { 1 }
Constant [ integer ATTRIBUTE_WIN_HIDDEN ] { 2 }
Constant [ integer ATTRIBUTE_WIN_SYSTEM ] { 4 }
@@ -203,7 +208,7 @@ Extension [ <persistent> extension #121 rar version 3.0.2 ] {
- Static methods [0] {
}
- - Properties [12] {
+ - Properties [15] {
Property [ <default> private $rarfile ]
Property [ <default> private $position ]
Property [ <default> private $name ]
@@ -216,9 +221,12 @@ Extension [ <persistent> extension #121 rar version 3.0.2 ] {
Property [ <default> private $version ]
Property [ <default> private $method ]
Property [ <default> private $flags ]
+ Property [ <default> private $redir_type ]
+ Property [ <default> private $redir_to_directory ]
+ Property [ <default> private $redir_target ]
}
- - Methods [16] {
+ - Methods [19] {
Method [ <internal:rar> public method extract ] {
- Parameters [4] {
@@ -308,6 +316,24 @@ Extension [ <persistent> extension #121 rar version 3.0.2 ] {
}
}
+ Method [ <internal:rar> public method getRedirType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:rar> public method isRedirectToDirectory ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:rar> public method getRedirTarget ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:rar> public method __toString ] {
- Parameters [0] {
@@ -322,7 +348,7 @@ Extension [ <persistent> extension #121 rar version 3.0.2 ] {
}
}
- Class [ <internal:rar> class RarException extends Exception ] {
+ Class [ <internal:rar> final class RarException extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -353,8 +379,8 @@ Extension [ <persistent> extension #121 rar version 3.0.2 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
- Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -363,28 +389,31 @@ Extension [ <persistent> extension #121 rar version 3.0.2 ] {
}
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
diff --git a/php-pecl-rar.spec b/php-pecl-rar.spec
index bdb41ec..e66426e 100644
--- a/php-pecl-rar.spec
+++ b/php-pecl-rar.spec
@@ -8,7 +8,7 @@
#
%{?scl: %scl_package php-pecl-rar}
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name rar
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -18,14 +18,13 @@
Summary: PHP extension for reading RAR archives
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 3.0.2
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 4.0.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP and Freeware with further limitations
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -37,8 +36,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -54,6 +55,18 @@ Obsoletes: php55w-pecl-%{pecl_name}
Obsoletes: php56u-pecl-%{pecl_name}
Obsoletes: php56w-pecl-%{pecl_name}
%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name}
+Obsoletes: php70w-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name}
+Obsoletes: php71w-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name}
+Obsoletes: php72w-pecl-%{pecl_name}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -82,10 +95,6 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
-%if 0%{?rhel} == 5
-sed -e 's/-Wno-logical-op-parentheses//' -i config.m4
-%endif
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_RAR_VERSION/{s/.* "//;s/".*$//;p}' php_rar.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -107,6 +116,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -127,7 +138,7 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
+%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
@@ -171,6 +182,12 @@ fi
%check
+%if "%{php_version}" > "7.2"
+# count issue - under investigation
+rm ?TS/tests/079.phpt
+rm ?TS/tests/092.phpt
+%endif
+
: Minimal load test for NTS extension
cd NTS
%{_bindir}/php --no-php-ini \
@@ -182,7 +199,7 @@ TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php
+%{_bindir}/php -n run-tests.php --show-diff
%if %{with_zts}
@@ -197,16 +214,11 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php
+%{__ztsphp} -n run-tests.php --show-diff
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%{?_licensedir:%license NTS/unrar/LICENSE.txt}
%doc %{pecl_docdir}/%{pecl_name}
@@ -221,6 +233,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Aug 1 2017 Remi Collet <remi@remirepo.net> - 4.0.0-1
+- Update to 4.0.0
+
* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 3.0.2-4
- adapt for F24
- drop runtime dependency on pear, new scriptlets