summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-22 08:58:00 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-22 08:58:00 +0200
commit5681cb1303b6b8b3824d61df6083fd591c288eef (patch)
tree57256103de89b88d6b3dc4524797ee1277aa8826
parentecc8c30eee5767194e6eaa2dfd17953856001fae (diff)
php-pecl-raphf: sources from github
-rw-r--r--php-pecl-raphf-dev.spec20
1 files changed, 15 insertions, 5 deletions
diff --git a/php-pecl-raphf-dev.spec b/php-pecl-raphf-dev.spec
index 3b1938a..5a202f4 100644
--- a/php-pecl-raphf-dev.spec
+++ b/php-pecl-raphf-dev.spec
@@ -23,6 +23,11 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
+%global gh_commit 6d04f5be0a7ac5ff0d6da2d167c8f1c833dcbaff
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner m6w6
+%global gh_project ext-raphf
+%global gh_date 20150721
%global with_zts 0%{?__ztsphp:1}
%global pecl_name raphf
# tests disabled because of circular dependency on pecl/http
@@ -41,11 +46,11 @@
Summary: Resource and persistent handles factory
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.5
-Release: 0.3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.4.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.3
@@ -108,8 +113,9 @@ These are the files needed to compile programs using %{name}.
%prep
-%setup -q -c
-mv %{pecl_name}-%{version} NTS
+%setup -qc
+mv %{gh_project}-%{gh_commit} NTS
+mv NTS/package.xml .
cd NTS
# Sanity check, really often broken
@@ -172,7 +178,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Test & Documentation
for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
+do install -Dpm 644 NTS/tests/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/tests/$i
done
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
@@ -264,6 +270,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Jul 22 2015 Remi Collet <remi@fedoraproject.org> - 1.0.5-0.4.20150721git6d04f5b
+- rebuild against php 7.0.0beta2
+- sources from github
+
* Wed Jul 8 2015 Remi Collet <remi@fedoraproject.org> - 1.0.5-0.3
- rebuild against php 7.0.0beta1