summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-16 16:18:29 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-16 16:18:29 +0200
commit341d36047eb84a4b5ae5bce9871cc1d821b129f5 (patch)
tree6ef744de498cd5688a37c4635ca7bcf58503f225
parent8cef4b139e85140af18ff77c8b866000fc0bbce8 (diff)
php-pecl: add numerical prefix to extension configuration file (more)
-rw-r--r--php-pecl-quickhash.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-pecl-quickhash.spec b/php-pecl-quickhash.spec
index 30016f2..8a93248 100644
--- a/php-pecl-quickhash.spec
+++ b/php-pecl-quickhash.spec
@@ -13,11 +13,16 @@
%global pecl_name quickhash
%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Set of specific strongly-typed classes for sets and hashing
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -90,7 +95,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
EOF
@@ -122,7 +127,7 @@ rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -130,7 +135,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -189,16 +194,19 @@ rm -rf %{buildroot}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-4
+- add numerical prefix to extension configuration file (php 5.6)
+
* Tue Mar 25 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-3
- allow SCL build