summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-16 16:18:29 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-16 16:18:29 +0200
commitdb1227223474f8469f8098535e03a404ae7ba3e5 (patch)
tree75a6b915d0dc3f6c35b6ae98948de82fd6d0da0f
parent5c41bc7da83cee39835c0e68a6bffce369a7fcdc (diff)
php-pecl: add numerical prefix to extension configuration file (more)
-rw-r--r--php-pecl-qb.spec18
1 files changed, 13 insertions, 5 deletions
diff --git a/php-pecl-qb.spec b/php-pecl-qb.spec
index fe61e15..caf9ab8 100644
--- a/php-pecl-qb.spec
+++ b/php-pecl-qb.spec
@@ -17,11 +17,16 @@
#global gh_project qb
%global pecl_name qb
%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Accelerator designed mainly for graphic work
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 2.2.0
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -136,7 +141,7 @@ rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 NTS/%{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 NTS/%{pecl_name}.ini %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -144,7 +149,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
# install ZTS extension
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 ZTS/%{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 ZTS/%{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -226,16 +231,19 @@ rm -rf %{buildroot}
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 2.2.0-3
+- add numerical prefix to extension configuration file (php 5.6)
+
* Sun Mar 30 2014 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
- Update to 2.2.0 (stable)
- use sources from pecl