summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-14 08:28:00 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-14 08:28:00 +0100
commitfa9b0858e7f4616cec030c329cdb54f6452cc4bb (patch)
tree1053553d4e5a83b77373eb2602674986195317c7
parentc5957339f11902ca738565a69eaa69f4476a3c6e (diff)
php-pecl-pthreads: 2.0.0
-rw-r--r--php-pecl-pthreads.spec10
-rw-r--r--pthreads.patch60
2 files changed, 4 insertions, 66 deletions
diff --git a/php-pecl-pthreads.spec b/php-pecl-pthreads.spec
index 5c61e57..bea28ad 100644
--- a/php-pecl-pthreads.spec
+++ b/php-pecl-pthreads.spec
@@ -12,16 +12,13 @@
Summary: Threading API
Name: php-pecl-%{pecl_name}
-Version: 1.0.1
+Version: 2.0.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://github.com/krakjoe/pthreads/pull/251
-Patch0: %{pecl_name}.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: php-zts-devel > 5.3
BuildRequires: php-pear
@@ -66,8 +63,6 @@ This extension is only available for PHP in ZTS mode.
%setup -q -c
cd %{pecl_name}-%{version}
-%patch0 -p1 -b .github
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PTHREADS_VERSION/{s/.* "//;s/".*$//;p}' php_pthreads.h)
if test "x${extver}" != "x%{version}"; then
@@ -155,6 +150,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Mar 14 2014 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- Update to 2.0.0
+
* Sun Mar 09 2014 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
- Update to 1.0.1 (stable)
- open https://github.com/krakjoe/pthreads/pull/251
diff --git a/pthreads.patch b/pthreads.patch
deleted file mode 100644
index df1ee97..0000000
--- a/pthreads.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From e81dd7342121398de1c6a55380a36dad80a74875 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Sun, 9 Mar 2014 07:43:59 +0100
-Subject: [PATCH 1/2] fix build: synchro.c:133:2: error: 'else' without a
- previous 'if'
-
----
- src/synchro.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/synchro.c b/src/synchro.c
-index 07360be..54efd46 100644
---- a/src/synchro.c
-+++ b/src/synchro.c
-@@ -128,8 +128,9 @@ void pthreads_synchro_block(zval *this_ptr, zend_fcall_info *info, zend_fcall_in
- zend_fcall_info_args_clear(info, 1);
-
- /* return the result */
-- if (!failed && retval)
-+ if (!failed && retval) {
- ZVAL_ZVAL(return_value, retval, 1, 1);
-+ }
- else ZVAL_NULL(return_value);
- } /* }}} */
-
---
-1.8.3.1
-
-From a45e52eafdbc6e3a394d8f72868f9104a7099f31 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Sun, 9 Mar 2014 07:45:18 +0100
-Subject: [PATCH 2/2] unused variables
-
----
- classes/pool.h | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/classes/pool.h b/classes/pool.h
-index 144f717..d7e2f0d 100644
---- a/classes/pool.h
-+++ b/classes/pool.h
-@@ -278,7 +278,6 @@ static inline int pool_collect_function(void *bucket, void *argument TSRMLS_DC)
- zval **task = (zval**) bucket;
- pool_call_t *call = (pool_call_t*) argument;
- zval *remove = NULL;
-- zend_ulong index = 0L;
- int result = ZEND_HASH_APPLY_KEEP;
-
- call->fci.retval_ptr_ptr = &remove;
-@@ -320,7 +319,6 @@ PHP_METHOD(Pool, collect) {
- work = zend_read_property(Z_OBJCE_P(getThis()), getThis(), ZEND_STRL("work"), 1 TSRMLS_CC);
-
- if (Z_TYPE_P(work) == IS_ARRAY && zend_hash_num_elements(Z_ARRVAL_P(work))) {
-- zval **task = NULL;
- pool_call_t call;
-
- call.fci = fci;
---
-1.8.3.1
-