summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-09-24 20:16:50 +0200
committerRemi Collet <fedora@famillecollet.com>2014-09-24 20:16:50 +0200
commitda91c5d4e2752086f57b56a2d05aba1a03c8fd1f (patch)
tree6e8faedc7c1ee8c6d7e466a23815059f7e2fbe4e
parentdc45f727aaaba7d699f0a9307913af34892f67e8 (diff)
php-pecl-pthreads: 2.0.9 (stable)
-rw-r--r--REFLECTION57
-rw-r--r--php-pecl-pthreads.spec8
2 files changed, 57 insertions, 8 deletions
diff --git a/REFLECTION b/REFLECTION
index 1898cbb..f39ced8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 pthreads version 2.0.8 ] {
+Extension [ <persistent> extension #124 pthreads version 2.0.9 ] {
- Constants [10] {
Constant [ integer PTHREADS_INHERIT_ALL ] { 1118481 }
@@ -22,13 +22,22 @@ Extension [ <persistent> extension #122 pthreads version 2.0.8 ] {
- Static properties [0] {
}
- - Static methods [1] {
+ - Static methods [2] {
Method [ <internal:pthreads> static public method extend ] {
- Parameters [1] {
Parameter #0 [ <required> $class ]
}
}
+
+ Method [ <internal:pthreads> static public method from ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Closure $run ]
+ Parameter #1 [ <optional> Closure or NULL $construct ]
+ Parameter #2 [ <optional> $args ]
+ }
+ }
}
- Properties [0] {
@@ -141,13 +150,22 @@ Extension [ <persistent> extension #122 pthreads version 2.0.8 ] {
- Static properties [0] {
}
- - Static methods [1] {
+ - Static methods [2] {
Method [ <internal:pthreads> static public method extend ] {
- Parameters [1] {
Parameter #0 [ <required> $class ]
}
}
+
+ Method [ <internal:pthreads> static public method from ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Closure $run ]
+ Parameter #1 [ <optional> Closure or NULL $construct ]
+ Parameter #2 [ <optional> $args ]
+ }
+ }
}
- Properties [0] {
@@ -260,7 +278,7 @@ Extension [ <persistent> extension #122 pthreads version 2.0.8 ] {
- Static properties [0] {
}
- - Static methods [4] {
+ - Static methods [5] {
Method [ <internal:pthreads> static public method getCurrentThreadId ] {
- Parameters [0] {
@@ -287,6 +305,15 @@ Extension [ <persistent> extension #122 pthreads version 2.0.8 ] {
Parameter #0 [ <required> $class ]
}
}
+
+ Method [ <internal:pthreads, inherits Threaded> static public method from ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Closure $run ]
+ Parameter #1 [ <optional> Closure or NULL $construct ]
+ Parameter #2 [ <optional> $args ]
+ }
+ }
}
- Properties [0] {
@@ -448,7 +475,7 @@ Extension [ <persistent> extension #122 pthreads version 2.0.8 ] {
- Static properties [0] {
}
- - Static methods [4] {
+ - Static methods [5] {
Method [ <internal:pthreads, inherits Thread> static public method getCurrentThreadId ] {
- Parameters [0] {
@@ -475,6 +502,15 @@ Extension [ <persistent> extension #122 pthreads version 2.0.8 ] {
Parameter #0 [ <required> $class ]
}
}
+
+ Method [ <internal:pthreads, inherits Threaded> static public method from ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Closure $run ]
+ Parameter #1 [ <optional> Closure or NULL $construct ]
+ Parameter #2 [ <optional> $args ]
+ }
+ }
}
- Properties [0] {
@@ -790,13 +826,22 @@ Extension [ <persistent> extension #122 pthreads version 2.0.8 ] {
- Static properties [0] {
}
- - Static methods [1] {
+ - Static methods [2] {
Method [ <internal:pthreads, inherits Threaded> static public method extend ] {
- Parameters [1] {
Parameter #0 [ <required> $class ]
}
}
+
+ Method [ <internal:pthreads, inherits Threaded> static public method from ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Closure $run ]
+ Parameter #1 [ <optional> Closure or NULL $construct ]
+ Parameter #2 [ <optional> $args ]
+ }
+ }
}
- Properties [1] {
diff --git a/php-pecl-pthreads.spec b/php-pecl-pthreads.spec
index 7028787..ab48092 100644
--- a/php-pecl-pthreads.spec
+++ b/php-pecl-pthreads.spec
@@ -20,7 +20,7 @@
Summary: Threading API
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 2.0.8
+Version: 2.0.9
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
@@ -35,6 +35,7 @@ Requires(post): %{__pecl}
Requires(postun): %{__pecl}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -166,8 +167,11 @@ rm -rf %{buildroot}
%changelog
+* Wed Sep 24 2014 Remi Collet <remi@fedoraproject.org> - 2.0.9-1
+- Update to 2.0.9 (stable)
+
* Mon Sep 15 2014 Remi Collet <remi@fedoraproject.org> - 2.0.8-1
-- Update to 2.0.8
+- Update to 2.0.8 (stable)
* Sun May 11 2014 Remi Collet <remi@fedoraproject.org> - 2.0.7-1
- Update to 2.0.7 (stable)