summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-09-15 07:49:38 +0200
committerRemi Collet <fedora@famillecollet.com>2014-09-15 07:49:38 +0200
commit7b0768d2bbd8804414122567e941e9186e4d692d (patch)
tree54155f57618aea6463ecd80fadb80c1670b2ad97
parent672f64c2a9ccb7b86bb401f70c083faec9b9090c (diff)
php-pecl-pthreads: 2.0.8
-rw-r--r--REFLECTION170
-rw-r--r--php-pecl-pthreads.spec34
2 files changed, 184 insertions, 20 deletions
diff --git a/REFLECTION b/REFLECTION
index 902844d..1898cbb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #118 pthreads version 2.0.7 ] {
+Extension [ <persistent> extension #122 pthreads version 2.0.8 ] {
- Constants [10] {
Constant [ integer PTHREADS_INHERIT_ALL ] { 1118481 }
@@ -13,7 +13,7 @@ Extension [ <persistent> extension #118 pthreads version 2.0.7 ] {
Constant [ integer PTHREADS_ALLOW_GLOBALS ] { 16777216 }
}
- - Classes [7] {
+ - Classes [8] {
Class [ <internal:pthreads> <iterateable> class Threaded implements Traversable, Countable ] {
- Constants [0] {
@@ -22,7 +22,13 @@ Extension [ <persistent> extension #118 pthreads version 2.0.7 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:pthreads> static public method extend ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $class ]
+ }
+ }
}
- Properties [0] {
@@ -135,7 +141,13 @@ Extension [ <persistent> extension #118 pthreads version 2.0.7 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:pthreads> static public method extend ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $class ]
+ }
+ }
}
- Properties [0] {
@@ -248,7 +260,7 @@ Extension [ <persistent> extension #118 pthreads version 2.0.7 ] {
- Static properties [0] {
}
- - Static methods [3] {
+ - Static methods [4] {
Method [ <internal:pthreads> static public method getCurrentThreadId ] {
- Parameters [0] {
@@ -268,6 +280,13 @@ Extension [ <persistent> extension #118 pthreads version 2.0.7 ] {
Parameter #1 [ <optional> $args ]
}
}
+
+ Method [ <internal:pthreads, inherits Threaded> static public method extend ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $class ]
+ }
+ }
}
- Properties [0] {
@@ -429,7 +448,7 @@ Extension [ <persistent> extension #118 pthreads version 2.0.7 ] {
- Static properties [0] {
}
- - Static methods [3] {
+ - Static methods [4] {
Method [ <internal:pthreads, inherits Thread> static public method getCurrentThreadId ] {
- Parameters [0] {
@@ -449,6 +468,13 @@ Extension [ <persistent> extension #118 pthreads version 2.0.7 ] {
Parameter #1 [ <optional> $args ]
}
}
+
+ Method [ <internal:pthreads, inherits Threaded> static public method extend ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $class ]
+ }
+ }
}
- Properties [0] {
@@ -756,6 +782,138 @@ Extension [ <persistent> extension #118 pthreads version 2.0.7 ] {
}
}
+ Class [ <internal:pthreads> <iterateable> class Collectable extends Threaded implements Countable, Traversable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:pthreads, inherits Threaded> static public method extend ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $class ]
+ }
+ }
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $garbage ]
+ }
+
+ - Methods [17] {
+ Method [ <internal:pthreads> public method isGarbage ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads> public method setGarbage ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method run ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method wait ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method notify ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method isRunning ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method isWaiting ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method isTerminated ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method getTerminationInfo ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method synchronized ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $function ]
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method lock ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method unlock ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method merge ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $from ]
+ Parameter #1 [ <optional> $overwrite ]
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method shift ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method chunk ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $size ]
+ Parameter #1 [ <optional> $preserve ]
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded> public method pop ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pthreads, inherits Threaded, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
Class [ <internal:pthreads> class Pool ] {
- Constants [0] {
diff --git a/php-pecl-pthreads.spec b/php-pecl-pthreads.spec
index 99fb02b..9c417cf 100644
--- a/php-pecl-pthreads.spec
+++ b/php-pecl-pthreads.spec
@@ -20,7 +20,7 @@
Summary: Threading API
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 2.0.7
+Version: 2.0.8
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
@@ -41,16 +41,19 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?vendor}" == "Remi Collet"
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name}
-Obsoletes: php53u-pecl-%{pecl_name}
-Obsoletes: php54-pecl-%{pecl_name}
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name}
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name}
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -66,12 +69,16 @@ A compatible Threading API for PHP5.3+
This extension is only available for PHP in ZTS mode.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+
%prep
%setup -q -c
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' -i package.xml
+
cd %{pecl_name}-%{version}
-sed -e '/PHP_PTHREADS_VERSION/s/2.0.8/%{version}/' -i php_pthreads.h
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PTHREADS_VERSION/{s/.* "//;s/".*$//;p}' php_pthreads.h)
@@ -108,12 +115,8 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-# Test & Documentation
+# Documentation
cd %{pecl_name}-%{version}
-for i in $(grep 'role="test"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
-do sed -e 's/\r//' -i $i
- install -Dpm 644 $i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
-done
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do sed -e 's/\r//' -i $i
install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
@@ -152,8 +155,8 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
+%{?_licensedir:%license %{pecl_name}-%{version}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
-%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_ztsinidir}/%{ini_name}
@@ -161,6 +164,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Sep 15 2014 Remi Collet <remi@fedoraproject.org> - 2.0.8-1
+- Update to 2.0.8
+
* Sun May 11 2014 Remi Collet <remi@fedoraproject.org> - 2.0.7-1
- Update to 2.0.7 (stable)