summaryrefslogtreecommitdiffstats
path: root/php-pecl-psr.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-psr.spec')
-rw-r--r--php-pecl-psr.spec14
1 files changed, 6 insertions, 8 deletions
diff --git a/php-pecl-psr.spec b/php-pecl-psr.spec
index d9cb3b1..e552efe 100644
--- a/php-pecl-psr.spec
+++ b/php-pecl-psr.spec
@@ -19,20 +19,17 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{!?_without_tests:1}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.0.0
+%global upstream_version 1.0.1
#global upstream_prever RC4
Summary: PSR interfaces
Name: %{?sub_prefix}php-pecl-psr
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: BSD
URL: https://pecl.php.net/package/psr
-Patch0: https://github.com/jbboehr/php-psr/commit/87855e941d39fc9ebcee3a84f0f73ce4103d236d.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/jbboehr/php-psr/pull/77.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
@@ -106,9 +103,6 @@ mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1 -b .up
-%patch1 -p1 -b .pr77
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PSR_VERSION/{s/.* "//;s/".*$//;p}' php_psr.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -254,6 +248,10 @@ fi
%changelog
+* Fri Nov 13 2020 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- update to 1.0.1
+- drop patch merged upstream
+
* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 1.0.0-5
- rebuild for PHP 8.0.0RC1