summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-09-11 07:02:00 +0200
committerRemi Collet <remi@remirepo.net>2018-09-11 07:02:00 +0200
commitd2a9a914c10c1380453de940bdbee53b93cea557 (patch)
treed82ce9a62f555d882d01257a4d64d4a53818286d
parentb5a7cbadbfa89b0b23210e3ced7b537c0302123d (diff)
v0.5.0
-rw-r--r--PHPINFO15
-rw-r--r--REFLECTION179
-rw-r--r--php-pecl-psr.spec7
3 files changed, 197 insertions, 4 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..fa12617
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,15 @@
+
+psr
+
+Version => 0.5.0
+Released => 2018-09-10
+Authors => John Boehr <jbboehr@gmail.com> (lead)
+PSR-3 Log Version => 1.0.0
+PSR-6 Cache Version => 1.0.0
+PSR-7 Http Message Version => 1.0.0
+PSR-11 Container Version => 1.0.0
+PSR-13 Link Version => 1.0.0
+PSR-15 HTTP Handlers (Server Handler) => 1.0.0
+PSR-15 HTTP Handlers (Middleware) => 1.0.0
+PSR-16 Simple Cache Version => 1.0.0
+PSR-17 HTTP Factories => 1.0.0
diff --git a/REFLECTION b/REFLECTION
index a88e44f..b20dc00 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,10 +1,10 @@
-Extension [ <persistent> extension #123 psr version 0.4.0 ] {
+Extension [ <persistent> extension #126 psr version 0.5.0 ] {
- Dependencies {
Dependency [ spl (Required) ]
}
- - Classes [31] {
+ - Classes [37] {
Interface [ <internal:psr> interface Psr\Cache\CacheException ] {
- Constants [0] {
@@ -1819,6 +1819,181 @@ Extension [ <persistent> extension #123 psr version 0.4.0 ] {
}
}
}
+
+ Interface [ <internal:psr> interface Psr\Http\Message\RequestFactoryInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:psr> abstract public method createRequest ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $method ]
+ Parameter #1 [ <required> $uri ]
+ }
+ - Return [ Psr\Http\Message\RequestInterface ]
+ }
+ }
+ }
+
+ Interface [ <internal:psr> interface Psr\Http\Message\ResponseFactoryInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:psr> abstract public method createResponse ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> integer $code ]
+ Parameter #1 [ <optional> string $reasonPhrase ]
+ }
+ - Return [ Psr\Http\Message\ResponseInterface ]
+ }
+ }
+ }
+
+ Interface [ <internal:psr> interface Psr\Http\Message\ServerRequestFactoryInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:psr> abstract public method createServerRequest ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $method ]
+ Parameter #1 [ <required> $uri ]
+ Parameter #2 [ <optional> array $serverParams ]
+ }
+ - Return [ Psr\Http\Message\ServerRequestInterface ]
+ }
+ }
+ }
+
+ Interface [ <internal:psr> interface Psr\Http\Message\StreamFactoryInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:psr> abstract public method createStream ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> string $content ]
+ }
+ - Return [ Psr\Http\Message\StreamInterface ]
+ }
+
+ Method [ <internal:psr> abstract public method createStreamFromFile ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $filename ]
+ Parameter #1 [ <optional> string $mode ]
+ }
+ - Return [ Psr\Http\Message\StreamInterface ]
+ }
+
+ Method [ <internal:psr> abstract public method createStreamFromResource ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $resouce ]
+ }
+ - Return [ Psr\Http\Message\StreamInterface ]
+ }
+ }
+ }
+
+ Interface [ <internal:psr> interface Psr\Http\Message\UploadedFileFactoryInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:psr> abstract public method createUploadedFile ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> Psr\Http\Message\StreamInterface $stream ]
+ Parameter #1 [ <optional> integer or NULL $size ]
+ Parameter #2 [ <optional> integer $error ]
+ Parameter #3 [ <optional> string or NULL $clientFilename ]
+ Parameter #4 [ <optional> string or NULL $clientMediaType ]
+ }
+ - Return [ Psr\Http\Message\UploadedFileInterface ]
+ }
+ }
+ }
+
+ Interface [ <internal:psr> interface Psr\Http\Message\UriFactoryInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:psr> abstract public method createUri ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> string $uri ]
+ }
+ - Return [ Psr\Http\Message\UriInterface ]
+ }
+ }
+ }
}
}
diff --git a/php-pecl-psr.spec b/php-pecl-psr.spec
index c6c99cf..04bb517 100644
--- a/php-pecl-psr.spec
+++ b/php-pecl-psr.spec
@@ -23,13 +23,13 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 0.4.0
+%global upstream_version 0.5.0
#global upstream_prever RC4
Summary: PSR interfaces
Name: %{?sub_prefix}php-pecl-psr
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: BSD
URL: http://pecl.php.net/package/psr
@@ -258,6 +258,9 @@ fi
%changelog
+* Tue Sep 11 2018 Remi Collet <remi@remirepo.net> - 0.5.0-1
+- update to 0.5.0
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 0.4.0-4
- rebuild for 7.3.0beta2 new ABI