summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-09 08:41:06 +0100
committerRemi Collet <remi@remirepo.net>2018-02-09 08:41:06 +0100
commitce84d69b14680f731fe3bd58c5288377b2371b25 (patch)
tree8b3c648404095507cb492f6b01030c2e806f74b3
parent5dda11dfc98bbc0d27bddf75182a54fc72ec3057 (diff)
v0.3.0 (stable)
-rw-r--r--REFLECTION18
-rw-r--r--php-pecl-psr.spec13
2 files changed, 18 insertions, 13 deletions
diff --git a/REFLECTION b/REFLECTION
index 82690a9..4d76703 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #118 psr version 0.3.0RC4 ] {
+Extension [ <persistent> extension #123 psr version 0.3.0 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -1224,14 +1224,14 @@ Extension [ <persistent> extension #118 psr version 0.3.0RC4 ] {
Class [ <internal:psr> class Psr\Log\LogLevel ] {
- Constants [8] {
- Constant [ string EMERGENCY ] { emergency }
- Constant [ string ALERT ] { alert }
- Constant [ string CRITICAL ] { critical }
- Constant [ string ERROR ] { error }
- Constant [ string WARNING ] { warning }
- Constant [ string NOTICE ] { notice }
- Constant [ string INFO ] { info }
- Constant [ string DEBUG ] { debug }
+ Constant [ public string EMERGENCY ] { emergency }
+ Constant [ public string ALERT ] { alert }
+ Constant [ public string CRITICAL ] { critical }
+ Constant [ public string ERROR ] { error }
+ Constant [ public string WARNING ] { warning }
+ Constant [ public string NOTICE ] { notice }
+ Constant [ public string INFO ] { info }
+ Constant [ public string DEBUG ] { debug }
}
- Static properties [0] {
diff --git a/php-pecl-psr.spec b/php-pecl-psr.spec
index ce8ef69..6f0dd18 100644
--- a/php-pecl-psr.spec
+++ b/php-pecl-psr.spec
@@ -1,11 +1,15 @@
# remirepo spec file for php-pecl-psr
#
-# Copyright (c) 2017 Remi Collet
+# Copyright (c) 2017-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-pecl-psr
@@ -20,7 +24,7 @@
%global ini_name 40-%{pecl_name}.ini
%endif
%global upstream_version 0.3.0
-%global upstream_prever RC4
+#global upstream_prever RC4
Summary: PSR interfaces
Name: %{?sub_prefix}php-pecl-psr
@@ -28,7 +32,6 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
License: PHP
-Group: Development/Languages
URL: http://pecl.php.net/package/psr
BuildRequires: %{?scl_prefix}php-devel
@@ -85,7 +88,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%package devel
Summary: %{name} developer files (header)
-Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{?scl_prefix}php-devel%{?_isa}
%if "%{?scl_prefix}" != "%{?sub_prefix}"
@@ -251,6 +253,9 @@ fi
%changelog
+* Fri Feb 9 2018 Remi Collet <remi@remirepo.net> - 0.3.0-1
+- update to 0.3.0 (stable)
+
* Sat Aug 12 2017 Remi Collet <remi@remirepo.net> - 0.3.0~RC4-1
- update to 0.3.0RC4