summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-12 07:57:45 +0200
committerRemi Collet <remi@remirepo.net>2021-04-12 07:57:45 +0200
commitbffc743d0162f1eba12c87e0579cb98fb4ef8dd9 (patch)
treed5260a1e5728847817bcf07fd0530db0e00de0b5
parent4fc1b754fd11185dd0f4a9faf04234645a10a882 (diff)
update to 1.1.0
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION6
-rw-r--r--php-pecl-psr.spec21
3 files changed, 13 insertions, 20 deletions
diff --git a/PHPINFO b/PHPINFO
index cfa825c..71c5bbb 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,13 +1,13 @@
psr
-Version => 1.0.1
-Released => 2020-11-12
+Version => 1.1.0
+Released => 2021-04-10
Authors => John Boehr <jbboehr@gmail.com> (lead)
PSR-3 Log Version => 1.0.0
PSR-6 Cache Version => 1.0.0
PSR-7 Http Message Version => 1.0.0
-PSR-11 Container Version => 1.0.0
+PSR-11 Container Version => 1.1.1
PSR-13 Link Version => 1.0.0
PSR-14 Event Dispatcher => 1.0.0
PSR-15 HTTP Handlers (Server Handler) => 1.0.0
diff --git a/REFLECTION b/REFLECTION
index 8aee883..435fc0a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #94 psr version 1.0.1 ] {
+Extension [ <persistent> extension #95 psr version 1.1.0 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -211,14 +211,14 @@ Extension [ <persistent> extension #94 psr version 1.0.1 ] {
Method [ <internal:psr> abstract public method get ] {
- Parameters [1] {
- Parameter #0 [ <required> $id ]
+ Parameter #0 [ <required> string $id ]
}
}
Method [ <internal:psr> abstract public method has ] {
- Parameters [1] {
- Parameter #0 [ <required> $id ]
+ Parameter #0 [ <required> string $id ]
}
}
}
diff --git a/php-pecl-psr.spec b/php-pecl-psr.spec
index e552efe..4ef50b3 100644
--- a/php-pecl-psr.spec
+++ b/php-pecl-psr.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-psr
#
-# Copyright (c) 2017-2020 Remi Collet
+# Copyright (c) 2017-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -19,7 +19,7 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{!?_without_tests:1}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.0.1
+%global upstream_version 1.1.0
#global upstream_prever RC4
Summary: PSR interfaces
@@ -30,6 +30,7 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstr
License: BSD
URL: https://pecl.php.net/package/psr
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
@@ -49,29 +50,18 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{relea
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared object
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
This extension provides the accepted PSR interfaces,
@@ -104,7 +94,7 @@ mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
cd NTS
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_PSR_VERSION/{s/.* "//;s/".*$//;p}' php_psr.h)
+extver=$(sed -n '/#define PHP_PSR_VERSION /{s/.* "//;s/".*$//;p}' php_psr.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
@@ -248,6 +238,9 @@ fi
%changelog
+* Mon Apr 12 2021 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
* Fri Nov 13 2020 Remi Collet <remi@remirepo.net> - 1.0.1-1
- update to 1.0.1
- drop patch merged upstream