summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-13 08:03:26 +0100
committerRemi Collet <remi@remirepo.net>2018-11-13 08:03:26 +0100
commit5a03c0adc763cde33657e842a50d134a3700a461 (patch)
tree423824c380f7a4d3c0c68582af3bebbc548de044
parentf1feae7322bee4e523159ac8dc3dcb38a14c1616 (diff)
update to 0.6.1 (no change)
-rw-r--r--55.patch64
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-psr.spec9
4 files changed, 7 insertions, 72 deletions
diff --git a/55.patch b/55.patch
deleted file mode 100644
index 4e8f03c..0000000
--- a/55.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From 0bb83c7e86e37667a643d581c2260e6a94b7585d Mon Sep 17 00:00:00 2001
-From: FlyingHail <flyinghail@msn.com>
-Date: Mon, 12 Nov 2018 17:00:19 +0800
-Subject: [PATCH] Fix: skip PSR-18 tests when PHP < 7
-
----
- tests/PsrHttpClientClientExceptionInterface.phpt | 2 +-
- tests/PsrHttpClientClientInterface.phpt | 2 +-
- tests/PsrHttpClientNetworkExceptionInterface.phpt | 2 +-
- tests/PsrHttpClientRequestExceptionInterface.phpt | 2 +-
- 4 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/tests/PsrHttpClientClientExceptionInterface.phpt b/tests/PsrHttpClientClientExceptionInterface.phpt
-index a02da4e..b270240 100644
---- a/tests/PsrHttpClientClientExceptionInterface.phpt
-+++ b/tests/PsrHttpClientClientExceptionInterface.phpt
-@@ -1,7 +1,7 @@
- --TEST--
- Psr\Http\Client\ClientExceptionInterface
- --SKIPIF--
--<?php if( !extension_loaded('psr') ) die('skip '); ?>
-+<?php if( !extension_loaded('psr') || PHP_MAJOR_VERSION < 7 ) die('skip '); ?>
- --FILE--
- <?php
- use Psr\Http\Client\ClientExceptionInterface;
-diff --git a/tests/PsrHttpClientClientInterface.phpt b/tests/PsrHttpClientClientInterface.phpt
-index 6aebb2a..ae12835 100644
---- a/tests/PsrHttpClientClientInterface.phpt
-+++ b/tests/PsrHttpClientClientInterface.phpt
-@@ -1,7 +1,7 @@
- --TEST--
- Psr\Http\Client\ClientInterface
- --SKIPIF--
--<?php if( !extension_loaded('psr') ) die('skip '); ?>
-+<?php if( !extension_loaded('psr') || PHP_MAJOR_VERSION < 7 ) die('skip '); ?>
- --FILE--
- <?php
- include __DIR__ . '/SampleMessage.inc';
-diff --git a/tests/PsrHttpClientNetworkExceptionInterface.phpt b/tests/PsrHttpClientNetworkExceptionInterface.phpt
-index 8ef9619..83803d2 100644
---- a/tests/PsrHttpClientNetworkExceptionInterface.phpt
-+++ b/tests/PsrHttpClientNetworkExceptionInterface.phpt
-@@ -1,7 +1,7 @@
- --TEST--
- Psr\Http\Client\NetworkExceptionInterface
- --SKIPIF--
--<?php if( !extension_loaded('psr') ) die('skip '); ?>
-+<?php if( !extension_loaded('psr') || PHP_MAJOR_VERSION < 7 ) die('skip '); ?>
- --FILE--
- <?php
- use Psr\Http\Message\RequestInterface;
-diff --git a/tests/PsrHttpClientRequestExceptionInterface.phpt b/tests/PsrHttpClientRequestExceptionInterface.phpt
-index a522466..f643b89 100644
---- a/tests/PsrHttpClientRequestExceptionInterface.phpt
-+++ b/tests/PsrHttpClientRequestExceptionInterface.phpt
-@@ -1,7 +1,7 @@
- --TEST--
- Psr\Http\Client\RequestExceptionInterface
- --SKIPIF--
--<?php if( !extension_loaded('psr') ) die('skip '); ?>
-+<?php if( !extension_loaded('psr') || PHP_MAJOR_VERSION < 7 ) die('skip '); ?>
- --FILE--
- <?php
- use Psr\Http\Message\RequestInterface;
diff --git a/PHPINFO b/PHPINFO
index 4026d54..99885f0 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,8 +1,8 @@
psr
-Version => 0.6.0
-Released => 2018-11-11
+Version => 0.6.1
+Released => 2018-11-13
Authors => John Boehr <jbboehr@gmail.com> (lead)
PSR-3 Log Version => 1.0.0
PSR-6 Cache Version => 1.0.0
diff --git a/REFLECTION b/REFLECTION
index 136d42f..e757e4c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #128 psr version 0.6.0 ] {
+Extension [ <persistent> extension #129 psr version 0.6.1 ] {
- Dependencies {
Dependency [ spl (Required) ]
diff --git a/php-pecl-psr.spec b/php-pecl-psr.spec
index a264282..1f089c2 100644
--- a/php-pecl-psr.spec
+++ b/php-pecl-psr.spec
@@ -19,7 +19,7 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{!?_without_tests:1}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.6.0
+%global upstream_version 0.6.1
#global upstream_prever RC4
Summary: PSR interfaces
@@ -30,8 +30,6 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstre
License: BSD
URL: http://pecl.php.net/package/psr
-Patch0: https://patch-diff.githubusercontent.com/raw/jbboehr/php-psr/pull/55.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 5.6
BuildRequires: %{?scl_prefix}php-pear
@@ -108,8 +106,6 @@ mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1 -b .pr55
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PSR_VERSION/{s/.* "//;s/".*$//;p}' php_psr.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -255,6 +251,9 @@ fi
%changelog
+* Tue Nov 13 2018 Remi Collet <remi@remirepo.net> - 0.6.1-1
+- update to 0.6.1 (no change)
+
* Mon Nov 12 2018 Remi Collet <remi@remirepo.net> - 0.6.0-1
- update to 0.6.0
- raise dependency on PHP 5.6