summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-04-10 08:43:00 +0200
committerRemi Collet <remi@php.net>2025-04-10 08:43:00 +0200
commitc1e129a3837fea85ef6d197e61536c812b0dc860 (patch)
treeb162f32c57f5c5d2183a9a4f6f52d219181f4f65
parent95169fc91fd0f4ca5cc7ba859556f1648d8ab6f6 (diff)
cleanup for Fedora
-rw-r--r--php-pecl-pspell.spec97
1 files changed, 28 insertions, 69 deletions
diff --git a/php-pecl-pspell.spec b/php-pecl-pspell.spec
index e5e4dbe..cf5bbaa 100644
--- a/php-pecl-pspell.spec
+++ b/php-pecl-pspell.spec
@@ -1,3 +1,6 @@
+# Fedora spec file for php-pecl-pspell
+# Without SCL compatibility from:
+#
# remirepo spec file for php-pecl-pspell
#
# SPDX-FileCopyrightText: Copyright 2023-2025 Remi Collet
@@ -7,56 +10,53 @@
# Please, preserve the changelog entries
#
-%{?scl:%scl_package php-pecl-pspell}
-
%bcond_without tests
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name pspell
%global ini_name 30-%{pecl_name}.ini
%global sources %{pecl_name}-%{version}
-%global _configure ../%{sources}/configure
Summary: Spell checker extension
-Name: %{?scl_prefix}php-pecl-pspell
+Name: php-pecl-%{pecl_name}
Version: 1.0.1
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/pspell
Source0: https://pecl.php.net/get/%{sources}.tgz
+ExcludeArch: %{ix86}
+
BuildRequires: make
-BuildRequires: %{?dtsprefix}gcc
+BuildRequires: gcc
# 8.1+ is supported by upstream but part of php-src until 8.4
-BuildRequires: %{?scl_prefix}php-devel >= 8.4
+BuildRequires: php-devel >= 8.4
BuildRequires: aspell-devel >= 0.50.0
-BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: php-pear
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+# Package removed from php-src in 8.4
# Set epoch so provides is > 0:8.4
-Obsoletes: %{?scl_prefix}php-%{pecl_name} < 8.4
-Provides: %{?scl_prefix}php-%{pecl_name} = 1:%{version}-%{release}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = 1:%{version}-%{release}
+Obsoletes: php-%{pecl_name} < 8.4
+Provides: php-%{pecl_name} = 1:%{version}-%{release}
+Provides: php-%{pecl_name}%{?_isa} = 1:%{version}-%{release}
%description
This extension allows you to check the spelling of a word and offer suggestions,
using GNU Aspell library and dictionaries.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
-
%prep
%setup -c -q
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd %{sources}
@@ -74,52 +74,28 @@ cat >%{ini_name} << 'EOF'
extension=%{pecl_name}
EOF
-mkdir NTS
-%if %{with_zts}
-mkdir ZTS
-%endif
-
%build
-%{?dtsenable}
-
cd %{sources}
%{__phpize}
sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
-cd ../NTS
%configure \
--with-pspell \
--with-php-config=%{__phpconfig}
%make_build
-%if %{with_zts}
-cd ../ZTS
-%configure \
- --with-pspell \
- --with-php-config=%{__ztsphpconfig}
-
-%make_build
-%endif
-
%install
-%{?dtsenable}
-
-%make_install -C NTS
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+cd %{sources}
+%make_install
+install -D -m 644 ../%{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-%make_install -C ZTS
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
+install -D -m 644 ../package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
# Documentation
-cd %{sources}
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -127,7 +103,7 @@ done
%check
cd %{sources}
-: minimal load test of NTS extension
+: minimal load test
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
@@ -135,26 +111,11 @@ cd %{sources}
OPT="%{?_smp_mflags} -q --show-diff"
%if %{with tests}
-: upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
+: upstream test suite
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
%{__php} -n run-tests.php $OPT
%endif
-%if %{with_zts}
-: minimal load test of ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep '^%{pecl_name}$'
-
-%if %{with tests}
-: upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-%{__ztsphp} -n run-tests.php $OPT
-%endif
-%endif
-
%files
%license %{sources}/LICENSE
@@ -164,13 +125,11 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
%changelog
+* Thu Apr 10 2025 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- cleanup for Fedora
+
* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 1.0.1-2
- rebuild for 8.4.0RC1